Jump to content

Include nanospell in TinyMCE


Recommended Posts

I was trying to activate the spell checker in TinyMCE (PW 2.4) as I read it isn't available anymore, because Google put it down.

Now I tried for almost 2 hours to get nanospell (http://tinymcespellcheck.com) activated without luck.

I downloaded the plugin, put it into /site/tinymce/plugins/nanospell and copied that path into the Third-party plugins field for my body field. But whenever I save it, the field doesn't load. And I can't get this working.

nanospell itself works fine on my server, I tried their example that comes with the plugin. 

Where do I have to put those 4 lines:

	external_plugins: {"nanospell": "/site/tinymce/plugins/nanospell/plugin.js"},
	nanospell_server: "php",
        nanospell_dictionary: "en,de" 
Link to comment
Share on other sites

Details tab of the RTE field > TinMCE Advanced Config Options > Third Party Plugins

That's the place where I have put in nanospell's  path. I don't think all the init() comes there (tried it, but doesn't work either).

Link to comment
Share on other sites

The TinyMCE Spell checker I have user I placed in:


Then in the Third Party Plugins bit I put:

spellchecker : /site/tinymce/myplugins/spellchecker

And then in Buttons 1 I added spellchecker

I think it was this one:


Just as a thought, you may be able to do the additional setting in config.php within the nanospell plugin folder

Link to comment
Share on other sites

It feels like I tried hundreds of combinations :-)

But, if I insert in third party plugins 

nanospell : /site/tinymce/plugins/nanospell

the body field (TinyMCE editor) won't load at all. The browser console says the editor_plugin.js is missing. If I rename the plugin.js (within the nanospell folder) there is another JS file that is missing, and so on.

The default spellchecker that shipps with TinyMCE works, but it only works if you click the button before you start writing. It doesn't underline words that are already typed as you click the toolbar button.

Link to comment
Share on other sites

Ok, this could be the reason. It seems this one is build for v 4 of TinyMCE. Seems there is no good way to integrate a spell checker into the editor.

Anyway, thanks for your help!!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...