Jump to content

Problems with FieldtypeOptions after Profile Import


Recommended Posts

Installed a older site profile into a fresh new PW master version 3.0.123 and get a problem with fieldtype options field.

Message Process return no content in the backend fieldsetting and pages that use a optionsfield.

On Frontend with debug mode on i get this:

ProcessPageEdit: SQLSTATE[42S02]: Base table or view not found: 1146 Table 'mydbname.fieldtype_options' doesn't exist

#0 W:\laragon\www\12_projectname\wire\modules\Fieldtype\FieldtypeOptions\SelectableOptionManager.php(139): PDOStatement->execute()
#1 W:\laragon\www\12_projectname\wire\modules\Fieldtype\FieldtypeOptions\FieldtypeOptions.module(263): ProcessWire\SelectableOptionManager->getOptions(Object(ProcessWire\Field), Array)
#2 W:\laragon\www\12_projectname\wire\core\Wire.php(389): ProcessWire\FieldtypeOptions->___wakeupValue(Object(ProcessWire\Page), Object(ProcessWire\Field), Array)
#3 W:\laragon\www\12_projectname\wire\core\Wire.php(416): ProcessWire\Wire->_callMethod('___wakeupValue', Array)
#4 W:\laragon\www\12_projectname\wire\core\Page.php(1422): ProcessWire\Wire->_callHookMethod('wakeupValue', Array)
#5 W:\laragon\www\12_projectname\wire\core\Page.php(1150): ProcessWire\Page->getFieldValue('orientat 

Field name was orientation and there is the break on the getFieldValue function?
But in the DB everything is there - are there bigger changes from PW 2.8 to 3.x??
the used field_orientation table and all the other option fields is there, too...

what could here gone wrong on db installation of the site profile or incombatibility from PW 2.x to 3.x?

If there is no fast solution or thing that i've not in mind - How could i setup this Fieldtype new?
Deinstallation/reinstalltion of this core fieldtype is not easy i think?

Best regards mr-fan


Link to comment
Share on other sites

I get this kind of error when...

1) I re-use a laragon www site name. If I ever used site name projectabc, delete it and use it again, I often end in database problems.
So... if you already used it before, try another name.

2) I use protected names. I once had an older profile in which some field names were protected names. One was limit, one was modules and another one I can't remember.
I looked into the install.php or install.sql, tried to find these fields, changed their names to something not-protected and everything worked well.

3) I have cached files in that profile. /site/assets/ has several cache folders and maybe even session folders. I don't know why but my profile had tons of these cached files. I deleted them it worked.


Another thing... in install.php (if I remember correctly) is a flag which enables kind of a debug installations that only checks so you can find errors way easier.

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...