Jump to content

'Unable to move uploaded file to...' error on Fasthosts (but is does upload)


Recommended Posts

Hi folks,

Pulling my hair out on this one!

I've created a client site locally on MAMP then uploaded it to our Media Temple Grid server for client review and for them to upload content. All good. I then transferred it to the client's Fasthosts Ignite server and we get an 'Unable to move file to...' error whenever an admin tries to upload a new image or other file type via any page in admin.

After trawling these forums (always very helpful!) I found various discussions around permissions and checked all files from /site/assets/ and below are 777. I also checked safe mode and Fasthosts insist it's off. 

The really odd thing is the file is actually being uploaded. When I check /site/assets/files/*pageidnumber*/ the file has been moved to the right folder OK. So it looks like it's just the admin side which is not acknowledging the transfer has happened.

Just to check all folders and files were moved OK when the site was moved to the clients Fasthosts server I downloaded the whole site from Fasthosts again and installed it in my local MAMP and all of functioning as expected :-(

So it defnitily looks server related. Unfortunately Fasthosts don't grant edit access to php.ini

So I then tried reviewing phpinfo.php on both servers to try and track down the difference. My MAMP is running Apache but Fasthosts are running Fast CGI so the resulting pages are completely different.

Can anyone point me in the right direction here or have any suggestions?

Many thanks in advance.


Link to comment
Share on other sites

I think this is now fixed.

Following this thread: https://processwire.com/talk/topic/1002-cant-upload-imagefiles-problem/

I created /site/assest/uploads which didn't previously exist and then added this line to /site/config.php immediately below the debug line

$config->uploadTmpDir = dirname(__FILE__) . '/assets/uploads/';

It seems the temp upload directory was either not set or not writable. 

Hope this helps someone.

  • Like 4
Link to comment
Share on other sites

  • 1 year later...

As a follow-up: I had the same problem and tried everything – including the one recommended by prestoav. I am developing 3 sites running on a FastHosts reseller account. All running PW 3.0.42 on php 5.6. One is on an older server and had no problems uploading images. The other two are on their newer 'cluster' servers and those were the sites with problems uploading.

Long story short, the FastHosts support investigated and said that turning debug OFF in the site config file would solve the problem. Sure enough, that's fixed the problem.

I don't know if it is a problem with PW, FastHosts servers or what, but if anyone encounters this problem, it's worth checking your debug setting.

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...