Jump to content

Search the Community

Showing results for tags 'processmodule'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Welcome to ProcessWire
    • News & Announcements
    • Showcase
    • Wishlist & Roadmap
  • Community Support
    • Getting Started
    • Tutorials
    • FAQs
    • General Support
    • API & Templates
    • Modules/Plugins
    • Themes and Profiles
    • Multi-Language Support
    • Security
    • Jobs
  • Off Topic
    • Pub
    • Dev Talk

Product Groups

  • Form Builder
  • ProFields
  • ProCache
  • ProMailer
  • Login Register Pro
  • ProDrafts
  • ListerPro
  • ProDevTools
  • Likes
  • Custom Development

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 2 results

  1. Hello all, I am creating a simple ProcessModule to better understand ProcessWire itself, but have stumbled in my attempts. Here is a sample scenario: I would like the processmodule interface to have two tabs, one for an overview and the second for details. Both tabs contain two comboboxes where the user can select options. A 'refresh' button to update the display with the currently selected options. I will add the form to process the combobox selections when I get the tabs to work (unless this is out of order). I cannot seem to create the two tabs. I have tried the many examples present in the forum comments for similar subjects without success, referenced different source files, such as ProcessPageEdit, etc., a numerous existing module source code. The latest 'simplified' attempt from my most recent forum search results is as follows: ProcessExample.module class ProcessExample extends Process implements Module, ConfigurableModule { ... public static function getModuleInfo() { return array( 'title' => 'Process Example', 'version' => 001, 'summary' => 'Sample Interface.', 'autoload' => false, 'singular' => true, 'permission' => 'page-edit', 'requires' => 'ProcessWire>=3.0.42', //'useNavJSON' => true, //Yes, I tried duplicating processpageedit without success ); } ... public function init() { $this->wire( 'modules' )->get( 'JqueryWireTabs' ); parent::init(); //$this->modules->get( 'JqueryWireTabs' ); // Neither position (before/after init) works. } ... public function ___execute() { $out = ''; $out .= "<div id='{$this->className}-tabs'>"; $out .= " <div id='{$this->className}-tab1'>Tab1</div>"; $out .= " <div id='{$this->className}-tab2'>Tab2</div>"; $out .= "</div>"; return $out; } ProcessExample.js if($("#ProcessExample-tabs").size()) { $("#ProcessExample-tabs").WireTabs({ items: $("#ProcessExample-tab1, #ProcessExample-tab2"), id: 'ProcessExample-tabs', rememberTabs: 1 }); } There are no errors shown in the console, notices (except those darn css map references), or logs when executing the above. The output displays as follows: This is the resulting script references in the <HEAD> section: <script type='text/javascript' src='/example/wire/modules/Jquery/JqueryCore/JqueryCore.js?v=1510330240'></script> <script type='text/javascript' src='/example/wire/modules/Jquery/JqueryUI/JqueryUI.js?v=1510330240'></script> <script type='text/javascript' src='/example/wire/modules/Jquery/JqueryWireTabs/JqueryWireTabs.js?v=1510330240'></script> <script type='text/javascript' src='/example/site/modules/example/ProcessExample.js?v=1-1511168979'></script> <script type='text/javascript' src='/example/wire/modules/Process/ProcessPageSearch/ProcessPageSearch.js?v=106-1510330240'></script> <script type='text/javascript' src='/example/wire/templates-admin/scripts/inputfields.js?v=14k'></script> <script type='text/javascript' src='/example/wire/templates-admin/scripts/main.js?v=14k'></script> <script type='text/javascript' src='/example/wire/modules/AdminTheme/AdminThemeDefault/scripts/main.js?v=14k'></script> <script type='text/javascript' src='/example/wire/modules/Jquery/JqueryUI/panel.js?v=1510330240'></script> <script type='text/javascript' src='/example/wire/modules/System/SystemNotifications/Notifications.js?v=12'></script> Surely I am missing something simple, and hope better trained (and less tunnel vision) eyes can provide insight.
  2. I've created a Process Module, and its execute() function renders the HTML response to an AJAX request. The AJAX request is being made outside of the admin panel, and in all likelihood will be made by "guest" users. Within my ModuleName.info.json file, I have added these lines: "permission": "generate-thumbnails", "permissions": { "generate-thumbnails": "Generate Thumbnails" }, Then within the Admin panel, I gave guests access to run that module. Unless logged in, the response to the AJAX request is always the login form's HTML, rather than the HTML my execute() function creates. So two questions: Is it possible to give non-logged-in users the ability to run that function via the AJAX request, or Is there a better ProcessWire way to create HTML to use as an AJAX response? Thank you!
×
×
  • Create New...