Jump to content

raulyjo

Members
  • Content Count

    10
  • Joined

  • Last visited

Community Reputation

3 Neutral

About raulyjo

  • Rank
    Jr. Member

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. I did the test of the module and --> SUCCESS! SMTP settings appear to work correctly.
  2. Hi, i have a problem with my Wire Mail SMTP Module. Apparently, the form works, but something is wrong with the email, I think, because when you send the email address, there is with a yellow mark. I'm going to show you: And there is my code: <script> app.controller('ContactoCtrl',function($scope, $http){ $scope.page=<?php echo $page->toJSON() ?>; $scope.enviarEmail = function(){ $http.post( '/videsil/pwapi/', { do: 'getEmail', data:{ 'from': $scope.email, 'subject': $scope.subject, 'message': $scope.name + ' te ha enviado este mensaje: ' + $scope.message }}) .success( function (result) { console.log("email enviado", result); $scope.name = null; $scope.email = null; $scope.subject = null; $scope.message = null; }) .error(function(data){ console.log("NO enviado", data) }); } }); </script> <div ng-controller="ContactoCtrl"> <section id="contact"> <div id="map" style="height:650px" data-latitude="39.4576737" data-longitude="-0.3628944,14" ></div> <div class="container-wrapper"> <div class="container"> <div class="row"> <div class="col-sm-4 col-sm-offset-8"> <div class="contact-form"> <h3 class="letravidesil">Contacto</h3> <address> <strong>Videsil S.L.</strong><br> C/ Nino Bravo, 5, 46812 <br> Ayelo de Malferit, Valencia <br> <abbr title="Phone"></abbr> (+34) 96 236 0123 </address> <form id="main-contact-form" name="contact-form" method="post" action="#"> <div class="form-group"> <input type="text" ng-model="name" name="name" class="form-control" placeholder="Nombre y teléfono" required> </div> <div class="form-group"> <input type="email" ng-model="email" name="email" class="form-control" placeholder="Email" required> </div> <div class="form-group"> <input type="text" ng-model="subject" name="subject" class="form-control" placeholder="Asunto" required> </div> <div class="form-group"> <textarea ng-model="message" class="form-control" rows="8" placeholder="Mensaje" required></textarea> </div> <button type="submit" class="btn btn-primary" name="submit" value="Enviar" ng-click="enviarEmail()">Enviar</button> </form> </div> </div> </div> </div> </div> </section><!--/#bottom--> </div> I don't know why is not working, because 6 months ago there was working with the same settings. Help please
  3. I have a init.php which is like my <head> and main.php as my footer, when I have my scripts src. I have also a template called contact.php, when is the map that I want to show and is like this: <script> app.controller('ContactoCtrl',function($scope, $http){ $scope.page=<?php echo $page->toJSON() ?>; $scope.enviarEmail = function(){ $http.post( '/videsil/pwapi/', { do: 'getEmail', data:{ 'from': $scope.email, 'subject': $scope.subject, 'message': $scope.name + ' te ha enviado este mensaje: ' + $scope.message }}) .success( function (result) { console.log("email enviado", result); $scope.name = null; $scope.email = null; $scope.subject = null; $scope.message = null; }) .error(function(data){ console.log("NO enviado", data) }); } }); </script> <div ng-controller="ContactoCtrl"> <section id="contact"> <div id="map" style="height:650px" data-latitude="39.4576737" data-longitude="-0.3628944,14" ></div> <div class="container-wrapper"> <div class="container"> <div class="row"> <div class="col-sm-4 col-sm-offset-8"> <div class="contact-form"> <h3 class="letravidesil">Contacto</h3> <address> <strong>Videsil S.L.</strong><br> C/ Nino Bravo, 5, 46812 <br> Ayelo de Malferit, Valencia <br> <abbr title="Phone"></abbr> (+34) 96 236 0123 </address> <form id="main-contact-form" name="contact-form" method="post" action="#"> <div class="form-group"> <input type="text" ng-model="name" name="name" class="form-control" placeholder="Nombre y teléfono" required> </div> <div class="form-group"> <input type="email" ng-model="email" name="email" class="form-control" placeholder="Email" required> </div> <div class="form-group"> <input type="text" ng-model="subject" name="subject" class="form-control" placeholder="Asunto" required> </div> <div class="form-group"> <textarea ng-model="message" class="form-control" rows="8" placeholder="Mensaje" required></textarea> </div> <button type="submit" class="btn btn-primary" name="submit" value="Enviar" ng-click="enviarEmail()">Enviar</button> </form> </div> </div> </div> </div> </div> </section><!--/#bottom--> </div>
  4. I tried to use the Mapmarker module, but I dont know how to show the map on my website. Im really newbie with processwire but I tried like this: Copy all of the files for this module into /site/modules/FieldtypeMapMarker/ In your admin, go to the Modules screen and "check for new modules." Click install for the Map Marker Fieldtype. In your admin, go to Setup > Fields > Add New Field. Choose MapMarker as the type.If you are not sure what to name your field, simply "map" is a good one! Once created, configure the settings on the input tab. Add your new "map" field to one or more templates, as you would any other field. I made all of this, but then... where I have to put this part? echo $page->map->address; // outputs the address you entered echo $page->map->lat; // outputs the latitude echo $page->map->lng; // outputs the longitude echo $page->map->zoom; // outputs the zoom level Inside of a div? Sorry for my mistakes :S
  5. But where I have to put this code? inside of the html page? By the way, im not using ryan's MapMarker module
  6. Hi guys, I have a new problem with my google maps and I was reading that is because of a new API Key, but im not really good with this theme. I was reading that I have to create a new API key of google maps and insert it on my website, but I dont know where I have to insert (im not really good with Javascript) In my code I have a Javascript doc with this lines : //Google Map var latitude = $('#google-map').data('latitude'); var longitude = $('#google-map').data('longitude'); function initialize_map() { var myLatlng = new google.maps.LatLng(latitude,longitude); var mapOptions = { zoom: 14, scrollwheel: false, center: myLatlng }; var map = new google.maps.Map(document.getElementById('google-map'), mapOptions); var marker = new google.maps.Marker({ position: myLatlng, map: map }); } google.maps.event.addDomListener(window, 'load', initialize_map); And in HTML code, I have this: <section id="contact"> <div id="google-map" style="height:650px" data-latitude="39.4576737" data-longitude="-0.3628944,14"></div> <div class="container-wrapper"> <div class="container"> <div class="row"> <div class="col-sm-4 col-sm-offset-8"> <div class="contact-form"> <h3 class="letravidesil">Contacto</h3> <address> <strong>Videsil S.L.</strong><br> C/ Nino Bravo, 5, 46812 <br> Ayelo de Malferit, Valencia <br> <abbr title="Phone"></abbr> (+34) 96 236 0123 </address> Otherwise, in the console of the browser appear this error --> Google Maps API error: MissingKeyMapError https://developers.google.com/maps/documentation/javascript/error-messages#missing-key-map-error Can anybody helps me? Sorry for my bad english
  7. It works!!!!!! Thank you really much
  8. Hi people. Im just fixing some problems on my domain but I can't solve it. I have a website in a amazon server and when I'm trying to enter in my new domain, it only appears this image I was searching on Internet about how to fix it and a tried this in my server: - I installed Ciberduck - I went home/bitnami/apps/MYWEBSITE/htdocs/site/config.php and modify the last line: $config->httpHosts = array('mywebsite.es', 'www.mywebsite.es'); - I modified a line of a hide doc called . htaccess like this: # RewriteBase / # RewriteBase /mywebsite/ # RewriteBase /~user/ - Then i modified miweb.conf doc in home/bitnami/apps/mywebsite/conf like this: <VirtualHost *:80> ServerAdmin Raul DocumentRoot "/opt/bitnami/apps/mywebsite/htdocs" ServerName mywebsite.es </VirtualHost> <VirtualHost *:80> ServerAdmin Raul DocumentRoot "/opt/bitnami/apps/mywebsite/htdocs" ServerName www.mywebsite.es </VirtualHost> <Directory "/opt/bitnami/apps/mywebsite/htdocs"> Options Indexes MultiViews AllowOverride All <IfVersion < 2.3 > Order allow,deny Allow from all </IfVersion> <IfVersion >= 2.3> Require all granted </IfVersion> </Directory> - And finally I restarted the server with Putty and this command in bitnami/apps/miweb/conf : sudo /opt/bitnami/ctlscript.sh restart apache Sorry for my bad english, I tried to explain best as I can
×
×
  • Create New...