Jump to content

Problem saving pages

Recommended Posts

I'm having frequent problems saving pages in a brand-new ProcessWire site I'm creating.

(I'm using ProcessWire 3.0.227.)

The problem is that I fill out the page, hit either "Publish" or "Save + Keep Unpublished" — and nothing happens.

Specifically: the page isn't saved. And no message is shown.

Looking in the JavaScript console, I see this error:

An invalid form control with name='body' is not focusable.

Looking through the HTML, I do in fact see a control with that name:

<textarea class="FieldtypeTextarea required uk-textarea InputfieldTinyMCEEditor InputfieldTinyMCENormal InputfieldMaxWidth InputfieldTinyMCELoaded" id="Inputfield_body" name="body" rows="15" required="required" aria-hidden="true" style="display: none;"></textarea>

But the error message isn't saying that a control doesn't exist, it's saying that it's "invalid" and/or "not focusable."

I'll keep trying to figure out what's happening, but if you have any ideas, please let me know!

Link to comment
Share on other sites

That error was in Safari. I'm seeing the same error in Chrome. In Firefox, I'm seeing the same error, and it's followed by many more, e.g.:

An invalid form control is not focusable.
The invalid form control with name=‘whats[]’ is not focusable.
The invalid form control with name=‘_whats_add_items’ is not focusable.

So: not a browser-specific issue.

Link to comment
Share on other sites

I logged an issue for this: https://github.com/processwire/processwire-issues/issues/1908

Take another look at the `textarea` element:

<textarea ... name="body" ... required="required" ... style="display: none;"></textarea>

It's marked `required`, but it's also marked `display: none`. TinyMCE fields have a complex structure, and that complex structure is preventing the `required` attribute code from working correctly.

Ultimately, TinyMCE fields shouldn't let users check the "Also use HTML5 "required" attribute?" option.

Link to comment
Share on other sites

On 4/11/2024 at 11:08 PM, Michael Lenaghan said:

OK, I think I found the problem; you can't set "Also use HTML5 "required" attribute?" on a TinyMCE-based `textarea` field. In other words, don't check this box:


To troubleshoot this issue, it's important to first check if there are any errors logged in your server's error logs or in ProcessWire's error log. Additionally, ensure that your file and directory permissions are set correctly, as this could sometimes cause saving issues. If the problem persists, reach out to the support team via the website, their forum or social media. I always do so if can't solve the problems by myself. I adore playing games and casinos online, and it is a bit of bad luck when a bad connection ar any other tech problem interferes with enjoying the process. If you like games and betting too, check out horse racing not on Gamstop review https://notgamstop.com/betting-sites-not-on-gamstop/horse-racing/ and try your luck! Wish you the best in solving the issue.

Thank you for saving my day, I appreciate you.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...