Jump to content

Shared Hosting and Symlinks


Inxentas
 Share

Recommended Posts

Hello there. I have an issue with a PW installation on some crappy shared host. A few days ago the site stopped working. So I checked the error logs, which said:

Option FollowSymlinks not allowed here

And logically, PW's .htaccess file says:

Options +FollowSymLinks

So it appears that FollowSymlinks is suddenly no longer allowed on this server. I rarely have to deal with server settings, but is the impression that PW simply needs FollowSymlinks to be allowed. Is this the case? Would it be valid to state that this server isn't suitable for a PW installation anymore, because the host no longer allows SymLinks? Would that statement be correct?

I've never had the pleasure of a shared host suddenly no longer allowing SymLinks out of the blue, to be fair I am not entirely sure how those work. I can run the site on my local and test servers just fine: it's just this shared host that's been giving me grief for the last few days. The homepage could be reached but every child page just gave me a serverside 404 (not the 404 you'd expect from PW itself).

Link to comment
Share on other sites

Have you tried changing FollowSymlinks to SymLinksifOwnerMatch in .htaccess (it's explained in the comments in section 1. Apache Options)? You should probably even be fine with just commenting out the line in a standard PW setup, so I'd try that first.

  • Like 1
  • Thanks 1
Link to comment
Share on other sites

  • 2 weeks later...

Yes, and that worked perfectly! Thank you @BitPoet.

I was hesitant to change the .htaccess file but truth be told, this is kind of a legacy project, so in the end I did not do much research on what that would affect. Are there any PW related issues I should take into account?

PS. I received a mail asking me to click a "mark as solution" button. I wanted to mark your reply as the solution but I'm not seeing that button. I fear I'm going blind.

Link to comment
Share on other sites

  • 1 year later...
On 11/15/2022 at 8:16 AM, Inxentas said:

Yes, and that worked perfectly! Thank you @BitPoet.

I was hesitant to change the .htaccess file but truth be told, this is kind of a legacy project, so in the end I did not do much research on what that would affect. Are there any PW related issues I should take into account?

PS. I received a mail asking me to click a "mark as solution" button. I wanted to mark your reply as the solution but I'm not seeing that button. I fear I'm going blind.

Hi @Inxentas

I just experienced the same issue. Would this hosting company have a name beginning letter H ?

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...