Jump to content

Error when uploading files containing © symbol in file name

Recommended Posts

A client of me got an error in PW 3.0.98 while uploading images that contain a © in the filename.
Any clues how I could filter this in the backend of PW to avoid this?



Share this post

Link to post
Share on other sites

What kind of error? What did it say?

Just tried to upload files with © in it and... well it worked as expected. The © was translated to c.




In this case I'm using ProcessWire 3.0.123.

Update: tried it on a 3.0.98 now and even there it works without problems.


Share this post

Link to post
Share on other sites

I believe it has something to do with the server.
My local copy of the site (3.0.98) translated the © into a c, too.
There isn’t any explaining error message, just „invalid image“ (see German screenshot).

When I remove the © from the filename it’s uploaded without any error.
I also tried other filenames containing Umlauts like ä or special symbols like @ – this works.
A symbol like the „Registered Mark“ ® produces the same error like the ©.

It’s not a big thing, my client can rename the files, but it would be nice to know why this happens only to this kind of letters.


Bildschirmfoto 2019-06-18 um 12.53.57.png

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...