Jump to content

pagination inside a process module


Recommended Posts

what else can I try? It must be the database. I uninstalled all modules and the file system is like from a new installation. All I did was import the /log/ folder from an older installation so that I'd have enough data to paginate through. That's it but still cannot use the pagination.

Link to comment
Share on other sites

OMG this is so frustrating.

here's some other stuff I tried

uninstall all modules
delete all modules
delete all unused field
delete all unused templates
empty the trash
(actually deleted the modules from the file system first and then under "missing" deleted all modules one by one from the database)
delete the cache table in the database
delete the cache folder in the file system
mess with the .htaccess file
switch the admin theme
turn on and off javascript for this browser
use other browsers

absolutely nothing helps and no error whatsoever.

What else is left to try? What would you do next? uninstall PW start over?

Are there some phpmyadmin settings that I'm not aware of?

thanks for help

Link to comment
Share on other sites

OK I just tried something else… upgrading to dev branch 3.0.207 (newest dev branch), replacing master branch 3.0.200


Now that's not to say there won't be any other issues that I'm not aware of at this point because, you know, it's the dev branch but at least that tells us something, right? Not sure what it tells me but it just seems to be a bug that has been fixed? So when is the next master version coming? Needless to say I would like to avoid using the dev branch for a live site.


  • Like 1
Link to comment
Share on other sites

3 minutes ago, bernhard said:

I'd like to hear the reason for that..

We recommend downloading the dev version if you are using it locally for development, while we recommend downloading the master version if it will be immediately used in a live/production environment (like if you are upgrading an existing installation). It is also generally safe to use the dev version in production after thorough testing in an non-production environment. – https://processwire.com/download/core/

Link to comment
Share on other sites

Thank you all a lot for your efforts, at least I'm not alone here…

One more thing, in the process module, I'm trying to amend the $results->getPaginationString()

I have:

'count' => count($results),
'start' => $results->getStart(),
'limit' => count($results),
'total' => $results->getTotal()

But I would like to use a specific field of the first and last result in the array on any given page, much rather than what ever $results->getStart and count($results) returns.
I cannot just do 'start' => $results->first->someField;


Link to comment
Share on other sites

need to pick this up, as new issues arose.

with PW 3.0.207 the pagination seems to work fine on admin templates, but for ProFields Table, the pagination neither works in .207 nor in .200 though the behaviour is slightly different. 

I guess I need to update, i.e. buy the newest update of that module then? 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...