Jump to content

[SOLVED] Custom user fields don’t work anymore


Recommended Posts

Hi everybody,
some time ago I implemented a blog in ProcessWire with the comments function. The comments have avatar images which were displayed based on the commentators email address. To manage the avatar images and some other data, I added custom fields to the user template. This used to work perfectly, but today I noticed that the avatar images were missing.

$user = users()->find("email=mail@example.com");
echo $user->first()->get('name'); // works perfectly
echo $user->first()->get('user_display_image'); // doesn't work anymore

UPDATE: I just found out, how to get the field value again. One has to check the option »Make field value accessible from API even if not viewable«. Screenshot:


I assume, the functionality must have been changed sometime between 2019 and 2021. With the above setting it works again.

Link to comment
Share on other sites

  • nurkka changed the title to [SOLVED] Custom user fields don’t work anymore

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...