Jump to content

Search the Community

Showing results for tags 'landing pages'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Welcome to ProcessWire
    • News & Announcements
    • Showcase
    • Wishlist & Roadmap
  • Community Support
    • Getting Started
    • Tutorials
    • FAQs
    • General Support
    • API & Templates
    • Modules/Plugins
    • Themes and Profiles
    • Multi-Language Support
    • Security
    • Jobs
  • Off Topic
    • Pub
    • Dev Talk

Product Groups

  • Form Builder
  • ProFields
  • ProCache
  • ProMailer
  • ProDrafts
  • ListerPro
  • ProDevTools
  • Likes
  • Custom Development

Categories

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 2 results

  1. Hi Guys, I am running into a bit of an odd problem. I have setup a landing pages section for another site without any issues. Therefore instead of having a ton of landing pages they all reside under /landing-pages/ and will redirect to the short URL. Example: Instead of root/landing-page/page it will be root/page. In my first site it works perfect! In repeating the same setup for another site I encounter the following problem: ERR_TOO_MANY_REDIRECTS Here is what I am doing: Created a Landing Pages Section Landing Pages Reside Under this Section with the landing-page template In the home template I have turned on segments, in landing-page template I have also turned on segments. In the top of the home template I have placed the following code: <?php if(strlen($input->urlSegment2)) { // we only accept 1 URL segment here, so 404 if there are any more throw new Wire404Exception(); } else if(strlen($input->urlSegment1)) { // render the landing page named in urlSegment1 $name = $sanitizer->pageName($input->urlSegment1); $post = $pages->get("/landing-pages/")->child("name=$name"); if($post->id) echo $post->render(); else throw new Wire404Exception(); } else { ?> In the top of the landing-page template I have placed the following code: <?php // Redirect to the fake URL if real URL is accessed if(!$input->urlSegment1) { $session->redirect($page->url); } include("inc/head.inc"); ?> If I go to the shorter url it works fine, if I attempt the /landing-pages/page url it wont redirect, it just causes the error. Now I tested replacing $session->redirect($page->url); with throw new Wire404Exception(); and then it will work with showing the 404 therefore my conclusion is the session is not catching the short url. Any help? I have checked htaccess, index and config, all are setup right. Running: PW 2.7
  2. Hi Guys, I have a question in regards to SEO and Processwire. We are in process of migrating a site with about 600+ pages that resides on a bespoke CMS. About 200 of these pages are keyword targeted pages. They are content heavy with friendly URLs. However, these pages reside in the CMS under a section called other. Since the CMS they are on is not Processwire but custom, the URLs are vanity URLS, whereas Processwire the URL would look like: /other/page-title Therefore, I have setup a vanity url field and used a similar approach to what Soma did here: https://processwire.com/talk/topic/3057-how-to-keep-pages-organized-when-managing-lots-of-landing-pages/ But for my solution I do show the shorter vanity url, in which some users are displaying the redirect. My question is this: If I show the shorter URL, is Google going to crawl the page as: /other/page-title or /page-title Any help is appreciated. Thanks guys!
×
×
  • Create New...