Hi, I have experimented with naming of images.
For people who want try out different settings with images, the current naming scheme isn't of good usage.
I have added some code to the Pageimage::size method, Pageimage::isVariation, and to the Imagesizer to make it work like here:
http://images.pw.nogajski.de/new-naming-convention/
It is open for discussion
---
Additional to that I like to implement a new temporary option on a per image base to force recreation of the requested image also if a cached version is available. I don't like to use all the time $image->removeVariations().
What is a useful option name for that?
forcenew
recreate
forcecreate
forcerecreate
...?
$options = array(
'cropping' => true,
'quality' => 80,
'forcenew' => true
);
$img = $image->size(120, 160, $options);
---
And for the naming convention I am unsure if a short custom appendix should be enabled too, or if this would be to much?
$customappendix: a-z0-9 strlen max 10 ?