Jump to content

I can't enter admin page (backend)


Recommended Posts

The situation is more weird than I guess. Today I tried to open admin page from the PC at my work. It works fine. There are no any ? symbols at url. I blew my mind yesterday at home. It seems server works and problem may be my PC at home. Perhaps the firewall or antivirus software blocks something. Try to check later.

Link to comment
Share on other sites

I love a good IT mystery :P 

I usually tackle problems like this; make the setup as simple as possible and exclude known problems (forum search) and then list the steps I can try:

- Check the site from a remote browser (works, Check!!!)

- Update software to the latest version (Apache / PHP / ...). this is always a good idea :)

- Disable a virusscanner / firewall / AD blocker and other extensions / plugins

- Use the most plain/simple PW install you can use (no extra modules), same for Apache, make it as simple as possible, no fancy mods

- Enable PW debug mode in the /site/config.php file

- Check Apache and PW log files, (add LogLevel debug rewrite:trace8 to your Virtual Host config).- Try the latest DEV version of PW from GitHub

- Change the Apache Virtual Host port

- Change PW admin folder name

- Change browser, without extensions/plugins, try WGET from the command line, if it works pay extra focus to the browser and its extensions

- index.php is the entry point for the admin site, I'd open it in an editor and add an exit('Mark!'); somewhere in the beginning, test if it is printed when opened in the browser and then move it further in the code (at the next important step) and try it again, and do this again, again, again... until the error happens and then you focus on what the code does between the two last steps. 

- Use fancy debug tools (Tracers, Live debugger, ..)

  • Like 1
Link to comment
Share on other sites

So I opened admin page from several PCs at work. Everything works fine. At home I check site from my wife's laptop. And its ok too.  Finally I tried to open admin page by Microsoft Edge and it works.

As a result I can conclude that server, it's services and PW work normal. The problem is the configuration of Firefox on my home PC. I have not locate problem yet. But the activated private browsing solves the problem.

Link to comment
Share on other sites

Delete past browsing and site data. The browser might have been caching redirects and you are being redirected to the same (incorrect) url even after the problem was fixed somewhere along the line.

for Firefox: https://superuser.com/questions/467999/clear-301-redirect-cache-in-firefox
for Chrome: https://superuser.com/questions/1166181/how-to-clear-cached-redirects-in-chrome

  • Like 2
  • Thanks 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...