Recommended Posts

This is my first post so, Hello everyone.

Ryan, I want to congratulate a great CMS.

I attach my translation for the Polish language.

The translation is fairly complete, but it requires some adjustments.

Hidden deeper setting are not yet translated.

And also the Polish translation for TinyMCE.

TinyMCE will not work without it.

https://github.com/PawelGIX/ProcessWire-Language-Pack-Polish--pl-PL-

EDIT:

I added a link to github.

ProcessWire-Language-Polish.zip

tinymce_language_Polish.zip

  • Like 2

Share this post


Link to post
Share on other sites

PawelGIX, great job and great first post! Thanks for taking the time to make this translation and welcome to the ProcessWire forums!

Share this post


Link to post
Share on other sites

Thanks for making polish language pack

I found a little problem with it. When it's activated, TinyMCE isn't showing up and here are the errors from Chrome:

Failed to load resource: the server responded with a status of 404 (Page Not Found) http://process...pl/wire/modules/Inputfield/InputfieldTinyMCE/tinymce-3.4.7/langs/pl.js
Failed to load: http://process...pl/wire/modules/Inputfield/InputfieldTinyMCE/tinymce-3.4.7/langs/pl.js tiny_mce.js:1
Failed to load resource: the server responded with a status of 404 (Page Not Found) http://process...pl/wire/modules/Inputfield/InputfieldTinyMCE/plugins/preelementfix/langs/pl.js
Failed to load: /wire/modules/Inputfield/InputfieldTinyMCE/plugins/preelementfix/langs/pl.js tiny_mce.js:1
Failed to load resource: the server responded with a status of 404 (Page Not Found) http://process...pl/wire/modules/Inputfield/InputfieldTinyMCE/tinymce-3.4.7/themes/advanced/langs/pl.js
Failed to load: http://process...pl/wire/modules/Inputfield/InputfieldTinyMCE/tinymce-3.4.7/themes/advanced/langs/pl.js

Adding polish translation to TinyMCE from this link to /wire/modules/Inputfield/InputfieldTinyMCE/tinymce-3.4.7/ didn't help. What helped was removing the language reference in Setup > Languages > Polish > wire--modules--inputfield--inputfieldtinymce--inputfieldtinymce.json as ryan advised.

Share this post


Link to post
Share on other sites

I wish that TinyMCE had a more graceful fallback for when a language file wasn't present. It seems like they way they are doing it is not right.

What helped was removing the language reference in Setup > Languages > Polish > wire--modules--inputfield--inputfieldtinymce--inputfieldtinymce.json as ryan advised.

Glad that worked, thanks for letting me know.

Share this post


Link to post
Share on other sites

Hello, in the last couple of days I've built a complete new Polish translation for the ProcessWire 3.0.63.

It may need some cleanup of typos, some translations were done without the context, as I'm new to ProcessWire, so those may need corrections.

Anyway, all language files reported by Processwire (168) and all contained phrases were translated.

@PawelGIX, I hope that you don't mind that I post here, but I don't want to open a new topic if topic about Polish translation already exist :)

@Ryan and everyone involved, thanks for building this great CMS!

Github repo:
https://github.com/sevenstudio/polish-wire

ZIP package also attached to this post.

I hope this will be usefull for Polish users of PW.

Bug reports, suggestions are welcome!

Thanks!
Tomasz

 

 

polish-language-pack-ProcessWire-3.0.63.zip

  • Like 1

Share this post


Link to post
Share on other sites

@rafaoski

You're welcome! I hope it will be useful.

I've submitted new Polish language pack (for 3.X) to the official modules directory at ProcessWire, it's still pending approval, but I hope it will be approved soon. If you will find any bugs, typos, please let me know and I will try to update it.

Thanks!

Pozdrawiam ;) !

  • Like 1

Share this post


Link to post
Share on other sites

Hello guys,

I would like to inform that I've updated my polish translation for PW 3.x to version 1.0.1

This version should be fully compatible with the latest PW dev version 3.0.77 as well with latest stable release.

In this update:

- new translation files were added for new features like new fieldset field, or import/export features

- there is also a complete translation file for the new login/register/profile module, created by @ryan in the last week

- other than that, I've corrected few small typos, few phrases were changed.

Complete polish translation for 3.x is now available in the official modules directory:

http://modules.processwire.com/modules/polski/

bug reports, typos, suggestions are welcome!

  • Like 2

Share this post


Link to post
Share on other sites

Hello, I've updated language pack to v1.0.2.

I've build this language pack in localhost running Windows, were paths were reported with inverted slashes "\". If language package was installed on unix based servers, this cause issues.

New update contains fixes of wrong paths in all translation files. This version should work correctly with all operating systems.

You can grab the latest version in modules directory
http://modules.processwire.com/modules/polski/
or directly at github repo.

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By bmacnaughton
      I am using the translation function (either $this->_() or __()) within a module that responds to AJAX API calls - there isn't really a page that is being served.
      When I supply a string with an apostrophe, e.g.,
      __('Book \'em danno') It is formatted as
      Book 'em danno  
      Is there some way to prevent output formatting when retrieving strings using the translation functions?
    • By Soma
      There's a permission for allowing editor to use the translator in PW 2.73. I could need this but it doesn't work. It shows the "Language" in the menu but when opening the page it says no entries to show. Anybody has some experience using the lang-edit permission for editor? 
    • By clsource
      Hello, 
      In this tutorial I show how to use the wirePopulateStringTags function in order to improve translatable strings.
      https://medium.com/@clsource/better-translatable-strings-in-processwire-621e9e6b18ee#.tv2u23j4i
      Basically it will improve how the strings are shown in the translation administration.
      echo wirePopulateStringTags( __('There are {count} {items} in the {place}'), ['items' => 'apples', 'count' => 32, 'place' => 'basket'] ); Will render 
      There are 32 apples in the basket
      And the Translator will see 
      There are {count} {items} in the {place}  
    • By Guy Verville
      I do love PW for a lot of reasons, but the language translation tool is not that easy to deal with. The site I am working on is in French and there will be no translation, so the default language has been translated into French (importing the french language pack, which is not up to date, and completing lot of stuff). However, for a reason I don't know, some buttons stay in English.
      I was able to find the string pattern %s + Next, and tried numerous variation. Everything is translated except Save + Next!
      As we say in French, PW a des croutes à manger à ce niveau. (probably not really translatable... ;-)  PW has some crumbs to eat on that level). While there was a great improvement on language translation management, wouldn't it be easier to have a tabled list of all translations? And, why, for example, should we have to enter the translation for "Save" at every occurrence in modules?
      ListerPro (which we purchased for that site) is really great to make searches. Would be fun to have translations strings placed in the admin area as pages...
      Food for stuff?
      Any way, back to my chase of %s + Next... (or whatever I will discover)

    • By alec
      Hello everyone. I have strange things happening when I want to edit Site translation files. When I try to edit files I got error: " Session: File does not exist: /site\templates\include\footer.inc (translation file not needed? textdomain: site--templates--include--footer-inc) "
      Here I noticed strange division on left. Somehow it is change direction. Can anyone explain to me why this is happening, and can cause this error?