Mats

Module: Leaflet Map

Recommended Posts

@Pretobrazza  The "Front-End page editor" is not installed. (FrontEndUser is installed.)

@Juergen  "...decided to put it inline only on that page...". This workaround works.

@gebeer  The $page->inlineScript is an empty. I'll get to testing later.

Many thanks for you three for your suggestions!

Share this post


Link to post
Share on other sites

Hallo!

i like the leaflet map module. but i have one question.

now i'm setting the style of the marker manually in the page template because i have not input for the marker style in my admin panel.
what i'm doing wrong?

installed modules

Fieldtypes

FieldtypeFontIconpicker 0.1.6
Leaflet Map Marker 3.0.2

Inputfield

InputfieldFontIconPicker 0.1.6
Leaflet Map Marker 3.0.2

Markup

Inline Scripts 3.0.2
MarkupFontIconPicker 0.1.6    
LeafletMap Markup 3.0.2

 

thx

- sanstraces -

Share this post


Link to post
Share on other sites

Hi,

I also the same problem, a white space on front-end. My code is

In head
<?php $map = wire('modules')->get('MarkupLeafletMap'); ?>
<?php echo  $map->getLeafletMapHeaderLines(); ?>

On my page : 
	$map = $modules->get('MarkupLeafletMap');
    $content.= $map->render($page->children, 'map2');

which gives


	<script src="https://ajax.googleapis.com/ajax/libs/jquery/3.2.1/jquery.min.js"></script>
	<script src="https://code.jquery.com/jquery-3.2.1.min.js"></script>

        <!-- Scripts supporting the use of Leaflet.js -->
        <script type="text/javascript" src="https://unpkg.com/leaflet@1.0.3/dist/leaflet.js"></script>
        <script type="text/javascript" src="/developpement/site/modules/FieldtypeLeafletMapMarker/assets/leaflet-markercluster/leaflet.markercluster.js"></script>
        <script type="text/javascript" src="/developpement/site/modules/FieldtypeLeafletMapMarker/assets/leaflet-providers/leaflet-providers.js"></script>
        <script type="text/javascript" src="/developpement/site/modules/FieldtypeLeafletMapMarker/MarkupLeafletMap.js"></script>

        <!-- Extend Leaflet with Awesome.Markers -->
        <link rel="stylesheet" type="text/css" href="/developpement/site/modules/FieldtypeLeafletMapMarker/assets/leaflet-awesome-markers/leaflet.awesome-markers.css" />
        <script type="text/javascript" src="/developpement/site/modules/FieldtypeLeafletMapMarker/assets/leaflet-awesome-markers/leaflet.awesome-markers.min.js"></script>

However, it looks like it doesn't find any page (404). I even put 777 on /MarkupLeafletMap module.

 

5987aedba8c46_Slection_188.thumb.png.00871b0002aae50ef603f986dbd569eb.pngSélection_189.png

What else can I try? Thanks

Melanie

Share this post


Link to post
Share on other sites

Solved my problem by just copying the wrong path in head :

<link rel='stylesheet' type='text/css' href='https://unpkg.com/leaflet@1.0.3/dist/leaflet.css' />
        <link rel='stylesheet' type='text/css' href='/developpement/site/modules/MarkupLeafletMap/assets/leaflet-markercluster/MarkerCluster.css' />
        <link rel='stylesheet' type='text/css' href='/developpement/site/modules/MarkupLeafletMap/assets/leaflet-markercluster/MarkerCluster.Default.css' />

        <!-- Scripts supporting the use of Leaflet.js -->
        <script type='text/javascript' src='https://unpkg.com/leaflet@1.0.3/dist/leaflet.js'></script>
        <script type='text/javascript' src='/developpement/site/modules/MarkupLeafletMap/assets/leaflet-markercluster/leaflet.markercluster.js'></script>
        <script type='text/javascript' src='/developpement/site/modules/MarkupLeafletMap/assets/leaflet-providers/leaflet-providers.js'></script>
        <script type='text/javascript' src='/developpement/site/modules/MarkupLeafletMap/MarkupLeafletMap.js'></script>

        <!-- Extend Leaflet with Awesome.Markers -->
        <link rel='stylesheet' type='text/css' href='/developpement/site/modules/MarkupLeafletMap/assets/leaflet-awesome-markers/leaflet.awesome-markers.css' />
        <script type='text/javascript' src='/developpemente/site/modules/MarkupLeafletMap/assets/leaflet-awesome-markers/leaflet.awesome-markers.min.js'></script>

 

However, I have a question. Is it possible to display popup by default (without having to click on the marker)?

Thanks!

Melanie

Share this post


Link to post
Share on other sites

If you want to use the whole universe of customization, why don't you use the leafletjs library directly (as instructed on the leafletjs page - there are good examples as a starting point) and just get the needed coords from the module?

Share this post


Link to post
Share on other sites

Having troubles with this... On the front-end, I'm getting a blank area. Scripts are loading fine, and no errors in the console. Something I'm missing maybe?

Share this post


Link to post
Share on other sites

Have you set width and height of the map? I always forget that. :)

Share this post


Link to post
Share on other sites
Just now, Mats said:

Have you set width and height of the map? I always forget that. :)

That appears to be set by the renderer?

--

This is the generated markup:

<script src="https://unpkg.com/jquery@3.2.1/dist/jquery.min.js"></script>
<!-- Styles supporting the use of Leaflet.js -->
<link rel="stylesheet" type="text/css" href="https://unpkg.com/leaflet@1.0.3/dist/leaflet.css" />
<link rel="stylesheet" type="text/css" href="/site/modules/FieldtypeLeafletMapMarker/assets/leaflet-markercluster/MarkerCluster.css" />
<link rel="stylesheet" type="text/css" href="/site/modules/FieldtypeLeafletMapMarker/assets/leaflet-markercluster/MarkerCluster.Default.css" />
<!-- Scripts supporting the use of Leaflet.js -->
<script type="text/javascript" src="https://unpkg.com/leaflet@1.0.3/dist/leaflet.js"></script>
<script type="text/javascript" src="/site/modules/FieldtypeLeafletMapMarker/assets/leaflet-markercluster/leaflet.markercluster.js"></script>
<script type="text/javascript" src="/site/modules/FieldtypeLeafletMapMarker/assets/leaflet-providers/leaflet-providers.js"></script>
<script type="text/javascript" src="/site/modules/FieldtypeLeafletMapMarker/MarkupLeafletMap.js"></script>
<!-- Extend Leaflet with Awesome.Markers -->
<link rel="stylesheet" type="text/css" href="/site/modules/FieldtypeLeafletMapMarker/assets/leaflet-awesome-markers/leaflet.awesome-markers.css" />
<script type="text/javascript" src="/site/modules/FieldtypeLeafletMapMarker/assets/leaflet-awesome-markers/leaflet.awesome-markers.min.js"></script>
<div id='mleafletmap1' class='MarkupLeafletMap' style='width: 100%; height: 500px;'></div>

 

Share this post


Link to post
Share on other sites

You're right the module set the dimensions. 

Share this post


Link to post
Share on other sites

Do you have any initialization code included on the page?

From my example site

<script type="text/javascript">
$(function() {
var mleafletmap1 = new jsMarkupLeafletMap();
mleafletmap1.setOption('zoom', 12);
mleafletmap1.setOption('scrollWheelZoom', false);

mleafletmap1.init('mleafletmap1', 32.5650134, -97.1253889, 'OpenStreetMap.Mapnik');
var default_marker_icon = L.AwesomeMarkers.icon({ icon: 'thumb-tack', iconColor: 'white', prefix: 'fa', markerColor: 'green' });
mleafletmap1.addMarkerIcon(default_marker_icon, 32.571438, -97.141617, '/cleanup-locations/cleanup-site-no.1-town-park/', 'Cleanup Site No.1 Town Park', '<br/><a class="button button-primary" href="/cleanup-locations/cleanup-site-no.1-town-park/">Register Now</a>');
mleafletmap1.addMarkerIcon(default_marker_icon, 32.568825, -97.135254, '/cleanup-locations/cleanup-site-no.2-katherine-rose-memorial-park/', 'Cleanup Site No.2 Katherine Rose Memorial Park', '<br/><a class="button button-primary" href="/cleanup-locations/cleanup-site-no.2-katherine-rose-memorial-park/">Register Now</a>');
mleafletmap1.addMarkerIcon(default_marker_icon, 32.568027, -97.134216, '/cleanup-locations/cleanup-site-no.3-hardy-allmon-soccer-complex/', 'Cleanup Site No.3 Hardy Allmon Soccer Complex', '<br/><a class="button button-primary" href="/cleanup-locations/cleanup-site-no.3-hardy-allmon-soccer-complex/">Register Now</a>');
mleafletmap1.addMarkerIcon(default_marker_icon, 32.566681, -97.122604, '/cleanup-locations/cleanup-site-no.4-julian-field-serenity-gardens/', 'Cleanup Site No.4 Julian Field-Serenity Gardens', '<br/><a class="button button-primary" href="/cleanup-locations/cleanup-site-no.4-julian-field-serenity-gardens/">Register Now</a>');
mleafletmap1.addMarkerIcon(default_marker_icon, 32.572479, -97.125290, '/cleanup-locations/cleanup-site-no.5-james-mcknight-park-west/', 'Cleanup Site No.5 James McKnight Park West', '<br/><a class="button button-primary" href="/cleanup-locations/cleanup-site-no.5-james-mcknight-park-west/">Register Now</a>');
mleafletmap1.addMarkerIcon(default_marker_icon, 32.575569, -97.120041, '/cleanup-locations/cleanup-site-no.6-james-mcknight-park-east/', 'Cleanup Site No.6 James McKnight Park East', '<br/><a class="button button-primary" href="/cleanup-locations/cleanup-site-no.6-james-mcknight-park-east/">Register Now</a>');
mleafletmap1.addMarkerIcon(default_marker_icon, 32.586960, -97.102921, '/cleanup-locations/cleanup-site-no.7-oliver-nature-park/', 'Cleanup Site No.7 Oliver Nature Park', '<br/><a class="button button-primary" href="/cleanup-locations/cleanup-site-no.7-oliver-nature-park/">Register Now</a>');
mleafletmap1.addMarkerIcon(default_marker_icon, 32.582439, -97.128456, '/cleanup-locations/cleanup-site-no.8-hog-pen-branch/', 'Cleanup Site No.8 Hog Pen Branch', '<br/><a class="button button-primary" href="/cleanup-locations/cleanup-site-no.8-hog-pen-branch/">Register Now</a>');
mleafletmap1.addMarkerIcon(default_marker_icon, 32.586273, -97.084381, '/cleanup-locations/cleanup-site-no.9-philip-thompson-soccer-complex/', 'Cleanup Site No.9 Philip Thompson Soccer Complex', '<br/><a class="button button-primary" href="/cleanup-locations/cleanup-site-no.9-philip-thompson-soccer-complex/">Register Now</a>');
mleafletmap1.fitToMarkers();
});
</script>

 

Share this post


Link to post
Share on other sites
8 minutes ago, gmclelland said:

Do you have any initialization code included on the page?

From my example site

[...]

No, unfortunately none of that is rendered... and now I'm having a PHP 7.1 issue with Simple Contact Form and my enviro doesn't have PHP 7.0... (What a day :lol:)

Share this post


Link to post
Share on other sites

Okay, resolved Simple Contact Form issue and uninstalled that for now...

Just for reference, I'm using Latte for the templates:

contact-us.php

$map = $modules->get('MarkupLeafletMap');
$view->map = $map->render($page, 'map');
$view->mapHead = $map->getLeafletMapHeaderLines(false);

contact-us.latte

{block headscripts}{include #parent}
{$mapHead|noescape}
{/block}

..

{$map|noescape}

For $map, only the container is rendered. The script is not appended to it.

  • Like 1

Share this post


Link to post
Share on other sites

Sorry to hear.  I use linode.com with https://serverpilot.io/ which allows you to switch php versions

I'm using the similar TemplateEngineFactory and TemplateEngineTwig modules.

Here is my cleanup-location-index.php

Spoiler

<?php namespace ProcessWire;

$map = wire('modules')->get('MarkupLeafletMap');

$cleanupLocations = $pages->find("template=cleanup-location, sort=sort");
$view->set('cleanupLocations', $cleanupLocations);

if(count($cleanupLocations)>0){
  // https://github.com/netcarver/PW-FieldtypeLeafletMapMarker
  $cleanupLocationsMap = $map->render($cleanupLocations, 'cleanup_location', array(
    'height' => '500px',
    'markerIcon' => 'thumb-tack',
    'markerColour' => 'green',
    'provider' => 'OpenStreetMap.Mapnik',
    'scrollWheelZoom' => 'false',
    'popupFormatter' => function($page) {
      $out[] = "<br/><a class=\"button button-primary\" href=\"$page->url\">Register Now</a>";
      return implode('<br/>', $out);
    }));
}

$view->set('cleanupLocationsMap', $cleanupLocationsMap);

$leafletHeaderLines = $map->getLeafletMapHeaderLines();
$view->set('leafletHeaderLines', $leafletHeaderLines );

 

Here is my cleanup-location-index.twig

Spoiler

{% extends "./partials/one-column-layout.twig" %}

{% block stylesheets %}
  {{ leafletHeaderLines }}
  {{ parent() }}
{% endblock stylesheets %}

{% block content %}
  {{ parent() }}

  {% if cleanupLocationsMap %}
    {{ cleanupLocationsMap }}
  {% endif %}
{% endblock content %}

{% block main2 %}
<div class="row main2 expanded slice-padding">
  <div class="row">
    <div class="small-12 columns">
      <div class="row">
        <h2>Select a cleanup location</h2>
        {% for location in cleanupLocations %}
            <div class="callout callout-list-item-dol row collapse">
                <div class="medium-10 columns">

                    <p><a class="callout-list-item-dol__title-link" href="{{ location.url }}">{{ location.title }}</a></p>
                </div>
                <div class="medium-2 columns">
                    <a class="button button-primary float-right" href="{{ location.url }}">View Details</a>
                </div>
            </div>
        {% else %}
            <p>There are no cleanup locations for this event.</p>
        {% endfor %}
      </div>
    </div><!-- columns -->
  </div><!-- row -->
</div><!-- row -->
{% endblock main2 %}

 

Hope that helps

Share this post


Link to post
Share on other sites

Is there any reason as to why the script markup is not being generated? It can't be a PHP support issue as no errors/warnings are being thrown...

Share this post


Link to post
Share on other sites

Ah, got it.

$inlineScript is not being added to $out, but rather being assigned to $this->page->inlineScripts... As such, this is passed to the MarkupAddInlineScript, which I accidentally uninstalled when getting rid of the Google map module.

Now,as I don't use <head> and <body> tags, the module can't insert the scripts automatically, and so passing $page->inlineScript to the emplate fixes the issue.

Hoping this can be documented, I'm sure I'm not the only one skipping out on optional HTML tags...

Share this post


Link to post
Share on other sites
8 hours ago, gmclelland said:

@Mike Rockett - it looks like it is working to me.  https://www.creeksidecleanup.com/cleanup-events/fall-cleanup-event-locations/  It prevents the desktop user's mouse from zooming in on the map when they use their mouse's scroll wheel.

That's exactly what I need it to do, but it doesn't add the relevant option to the JS code...

Let me investigate.

Share this post


Link to post
Share on other sites

I'm beginning to think you're using a different release or something... This is my controller now:

$leaflet = $modules->MarkupLeafletMap;
$view->mapHead = $leaflet->getLeafletMapHeaderLines(false);
$view->map = $leaflet->render($page, 'map', [
    'height' => '500px',
    'scrollWheelZoom' => false,
]);

And this is the output:

$(function() {
var mleafletmap1 = new jsMarkupLeafletMap();
mleafletmap1.setOption('zoom', 14);

mleafletmap1.init('mleafletmap1', -26.172777, 28.085833, 'CartoDB.Positron');
var default_marker_icon = L.AwesomeMarkers.icon({ icon: 'home', iconColor: 'white', prefix: 'fa', markerColor: 'darkblue' });
mleafletmap1.addMarkerIcon(default_marker_icon, -26.172777, 28.085833, '/contact-us', 'Contact Us', '');
});

There's nothing in MarkupLeafletMap.module that indicates the options I provide should be added, unless I'm adding multiple markers, in which case it adds to relevant addMarkerIcon function-call to the script. I could well set the two options require in init, but that's not the correct solution.

Share this post


Link to post
Share on other sites

With the newest module version, PW 3, Leaflet 1.2, I get this:

jQuery.Deferred exception: L.tileLayer.provider is not a function jsMarkupLeafletMap

 

Did they change something again?

Share this post


Link to post
Share on other sites
On 5/4/2017 at 9:01 AM, Pretobrazza said:

tried all the possibilities  that were suggested for Batch child editor

Very late response to this, but I would like to follow up on this. I specifically testing BCE with importing CSV to the MapMarker module and it worked fine (if you set up the CSV field pairings correctly. It should also work with the Leaflet map as well. If you have time, it would be great to hear how you set these up in case there is actually a problem still.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Robin S
      Another little admin helper module...
      Template Field Widths
      Adds a "Field widths" field to Edit Template that allows you to quickly set the widths of inputfields in the template.

      Why?
      When setting up a new template or trying out different field layouts I find it a bit slow and tedious to have to open each field individually in a modal just to set the width. This module speeds up the process.
      Installation
      Install the Template Field Widths module.
      Config options
      You can set the default presentation of the "Field widths" field to collapsed or open. You can choose Name or Label as the primary identifier shown for the field. The unchosen alternative will become the title attribute shown on hover. You can choose to show the original field width next to the template context field width.  
      https://github.com/Toutouwai/TemplateFieldWidths
      https://modules.processwire.com/modules/template-field-widths/
    • By horst
      Croppable Image 3
      for PW 3.0.20+
      Module Version 1.1.16
      Sponsored by http://dreikon.de/, many thanks Timo & Niko!
      You can get it in the modules directory!
      Please refer to the readme on github for instructions.
       
      -------------------------------------------------------------------------
       
      Updating from prior versions:
       
      Updating from Croppable Image 3 with versions prior to 1.1.7, please do this as a one time step:
      In the PW Admin, go to side -> modules -> new, use "install via ClassName" and use CroppableImage3 for the Module Class Name. This will update your existing CroppableImage3 module sub directory, even if it is called a new install. After that, the module will be recogniced by the PW updater module, what makes it a lot easier on further updates.
      -------------------------------------------------------------------------
       
      For updating from the legacy Thumbnail / CropImage to CroppableImage3 read on here.
       
      -------------------------------------------------------------------------
       
    • By MoritzLost
      UPDATE: I have published a stable version of this module!
      Discussion thread:
      Github: https://github.com/MoritzLost/TextformatterPageTitleLinks
      ---
      Hello there,
      I'm working on a tiny textformatter module that searches the text for titles of other pages on your site and creates hyperlinks to them. I'm not sure if something like this exists already, but I haven't found anything in the module directory, so I wrote my own solution 🙂
      It's not properly tested yet and is still missing some functionality I would like to implement, so at the moment it should be considered in BETA. Features include limiting the pages that will get searched by template, and adding a custom CSS class to the generated hyperlinks. As I'm writing this I noticed that it will probably include unpublished and hidden pages at the moment, so yeah ... it's still in development alright 😅
      You can download the module from Github:
      https://github.com/MoritzLost/TextformatterPageTitleLinks
      There's some more information in the readme as well.
      Anyway, let me know what you think! I'm happy about any feedback, possible improvements or ideas on how to improve the module. Cheers.
    • By blad
      Hi guys!
      I just uploaded a module to explore files based on elFinder. By default it will show the "Files" folder.
      Screenshots:

      Video:
       
      To do:
       More options To fix:
       The function of rotating or scaling an image fails  Image editors V 1.01 (view issue)
      Fixed the bug working with the Multi-Language support ( translation of folders ). Fixed the name of elfinder.en  Github:
      https://github.com/LuisSantiago/ProcessElFinder/
      I hope you like it.
    • By BitPoet
      I'm really in love with FormBuilder, but the one thing missing to match all my end users' expectations were repeatable field groups. Think repeaters, in ProcessWire terms. Our primary application of PW is our corporate intranet, so "lines" of fields are quite common in the forms I build. We have all kinds of request forms where the information for a varying number of colleagues needs to be entered (from meal order to flight booking request) and where it is simply impractical to send a form for each, and I don't want to clutter my forms with multiple instances of fields that may only get used ten percent of the time.
      That's why I started to build FormBuilderMultiplier (link to GitHub).
      What it does:
      Adds an option to make a regular Fieldgroup repeatable Lets you limit the number of instances of a Fieldgroup on the form Adds an "Add row" button the form that adds another instance of the Fieldgroup's fields Adds a counter suffix at the end of every affected field's label Stores the entered values just like regular fields Makes the entered values available in preview and email notifications Supports most text based fields, textareas and selects (really, I haven't had enough time to test all the available choices yet) What it doesn't do (yet):
      Support saving to ProcessWire pages (i.e. real Repeaters) I haven't tested all the validation stuff, Date/Time inputs etc. yet, but since I'm utterly swamped with other stuff at work, I didn't want to wait until I have it polished. Any feedback is welcome. There might also be some issues with different output frameworks that I haven't encountered yet. The forms I work with mostly use UIKit.
      Status:
      Still alpha, so test well before using it in the field.
      Known issues:
      When rows are added, the form's iframe needs to be resized, which isn't completely clean yet.
      How it works:
      The Fieldgroup settings are added through regular hooks, as is the logic that adds the necessary field copies for processing the form and displaying previews.
      "Multiplied" field instances are suffixed with _NUM, where NUM is an incremental integer starting from 1. So if you have add two fields named "surname" and "givenname" to a fieldgroup and check the "multiply" checkbox, the form will initially have "surname_1" and "givenname_1" field (I'm still considering changing that to make the risk to shoot oneself into the foot by having a regular "surname_1" field somewhere else in the form less likely).
      When a "row" is added, the first row is cloned through JS and the counter in the fields' IDs, names and "for" attributes as well as the counter in the label are incremented before appending the copies to the Fieldset container in the form.
      To keep backend and frontend in sync, a hidden field named [name of the fieldset]__multiplier_rows is added to the form. Both the backend and the frontend script use this to store and retrieve the number of "rows".
      ToDo:
      Naturally, add the option to store the data in real repeaters when saving to pages. Do a lot of testing (and likely fixing). Make a few things (like the "Add row" button label etc.) configurable in field(set) context. Add a smooth API to retrieve the multiplied values as WireArrays. The mandatory moving screenshot: