Mats

Module: Leaflet Map

Recommended Posts

I reinstalled the module, and now its working.
When I setup the repeater to allways open the items the map and magnifying glass icon seems to work.

Thanks for your help!

Share this post


Link to post
Share on other sites

is it possible to use an image filed for the markers instead of the fontawesome option?
my code looks like this (it works with the FontIconPicker):
 

<?php
    $options = array(
    'height' => '100%',
    'markerIconColour' => 'black',
    'popupFormatter' => function($page) {
        $out[] = "<p>$page->headline</p>";
        return implode($out);
    },
    'markerFormatter' => function($page, $marker_options) {
        $marker_options['icon'] = $page->marker_icon; // Override the default icon for this marker.
        return $marker_options;
    }
);
      $items = $lage->map_repeater; 
echo $map->render($items, 'map', $options); 
                 ?>

 

Share this post


Link to post
Share on other sites

Hi!

I have problems displaying the map. It is not showing up.

I installed all the modules, setup the field and the template and put the following in my template file (home.php with delayed output):

echo $page->map->address;   // outputs the address you entered
echo $page->map->lat;       // outputs the latitude
echo $page->map->lng;       // outputs the longitude
echo $page->map->zoom;      // outputs the zoom level
$map = wire('modules')->get('MarkupLeafletMap');
echo $map->getLeafletMapHeaderLines();
echo $map->render($page, 'map');

Address, lat, lng and zoom are printed out, but there is no map. What am I doing wrong? I am not a coder.

Looks like sonething is messed up, the source code of the page looks like this

leafletmarkersource.png

Is that the correct? It is the same problem as with the google map marker field :mellow:

Share this post


Link to post
Share on other sites

fliwatuet: Looking at the source, it seems you are echoing the map outside of your body and html elements.

Share this post


Link to post
Share on other sites

This is my home.php:
 

<?php namespace ProcessWire;

echo $page->map->address;   // outputs the address you entered
echo $page->map->lat;       // outputs the latitude
echo $page->map->lng;       // outputs the longitude
echo $page->map->zoom;      // outputs the zoom level
$map = wire('modules')->get('MarkupLeafletMap');
echo $map->getLeafletMapHeaderLines();
echo $map->render($page, 'map');

// home.php (homepage) template file.
// See README.txt for more information

// Primary content is the page body copy and navigation to children.
// See the _func.php file for the renderNav() function example
$content = $page->body . renderNav($page->children);

// if there are images, lets choose one to output in the sidebar
if(count($page->images)) {
    // if the page has images on it, grab one of them randomly...
    $image = $page->images->getRandom();
    // resize it to 400 pixels wide
    $image = $image->width(400);
    // output the image at the top of the sidebar...
    $sidebar = "<img src='$image->url' alt='$image->description' />";
    // ...and append sidebar text under the image
    $sidebar .= $page->sidebar;    
} else {
    // no images...
    // append sidebar text if the page has it
    $sidebar = $page->sidebar;
}

 

Share this post


Link to post
Share on other sites

I tried. But whenever I put

<?php
$map = wire('modules')->get('MarkupLeafletMap');
echo $map->getLeafletMapHeaderLines();
?>

in the head section of _main.php I get this error message:
 

Error: Uncaught Error: Call to a member function render() on null in /home/html/portal.dev/site/templates/home.php:14
Stack trace:
#0 /home/html/portal.dev/wire/core/TemplateFile.php(268): require()
#1 [internal function]: ProcessWire\TemplateFile->___render()
#2 /home/html/portal.dev/wire/core/Wire.php(374): call_user_func_array(Array, Array)
#3 /home/html/portal.dev/wire/core/WireHooks.php(549): ProcessWire\Wire->_callMethod('___render', Array)
#4 /home/html/portal.dev/wire/core/Wire.php(399): ProcessWire\WireHooks->runHooks(Object(ProcessWire\TemplateFile), 'render', Array)
#5 /home/html/portal.dev/wire/modules/PageRender.module(515): ProcessWire\Wire->__call('render', Array)
#6 [internal function]: ProcessWire\PageRender->___renderPage(Object(ProcessWire\HookEvent))
#7 /home/html/portal.dev/wire/core/Wire.php(374): call_user_func_array(Array, Array)
#8 /home/html/portal.dev/wire/core/WireHooks.php(549): ProcessWire\Wire->_callMethod( (line 14 of /home/html/portal.dev/site/templates/home.php)

This error message was shown because: you are logged in as a Superuser. Error has been logged.

 

Share this post


Link to post
Share on other sites

@fliwatuet could you post the content of the head section of your _main.php please. It's fine to redact anything you feel is private if you need to.

Also, I use this module on a PHP7 installation and seem to have no problems with it.

  • Like 1

Share this post


Link to post
Share on other sites

This is the original file (I took out the comments):
 

<?php namespace ProcessWire;

?><!DOCTYPE html>
<html lang="en">
<head>
    <meta http-equiv="content-type" content="text/html; charset=utf-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1" />
    <title><?php echo $title; ?></title>
    <meta name="description" content="<?php echo $page->summary; ?>" />
    <link href='//fonts.googleapis.com/css?family=Lusitana:400,700|Quattrocento:400,700' rel='stylesheet' type='text/css' />
    <link rel="stylesheet" type="text/css" href="<?php echo $config->urls->templates?>styles/main.css" />
</head>

When I add

    <?php
       $map = wire('modules')->get('MarkupLeafletMap');
       echo $map->getLeafletMapHeaderLines();
    ?>

right before </head> I still get the error message mentioned above when I use "echo $map->render($page, 'map');" in home.php!

BTW: the map in the backend is working.

Share this post


Link to post
Share on other sites

@fliwatuet

Sounds like $map is undefined in the home.php file. Please try this. In _main.php...

<!DOCTYPE html>
<html lang="en">
<head>
    <meta http-equiv="content-type" content="text/html; charset=utf-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1" />
    <title><?php echo $title; ?></title>
    <meta name="description" content="<?php echo $page->summary; ?>" />
    <link href='//fonts.googleapis.com/css?family=Lusitana:400,700|Quattrocento:400,700' rel='stylesheet' type='text/css' />
    <link rel="stylesheet" type="text/css" href="<?php echo $config->urls->templates?>styles/main.css" />
<?php
    $map = wire('modules')->get('MarkupLeafletMap');
    echo $map->getLeafletMapHeaderLines();
?>
</head>

in home.php...

<?php
    $map = wire('modules')->get('MarkupLeafletMap');
    echo $map->render($page, 'map');
?>

Also, are you sure your field is actually called 'map'?

Share this post


Link to post
Share on other sites

Yes, the field is called map.

This is working fine:

$page->map->address
$page->map->lat
$page->map->lng
$page->map->zoom

 

I changed the code to your suggestion, now there is no error message anymore, but still no map...

Share this post


Link to post
Share on other sites

Does the page you are viewing using the home template actually have a value for the map field saved in it? Scrub that, it sounds like it does.

Share this post


Link to post
Share on other sites

Ok, if you inspect the page displaying the map with your browser tools, are there any JS errors or 404s showing up for the linked resources?

Share this post


Link to post
Share on other sites
7 minutes ago, netcarver said:

Does the page you are viewing using the home template actually have a value for the map field saved in it?

What do you mean? I added the map field to the home template and then edited the home page, put an address into the map field. I then edited the home.php template file and the _main.php.

No errors as far as i can see.

Share this post


Link to post
Share on other sites

Hello @netcarver I'm having the same problem @fliwatuet reported above.

I supposed I've added everything correctly:

in my _init.php:

$map = $modules->get('MarkupLeafletMap');

inside the <head></head> of my top_nav.php:

echo $map->getLeafletMapHeaderLines();

and then in my template file:

<?php echo $map->render($page, 'map'); ?> // yes, the field is called "map"

Inspecting the code I see all the css and js files in the <head> after this comment:

<!-- Styles supporting the use of Leaflet.js -->
.. css and js are here ..

And the correct <div> is generated by the module:

<div id="mleafletmap1" class="MarkupLeafletMap" style="width: 100%; height: 500px;"></div>

...but unfortunately the map is blank on the front-page of the site. 

I'm working on localhost on ProcessWire 2.8.35.

....got suggestions for me?

Share this post


Link to post
Share on other sites

I have also this problem sometimes (especially when I am not logged in). Could it be possible that there is a limit on the Leaflet service which supports only a specific amount of requests to a certain domain?

Share this post


Link to post
Share on other sites

If you open up the inspection tools in your browser and reload the page, are there any resources that fail to load or any js errors reported?

Share this post


Link to post
Share on other sites

Thanks for the reply @netcarver. I appreciate.

No errors anywhere in the console/inspector.

I've also tried to manually point the module to the 1.0.2 version of the leaflet JS and css (changhing both unpkg.com urls) but without luck, same blank div.

Have you got time to try to reproduce this strange behaviour?

 

 

Share this post


Link to post
Share on other sites

@3fingers So, all the resources are loading - and there are no errors - and there is no output? Ok - is this on a local development box or on a server I can take a look at?

Edited to add: I have seen a correctly set-up map fail to load if a browser is blocking scripts using an extension like noscript/umatrix/ublock-origin etc.

  • Like 1

Share this post


Link to post
Share on other sites

...And there was the problem! I got an ad-blocker installed causing this issue on chrome. Unfortunately nowadays a lot of people have them turned on.

I'm going to investigate for a workaround, but It is kind of a remarkable issue for my project :(

In the meantime thanks for your support.

  • Like 1

Share this post


Link to post
Share on other sites

Hello, I have a question if this module can do the following.

I have a turtle that lives in one ore more states (US) or countries. I want to show this on a map on the page about that turtle. The input has to based on just the name of the state or country as I want to use the same also just for a text reference (like a tag).

Besides that I want a big map on a sperate page that combines all the turtles and shows which are located where with a hoover link to that turtle (page).

The final step is a page per state or country that show the map of that region on top and all related posts below...

It's a bit ambitious but I had to ask...

Share this post


Link to post
Share on other sites
On 30/12/2016 at 2:12 PM, webhoes said:

Hello, I have a question if this module can do the following.

I have a turtle that lives in one ore more states (US) or countries. I want to show this on a map on the page about that turtle. The input has to based on just the name of the state or country as I want to use the same also just for a text reference (like a tag).

Besides that I want a big map on a sperate page that combines all the turtles and shows which are located where with a hoover link to that turtle (page).

The final step is a page per state or country that show the map of that region on top and all related posts below...

It's a bit ambitious but I had to ask...

All possible.....for the maps you can select  what items you show on your map based on any field (for your specific turtle page):

$items = $pages->find("marker_colour=red");

My code here:

// LEAFLET MAP WITH BICYCLE ICONS
$items = $pages->find("marker_icon=bicycle");
$map = wire('modules')->get('MarkupLeafletMap');
$options = array(
    'markerFormatter' => function($page, $marker_options) {
              if ($page->marker_icon->title) {
                        $marker_options['icon'] = $page->marker_icon->title;
                    }
                    if ($page->marker_colour->title) {
                        $marker_options['markerColor'] = $page->marker_colour->title;
                    }
                    // And the icon colour. This is another text field. Colour values like White, Black or an RGB value are ok here.
                    if ($page->marker_icon_colour->title) {
                        $marker_options['iconColor'] = $page->marker_icon_colour->title;
                    }    
        return $marker_options;
    },
    'popupFormatter' => function($page) {
        $out[] = "<strong>$page->summary</strong>";
        $out[] = "<a href=\"$page->url\" ><img src=\"{$page->summary_image->url}\" class=\"image fit\"  /></a>";
        $out[] = "<img src=\"{$page->summary_image->url}\" width=\"200\" height=\"200\" />"; // ** NB: Use escaped double quotes if HTML attributes needed **
        return implode('<br/>', $out);
    }
);

 

and for items from different categories (species for your big map):

$items = $pages->find("marker_colour=red|green|blue");

 

Remember you can use:

'red', 'darkred', 'orange', 'green', 'darkgreen', 'blue', 'purple', 'darkpuple' & 'cadetblue'

and any icons from your version of Awesome icons: http://fontawesome.io/icons/

 

Beneath each map you can summarise revevant posts for each region or each species with the page find function based on an "options field type":

$features = $pages->find('species=loggerhead');

 

  • Like 1

Share this post


Link to post
Share on other sites

Does anyone know how you can populate the address field from another field on the template ? 

Eg; the title field is holding a country name, therefore would be nice if user does not need to type in country again, map just populates automagically.

Thx,

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By BitPoet
      MediaLibrary
      Update: MediaLibrary can now be found in the official module list.
      Out of necessity, I've started to implement a simple media library module.
      The basic mechanism is that it adds a MediaLibrary template with file and image fields. Pages of this type can be added anywhere in the page tree.
      The link and image pickers in CKEditor are extended to allow quick selection of library pages from dropdowns. In the link picker this happens in the MediaLibrary tab, where you can also see a preview of the selected image. In the image picker, simply select a library from the dropdown at the top, everything else is handled by standard functionality.
      I've put the code onto github. This module is compatible with ProcessWire 3.
      Steps to usage:
      Download the module's zip from github (switch to the pw3 branche beforehand if you want to test on PW 3.x) and unpack it into site/modules Click "Modules" -> "Refresh" in the admin Click "Install" for MediaLibrary For testing, create a page with the MediaLibrary template under home (give it an expressive title like 'Global Media') and add some images and files Edit a differnt page with a CKEditor field and add a link and an image to see the MediaLibrary features in action (see the screencap for details) Optionally, go into the module settings for MediaLibrary Note: this module is far from being as elaborate as Kongondo's Media Manager (and doesn't plan to be). If you need a feature-rich solution for integrated media management, give it a look.
      Feel free to change the settings for MediaFiles and MediaImages fields, just keep the type as multiple.
      There are some not-so-pretty hacks for creating and inserting the correct markup, which could probably be changed to use standard input fields, though I'm a bit at a loss right now how to get it to work. I've also still got to take a look at error handling before I can call it fit for production. All feedback and pointers are appreciated (that's also why I post this in the development section).

      Edit 09.03.2016 / version 0.0.4: there's now also a "Media" admin page with a shortcut to quickly add a new library.

      Edit 01.05.2016:
      Version 0.0.8:
      - The module now supports nested media libraries (all descendants of eligible media libraries are also selectable in link/image picker).
      - There's a MediaLibrary::getPageMediaLibraries method you can hook after to modify the array of available libraries.
      - You can switch between (default) select dropdowns or radio boxes in the module configuration of MediaLIbrary to choose libraries.
      Edit 10.10.2018:
      Version 0.1.3:
      - Dropped compatibility for ProcessWire legacy versions by adding namespaces
      - Allow deletion of libraries from the Media overview admin page
      - Added an option to hide media libraries from the page tree (optionally also for superusers)
    • By Robin S
      This module corrects a few things that I find awkward about the "Add New Template" workflow in the PW admin. I opened a wishlist topic a while back because it would good to resolve some of these things in the core, but this module is a stopgap for now.
      Originally I was going to share these as a few standalone hooks, but decided to bundle them together in a configurable module instead.
      Add Template Enhancements
      A module for ProcessWire CMS/CMF. Adds some efficiency enhancements when adding or cloning templates via admin.

      Features
      Derive label from name when new template added: if you like to give each of your templates a label then this feature can save some time. The label can be added automatically when templates are added in admin, in admin/API, or not at all. There are options for underscore/hyphen replacement and capitalisation of the label. Edit template after add: when adding only a single template, the template is automatically opened for editing after it is added. Copy field contexts when cloning: this copies the field contexts (a.k.a. overrides such as column width, label and description) from the source template to the new template when using the "Duplicate/clone this template?" feature on the Advanced tab. Copy field contexts when duplicating fields: this copies the field contexts if you select the "Duplicate fields used by another template" option when adding a new template. Usage
      Install the Add Template Enhancements module.
      Configure the module settings according to what suits you.
       
      https://github.com/Toutouwai/AddTemplateEnhancements
      https://modules.processwire.com/modules/add-template-enhancements/
    • By Mike Rockett
      As I mentioned in this issue, I've create a new textformatter for ParsedownExtraPlugin, which adds some oomph to your markdown.
      Repo: Parsedown Extra Plugin
      Unlike the built-in textformatter for Parsedown and Parsedown Extra, this should be used when you want to use Extra with additional configuration/customisation.
      Some examples:
      ### Test {.heading} - A [external link](https://google.com/){.google} with `google` as a class that opens in a new tab if the config property is set. - [Another link](/page){target=_blank} that opens in a new tab even though it isn't external. ```html .html <p>Test</p> ``` There's some config options available to you, such as setting attributes on all/external images and links, setting table and table-cell alignment classes, adjusting footnote classes and IDs, adding <code> attributes to their parent <pre> elements, and changing the <code> class if your syntax highlighter does not use language-*.
      I was thinking about adding the ability to make links open in a new tab by appending a plus to the link syntax, but only external links should be opening in a new tab anyway. Further, this would add extra, unnecessary processing time.
      Please let me know if you bump into any problems. ☺️
    • By Mike Rockett
      TextformatterTypographer (0.4.0 Beta)
      A ProcessWire wrapper for the awesome PHP Typography class, originally authored by KINGdesk LLC and enhanced by Peter Putzer in wp-Typography. Like Smartypants, it supercharges text fields with enhanced typography and typesetting, such as smart quotations, hyphenation in 59 languages, ellipses, copyright-, trade-, and service-marks, math symbols, and more.
      Learn more on my blog
      It's based on the PHP-Typography library found over at wp-Typography, which is more frequently updated and feature rich that its original by KINGdesk LLC.
      The module itself is fully configurable. I haven't done extensive testing, but there is nothing complex about this, and so I only envisage a typographical bug here and there, if any.
      Please do test it out and let me know what you think.
      Also note that I have indicated support for PW 2.8, but I haven't tested there as yet. This was built on PW 3.0.42/62.
    • By Mike Rockett
      Jumplinks for ProcessWire
      Release: 1.5.50
      Jumplinks is an enhanced version of the original ProcessRedirects by Antti Peisa.
      The Process module manages your permanent and temporary redirects (we'll call these "jumplinks" from now on, unless in reference to redirects from another module), useful for when you're migrating over to ProcessWire from another system/platform. Each jumplink supports wildcards, shortening the time needed to create them.
      Unlike similar modules for other platforms, wildcards in Jumplinks are much easier to work with, as Regular Expressions are not fully exposed. Instead, parameters wrapped in curly braces are used - these are described in the documentation.
      Under Development: 2.0, to be powered by FastRoute
      As of version 1.5.0, Jumplinks requires at least ProcessWire 2.6.1 to run.
      View on GitLab
      Download via the Modules Directory
      Read the docs
      Features
      The most prominent features include:
      Basic jumplinks (from one fixed route to another) Parameter-based wildcards with "Smart" equivalents Mapping Collections (for converting ID-based routes to their named-equivalents without the need to create multiple jumplinks) Destination Selectors (for finding and redirecting to pages containing legacy location information) Timed Activation (activate and/or deactivate jumplinks at specific times) 404-Monitor (for creating jumplinks based on 404 hits) Additionally, the following features may come in handy:
      Stale jumplink management Legacy domain support for slow migrations An importer (from CSV or ProcessRedirects) Feedback & Feature Requests
      I’d love to know what you think of this module. Please provide some feedback on the module as a whole, or even regarding smaller things that make it whole. Also, please feel free to submit feature requests and their use-cases.
      Note: Features requested so far have been added to the to-do list, and will be added to 2.0, and not the current dev/master branches.
      Open Source

      Jumplinks is an open-source project, and is free to use. In fact, Jumplinks will always be open-source, and will always remain free to use. Forever. If you would like to support the development of Jumplinks, please consider making a small donation via PayPal.
      Enjoy!