Jump to content

Issue with has_parent selector


Sinmok
 Share

Recommended Posts

4 minutes ago, Zeka said:

@Orkun I think that it is enoght to run it once if you have some issues or after update to PW >= 3.0.156. 

https://github.com/processwire/processwire/blob/master/wire/core/PagesParents.php#L485

Save method from PagesParents class executes on every page save and if it's necessary it will execute rebuildAll method.

https://github.com/processwire/processwire/blob/master/wire/core/PagesParents.php#L502

Hi @Zeka

Thank you for the clarification!

Link to comment
Share on other sites

  • 8 months later...
Posted (edited)

Hi friends,

After running "$pages->parents()->rebuildAll();" in TracyDebugger (PW version 3.0.178), I got table "pages_parents" empty!

Any suggestions? has_parent still not working and I really needed it.

Thank you all

------

After a lot of tests, I realize that the problem is missing system resources. My database is getting huge and the rebuildAll cannot work properly. 

I did some tunning in my machine and could run properly.

I hope that problem has_parent has finally solved.

Thank you anyway!

empty_parents.png

structure.png

Edited by Bacos
More information...
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...