Jump to content
vegardw

Truly HTTPS out of the box

Recommended Posts

When installing ProcessWire out of the box (Softaculous), there is one minor mistake in making it truly https friendly.

site/templates/_main.php - the http: has to be removed in order to load the google font accordingly to the site setup https/http.

<head>
	<meta http-equiv="content-type" content="text/html; charset=utf-8" />
	<title><?php echo $title; ?></title>
	<meta name="description" content="<?php echo $page->summary; ?>" />
	<link href='http://fonts.googleapis.com/css?family=Lusitana:400,700|Quattrocento:400,700' rel='stylesheet' type='text/css' />
	<link rel="stylesheet" type="text/css" href="<?php echo $config->urls->templates?>styles/main.css" />
</head> 

Great product! Continue the brilliance.

  • Like 3

Share this post


Link to post
Share on other sites

Hi there, and welcome to processwire.

How did you find processwire amongst the others ?

Share this post


Link to post
Share on other sites

Not sure what you mean:

About processwire site setup see the api

https://processwire.com/api/variables/config/

Examples:

Links to fonts from google goes like this:
<link href='http://fonts.googleapis.com/css?family= . . . . . . ' rel='stylesheet' type='text/css'>

Links to your font-awesome.min.css goes like this:
<link href='/site/templates/styles/font-awesome/css/font-awesome.min.css' rel='stylesheet' type='text/css' />

Links to your internal css and js go like this:
<link href="/site/templates/webfonts/your_webfont_styles.css" rel="stylesheet">
<link href="/site/templates/your_style.css" rel="stylesheet">
<script src="/site/templates/webfonts/your_webfont_script.js"></script>

Share this post


Link to post
Share on other sites

Pwired, instead of http:// the Google fonts should be loaded just with //, then it would use http/https according to the current page.

That is of course quick change and pretty much site specific setting.

And welcome to the forums vegardw!

  • Like 2

Share this post


Link to post
Share on other sites

I just wanted to inform, due to not want to edit everytime there will be an update (not that I will use the default theme forever, but yes, small issue). Could probably be solved better, just fast fix.

Share this post


Link to post
Share on other sites

Thanks vegardw for spotting this. Would you mind filing a bug report on Github please?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By alanxptm
      Hi, I have already tried in different ways and many times to migrate but I always have issues at the end.
      Here's what I have done so far:
       
      case 1:
      1. Install PW on live server (all normal)
      2. Import local DB into live DB
      3. Front page site seems to work but I cannot login into admin page
      case 2 (I'm currently on this stage):
      1. Copied all files from local to live server
      2. Import local DB into live empty DB
      3. Front page works, but any other page and admin page are 404
       
      In both cases:
      - I have changed config.php info accordingly to live server (DB name, DB user and pwd, userauthsalt code)
      - Uncommented RewriteBase / and RewriteBase /pw/ lines on .htaccess
      - applied owner and group permissions to www-data for PW location
      - applied permissions to folders and files accordingly
      - applied a2enmod rewrite to apache2 on live server and restarted service
       
      I have read some posts (Ryan's too) about migration and it seems to me that I'm doing it fine, don't know what it fails-
      I'm on VMWare machine, Ubuntu Server 18.04, php 7.2, phpMyAdmin 5.0.1
      Hope you can help me, thanks in advance
    • By rushy
      Hi. I've been using Processwire for a few years now and installed it on a few different shared hosting servers without issues, but I'm now running into an issue on a Fasthosts shared server that I've not seen before. The installation goes ok and I have a working default site profile but I am unable to complete any uploads of images. It just hangs at the progress spinner during the upload. I thought it might be a priviledge issue so have temporarily set the dir / file privs. as 777 / 666 just to test that but it made no difference. I have no errors in the wire log. In server error log I have:
      set_time_limit() has been disabled for security reasons in ....htdocs/wire/core/ImageSizerEngine.php on line 1035 and i note in the assets/file dir. where the image is being stored the date on the file being created has a year of 1970 and 0 length. If I leave the page this file disappears and nothing has been stored. 
      Does anyone know how I can enable set_time_limit if this is likely to be the problem? 
      Many thanks! Paul
    • By Robin S
      After forgetting the class name of the wonderful AdminPageFieldEditLinks module for what feels like the 100th time I decided I needed to give my failing memory a helping hand...
      Autocomplete Module Class Name
      Provides class name autocomplete suggestions for the "Add Module From Directory" and "Add Module From URL" fields at Modules > New.
      Requires ProcessWire >= v3.0.16.
      Screencast

      Installation
      Install the Autocomplete Module Class Name module.
      Configuration
      Add Module From Directory
      Choose the type of autocomplete suggestions list: "Module class names from directory" or "Custom list of module class names". The latter could be useful if you regularly install some modules and would prefer a shorter list of autocomplete suggestions. The list of class names in the modules directory is generated when the Autocomplete Module Class Name module is installed. It doesn't update automatically (because the retrieval of the class names is quite slow), but you can use the button underneath when you want to retrieve an updated list of class names from the directory. Add Module From URL
      If you want to see autocomplete suggestions for the "Add Module From URL" field then enter them in the following format:
      [autocomplete suggestion] > [module ZIP url]
      Example: RepeaterImages > https://github.com/Toutouwai/RepeaterImages/archive/master.zip Awesomplete options
      The "fuzzy search" option uses custom filter and item functions for Awesomplete so that the characters you type just have to exist in the autocomplete suggestion item and occur after preceding matches but do not need to be contiguous. Uncheck this option if you prefer the standard Awesomplete matching. Custom settings for Awesomplete can be entered in the "Awesomplete options" field if needed. See the Awesomplete documentation for more information.  
      https://github.com/Toutouwai/AutocompleteModuleClassName
      https://modules.processwire.com/modules/autocomplete-module-class-name/
    • By gregg
      While trying to install 3.0.123, i encountered the following error: 
           Parse error: syntax error, unexpected '[' in /home/naucom5/public_html/wire/core/FunctionsAPI.php on line 469
      In cPanel, i extracted the zip file to 'public_html', which created the directory 'processwire-master', and then moved the files from 'processwire-master' to 'public_html' (which previously had 1 unrelated directory).
      Installation went well choosing Uikit profile, including connecting to database. Compatibility check ok (mod_rewrite error cleared after recheck), successful database connection, config.php saved, unchecked a few cleanup items, then the error message.
      Any suggestions appreciated. 
    • By Marco Angeli
      Hi there,
      I added a ssl certificate to my site and I'd like to redirect every single http url to its new https version
      So I added this code in the .htacces file, after the RewriteEngine On :
      Redirect 301 /about https://www.mysite.it/about
      Unfortunately this is now working: I get the "too many redirects" error.
      The following code works, but it's a bulk redirection to the home page, something I don't want for SEO reasons (https://moz.com/blog/save-your-website-with-redirects😞
      RewriteCond %{HTTP_HOST} mysite\.it [NC]
      RewriteCond %{SERVER_PORT} 80
      RewriteRule ^(.*)$ https://www.mysite.it/$1 [R,L]
      Any suggestions?
×
×
  • Create New...