adrian

Batch Child Editor

Recommended Posts

Juergen    272

Now I have tested it with the browser console. As you can see, there are no JS-errors:

Screenshot_9.thumb.jpg.5a554b1f772a403abcb8a7aedde8e3b2.jpg

In line 165 of the BatchChildEditor.js the checkbox markup will be declared:

bce_toggleControl = '<input type="checkbox" class="' + bce_columnControlClass + '" style="position: relative; top: 2px; margin-right: 4px;" />',

But this markup will not be added next to tableheader cells.

I havent been working with the browser console so far. Maybe I am doing something wrong or I am in the wrong part of the console, but I cannot find an error.

  • Like 1

Share this post


Link to post
Share on other sites
tpr    2,222

Thanks - a script can fail even if there are no errors, eg. in this case probably the markup can't be added because the target element is not found in the DOM (maybe the selector used doesn't match anything). It's hard to tell anything else without seeing it. I would try using console.log(obj.length); where object is the target (jQuery) element. If it's 1 (shown in the console) then it's there, otherwise not.

  • Like 1

Share this post


Link to post
Share on other sites
Juergen    272

OK I have tried the following:

I have added the following  script to the admin.php file

<script type="text/javascript">
a = "test";
console.log(a.length);
obj = bce_toggleControl;
console.log(obj.length);
</script>

The variable a with the content "test" is only to check if the console.log works.

I got the following output:

Screenshot_22.jpg.93a15132b914379bfad097b76e23dd0e.jpg

As you can see the variable "a" has a length of 4 - this is correct.

But the variable "bce_toggleControl" which is responsible for the checkbox doesnt return anything.

I have also tried it with bce_fieldID depending on this snippet

    // add column controls (top, bottom and replace modes)
    $(document).on('loaded', '#' + bce_fieldID, function () {
        addBceColumnControls();
    });

Same result

  • Like 1

Share this post


Link to post
Share on other sites
tpr    2,222

Try adding console.log() directly into BatchChildEditor.js file instead.

Share this post


Link to post
Share on other sites
Juergen    272

Of course :)

Here is what I have added:

        a = "test";
        console.log(a,length);
        console.log(bce_fieldID,length);

   // add column controls (top, bottom and replace modes)
    $(document).on('loaded', '#' + bce_fieldID, function () {
        addBceColumnControls();
    });

And this is what I got:

Screenshot_24.jpg.081992a4f4ac6670d4afbb8a7a75f12e.jpg

As you can see the variable "bce_fieldsetID" consist of 23 letters (= ProcessPageEditChildren)

So this variable of the if statement is there!!!

  • Like 1

Share this post


Link to post
Share on other sites
Juergen    272

What I have found out is the following.

In the JS-file there is the part where the additional function will be created (approx. at line 218)

    function addBceColumnControls() {
         
        //this timeout is a bit of a hack that should be improved in the future
        setTimeout(function () {

            if (bce_isColumnControlsAdded) {
                return false;
            }

            if ($(bce_adminDataTableSelector).length === 0) {
                return false;
            }

            // do not add controls if there is no more than 1 row
            if ($(bce_adminDataTableSelector + ' tbody tr').length <= 1) {
                return false;
            }

            //$(bce_adminDataTableSelector + ' tbody').on('click', 'input[type="checkbox"], i.InputfieldChildTableRowDeleteLink', function () {
            $(bce_adminDataTableSelector + ' tbody').on('click', 'input[type="checkbox"]', function () {
                setColumnControlStates($(this));
            });
            
            // add new controls
            for (var i = 0; i < bce_allowedColumnControls.length; i++) {

                var currentControl = bce_allowedColumnControls[i];

                // skip non-existing elements
                if (!$(currentControl).length) {
                    continue;
                }

                // get index of first checkbox in the first row
                var index = $(bce_adminDataTableSelector + ' ' + currentControl + ':eq(0)').parent().index();

                // do the add
                $(bce_adminDataTableSelector + ' th:eq(' + index + ')').prepend($(bce_toggleControl));

                // set initial checkbox states
                setColumnControlStates($(bce_adminDataTableSelector + ' th:eq(' + index + ') input'));

                // add event
                addColumnControlEvent(bce_adminDataTableSelector, currentControl, index);
            }

            // disable thead break to multiline
            $(bce_adminDataTableSelector + ' thead').css('white-space', 'nowrap');

            bce_isColumnControlsAdded = true;

            return true;

        }, 1000);

    }

There are a lot of if-statements depending on the length of a variable.

It is not possible to log the variables inside this function. Fe. if I want to check the variable length of the second if statement

if ($(bce_adminDataTableSelector).length === 0) {
                return false;
            }

with console.log(bce_adminDataTableSelector.length); or console.log($(bce_adminDataTableSelector).length); nothing will be returned, so maybe the if-statements doesnt work in this case.

  • Like 1

Share this post


Link to post
Share on other sites
tpr    2,222

Yepp, the main goal would be to detect where it stops at your side :) 

Btw "variable length" in these cases are the number of items found in the DOM. So if it's 0 for "$(bce_adminDataTableSelector).length" it means the html tag is not found in the DOM.

I guess you can't provide login details via PM, that would make things easier :) 

  • Like 1

Share this post


Link to post
Share on other sites
Juergen    272

If you write "bce_adminDataTableSelector.length instead of ($(bce_adminDataTableSelector).length) it will return 41 instead of 0 after clicking the tab. It seems that $ before causes a problem.

Share this post


Link to post
Share on other sites
tpr    2,222

The search is over, thanks to @Juergen providing login to the site in question. I have modified the way the controls are added, now it happens when you hover on the admindatatable, this seems to be the most reliable way. See the modified file attached.

BatchChildEditor.js

  • Like 3

Share this post


Link to post
Share on other sites
adrian    7,667

Thank you both for getting to the bottom of this!

@tpr - I did tweak your changes slightly to use "one" and "mouseover":

    $(document).one('mouseover', bce_adminDataTableSelector, function () {

instead of "on" and "hover":

    $(document).on('hover', bce_adminDataTableSelector, function () {

so that it's triggered only once. I know you had another check in there to see if the controls were already added, but I still think this an improvement. Do you see any issues with this change?

  • Like 1

Share this post


Link to post
Share on other sites
tpr    2,222

Thanks, I also think yours is better. At the time I wrote the original Js I wasn't aware of .one(), I would use that too.

  • Like 1

Share this post


Link to post
Share on other sites
Pretobrazza    7

Hi,

I'm using PW 3.0.61  with PHP7 and yesterday I downloaded this module as I urgently need to import coordinates to link those pages to my map in the frontend.  As I'm using  Leaflet Map Marker in the admin, the subfields in the 'map' table in the database are:

map.data map.lat map.lng map.zoom map.status
e.g. Albatrosstraat, Knokke-Heist, BE 51.34085 3.242333 18

-100

As I have to import 1000's of pages, I have no option but to work by batch georefferring and csv imports.

I tried everything to make the import of the subfields work but to no avail. Could it be that the module is not compatible with PW 3.0.61  or that Leaflet Map Marker has other settings, or am I missing something somewhere?

I tried to pair CSV column number and Processwire field names as in:

1:title
2:
map.data (tried map.address too)
3:map.lat
4.map:lng etc. 

 

 

Share this post


Link to post
Share on other sites

I am trying to import several child pages using a cvs file. All normal field types are importing without a problem, but when importing 'ProFields Textareas' fields, these fields are not being populated with the specified data form the CSV file.

My Textareas field type is named “chartNumbers”, which contains 3 ‘Textarea Definitions’: “fieldfrom”, “fieldto”, fieldsplit”.

I have written the ‘CSV filed pairings’ in my page settings like this:

1:title
2:page_shorttitle
3:page_subtitle
4:page_summary
5:chartNumbers.fieldfrom
6:chartNumbers.fieldto
7:chartNumbers.fieldsplit

I believe that the above field parings are correct based on what I read in this post .

Having spent almost 5-hours trying to figure this out, my brain has decided to give up at 5:30am.

Can anybody tell me what I’m doing incorrect (if that is the case), or help me figure out what is going wrong.


My setup:  PW v3.0.61 Master, ProFields Textareas v0.0.7,  Batch Child Editor v1.6.6

Share this post


Link to post
Share on other sites
On 12/05/2017 at 5:38 AM, CodeCoffeeCode said:

My setup:  PW v3.0.61 Master, ProFields Textareas v0.0.7,  Batch Child Editor v1.6.6

Ive just updated to PW v3.0.62.  As Pretobrazza mentioned on May 3rd in this post, I think there maybe a compatibility issue with this module when trying to import 'ProFields Textareas - Textarea Definitions' fields.

Any help would be useful. It is impossible to import these fields using the 'Import pages from CSV' module,  I've several hundred pages to import that require these fields populating.

Share this post


Link to post
Share on other sites
bernhard    1,322

hi codecoffeecode,

you can try to use something like my solution for your import if you are only doing the import once (and not need your users to be able to import anything). it's very easy to import all kinds of data like this. adrian will be offline for some weeks...

hope that helps ;)

  • Like 1

Share this post


Link to post
Share on other sites
adrian    7,667

Hi @Pretobrazza and @CodeCoffeeCode - I am sorry for the very long delay in responding - I have just returned from an extended time away from my computer.

It looks like the issues you were having with textareas fields and the map marker were actually due to PHP 7. The latest version should fix things - I tested with textareas which now work perfectly again - hopefully map marker fields will also work again now.

I have also fixed some other issues with adding multiple new child in Edit mode and also taken care of this issue.

Please let me know how things work for you now.

  • Like 3

Share this post


Link to post
Share on other sites
titanium    61

Adrian, let me first say "thank you so much" for this great module - it's incredibly helpful.

I think I have found a small bug. When one or more quotes are used in the title of the page, the "edit" section breaks, see attached screenshot. I have now seen this across different installations, so I think it hasn't to do with my setup.

Batch Child Editor is latest version 1.6.7, ProcessWire is 3.0.65

screenshot.thumb.png.cbb81380f4f777a84bce9f68844de2cf.png

  • Like 1

Share this post


Link to post
Share on other sites
adrian    7,667

Hi @titanium - sorry for the delay - turns out this was a new problem with the multi-language title info that was added recently.

Please test the latest version and let me know if you have any further problems.

  • Like 2

Share this post


Link to post
Share on other sites
Klenkes    67

Just ran into a funny problem.
Well... not really funny, but it took me way too long to figure it out. (Sometimes I wonder how get through the day...)

I am developing the migration of 10+ similar sites from another CMS to PW. All the websites have lots of fields and data, and BCE is the only way to map the data to textareas subfileds. All tests worked great so far until now!

Suddenly I was unable to input my fieldpairings. 

ProcessWire: ProcessPageEdit: SQLSTATE[22001]: String data, right truncated: 1406 Data too long for column 'data' at row 1

As I said it took me way too long to realize the "Data too long for column data"

During my testing the database field 'data' got filled up with all the settings for all the parent pages, and since it is of type text, I guess 64kb is the limit.

I had to uninstall and reinstall BCE to start over with an empty data field.

I guess there is no real solution to this but I wanted to add it here in case somebody faces the same dilemma.

  • Like 2

Share this post


Link to post
Share on other sites
adrian    7,667

@Klenkes - a simple solution to this would be for you to manually change the "data" field in the "modules" db table from "text" to "mediumtext". I'll see if I can get Ryan to do it in the core so it's always available.

https://github.com/processwire/processwire-issues/issues/321

Edited by adrian
Added link to new Github issue
  • Like 2

Share this post


Link to post
Share on other sites
Klenkes    67

I thought about mediumtext but don't know what "unwanted" effect it may have on other PW functions.

I went the even more simple way and import now to a single import page, and then move the imported pages with your great AdminActions to their destination parents. This way I don't have to configure all parent pages with my fieldpairings.

BTW... thank you very much for AdminActions. Without Move and Search and Replace this project wouldn't be possible.

  • Like 4

Share this post


Link to post
Share on other sites
Klenkes    67

Me again... I imported a few hundred pages to more than 30 parents and almost everthing is fine.

Then I noticed that all custom ids and classes in my imported textareas were filtered out during save, even with deactivated ACF and HTML Purifier(in textareas settings) Pasting in the same HTML in source mode afterwards leaves the custum stuff alone. So it works.

I don't even know wether it's a BCE issue or with Profields textareas? This problem seems familiar but I can't remember...

  • Like 1

Share this post


Link to post
Share on other sites
adrian    7,667
7 hours ago, Klenkes said:

Me again... I imported a few hundred pages to more than 30 parents and almost everthing is fine.

Then I noticed that all custom ids and classes in my imported textareas were filtered out during save, even with deactivated ACF and HTML Purifier(in textareas settings) Pasting in the same HTML in source mode afterwards leaves the custum stuff alone. So it works.

I don't even know wether it's a BCE issue or with Profields textareas? This problem seems familiar but I can't remember...

I do use the $sanitizer->purify option with all content added via BCE, so that will be the source of the problem for sure. I can see two possible options here.

1) Add a BCE config setting to enable you to turn off the purifier sitewide and/or per parent page.
2) Check the purifier status for the field that the content is being added to and respect that.

Any thoughts?

PS if you want a quick fix, just edit this line:
https://github.com/adrianbj/BatchChildEditor/blob/ba228d2f011d306345f02ec4aa19d090f2d89481/BatchChildEditor.module#L1448

Share this post


Link to post
Share on other sites
Klenkes    67

That explains a lot ;)

For the sites I migrate to PW option 1 would me my choice, because importing the content is the first priority and editing the content comes later. Nobody wants to sift through a few hundred pages to make it all like it was. In my case editors are skilled, trusted and would be fired if they do monkeybusiness with the HTML.

...but then again... option 2 would work as well since I already deactivated all the purifier options for the fields anyway.

For now I will go with the dirty fix >:D

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By antoiba86
      I am a bit confused, because I don't know how to solve this problem.
      When I install the module Languages Support - Page Names, my web falls apart.
      I have all the necessary modules installed as Language support for example.
      This is the error I get in the admin panel.
      Warning: Invalid argument supplied for foreach() in /hosting/www/antoibaprogramming.com/public/wire/modules/LanguageSupport/LanguageSupportPageNames.module on line 107 Warning: Invalid argument supplied for foreach() in /hosting/www/antoibaprogramming.com/public/wire/modules/LanguageSupport/LanguageSupportPageNames.module on line 198 Warning: Invalid argument supplied for foreach() in /hosting/www/antoibaprogramming.com/public/wire/modules/LanguageSupport/LanguageSupportPageNames.module on line 1011 Warning: Invalid argument supplied for foreach() in /hosting/www/antoibaprogramming.com/public/wire/modules/LanguageSupport/LanguageSupportPageNames.module on line 1011 Warning: Invalid argument supplied for foreach() in /hosting/www/antoibaprogramming.com/public/wire/modules/LanguageSupport/LanguageSupportPageNames.module on line 1041
      And this in the front-end.
      Warning: Invalid argument supplied for foreach() in /hosting/www/antoibaprogramming.com/public/wire/modules/LanguageSupport/LanguageSupportPageNames.module on line 107
      Fatal error: Call to a member function get() on null in /hosting/www/antoibaprogramming.com/public/wire/modules/LanguageSupport/LanguageSupportPageNames.module on line 605 Fatal error: Call to a member function get() on null in /hosting/www/antoibaprogramming.com/public/wire/modules/LanguageSupport/LanguageSupportPageNames.module on line 605
    • By kongondo
      The Module Blog for ProcessWire replicates and extends the popular Blog Profile.
      Blog is now in version 2.
      Please read the README in the Github link below in its entirety before using this module 
      Blog Documentation is here (Work in Progress!)
      See this post for new features in version 2 or the readme in GitHub.
      To upgrade from version 1, see these instructions.
      ##################################################
      Most of the text below refers to Blog version 1 (left here for posterity). 
       
      Blog version 1 consists of two modules:
      ProcessBlog: Manage Blog in the backend/Admin.
      MarkupBlog: Display Blog in the frontend.
      Being a module, Blog can be installed in both fresh and existing sites. Note, however, that presently, ProcessBlog is not compatible with existing installs of the Blog Profile. This is because of various structural and naming differences in respect of Fields, Templates, Template Files and Pages. If there is demand for such compatibility, I will code a separate version for managing Blog Profile installs.
      In order to use the 'Recent Tweets Widget', you will need to separately install and setup the module 'MarkupTwitterFeed'.
      Please read the README in the Github link below in its entirety before using this module (especially the bit about the Pages, etc. created by the module). 
      I'll appreciate Beta testers, thanks! Stable release works fine.
      Download
      Modules Directory: http://modules.processwire.com/modules/process-blog/
      Github: https://github.com/kongondo/Blog
      You can also install from right within your ProcessWire install.
      Screenshots (Blog version 1)

      Video Demos
      ProcessBlog
      MarkupBlog
      Credits
      Ryan Cramer
      The Alpha Testers and 'Critics' 
      License
      GPL2
    • By bernhard
      hi everybody,
      this is a preview of a module that i'm working on for quite a long time. I needed it for an intranet office management application that i'm still working on. It makes it very easy to create very customized Datatables using the awesome jquery datatables plugin (www.datatables.net)
       
      EARLY ALPHA release!
      It's very likely that there will lots of changes to this module that may cause breaking your implementations.
       
      Module source
      sorry, removed as it changes too frequently; closed alpha - contact me if you think you can contribute
       
       
      Remarks:
      The module is intended to be used on the backend. Loading styles is at the moment only done via adding files to the $config->styles/scripts arrays. Also the communicaton to javascript is done via the $config->js() method that is built into the admin and would have to be implemented manually on frontend use. But it would not be difficult of course
      Installation:
      Nothing special here, just download + install
       
      edit: removed some parts, because i made a complete rewrite of the module! (see last posting in the thread)
       
      Customization example:
      in the screencast you see an example that i'm using in a process module. i put the table inside an InputfieldMarkup just to have the same look&feel all around the admin. you see that you could also use this module to create tables quickly and easily using @kongondo s runtime markup module.
      complete PHP code:
      $this->headline('Kundenliste'); $form = $modules->get('InputfieldForm'); // init datatables module $dt2 = $modules->get('RockDataTables2'); // setup columns // name $col = new dtCol(); $col->name = 'name'; $col->title = 'Name'; $col->data = function($page) { return $page->title; }; $dt2->cols->add($col); // type $col = new dtCol(); $col->name = 'type'; $col->data = function($page) { return $page->rockcontact_type->title; }; $dt2->cols->add($col); // modified $col = new dtCol(); $col->name = 'modified'; $col->data = function($page) { $obj = new stdClass(); $obj->timestamp = $page->modified; $obj->display = date('d.m.Y', $page->modified); return $obj; }; $dt2->cols->add($col); // setup table $dt2->id = 'dt_kundenliste'; $dt2->js('/site/modules/ProcessRockProjects/dt_kundenliste.js'); $f = $modules->get('InputfieldMarkup'); $f->value = $dt2->render(); $form->add($f); // ################################## // ajax request -> return data // non-ajax -> render form + table // ################################## if($config->ajax) { echo $dt2->getJSON($pages->find('template=rockcontact, sort=random, limit=10000')); die(); } else $out .= $form->render(); return $out; what is interesting here is this part:
      // modified $col = new dtCol(); $col->name = 'modified'; $col->data = function($page) { $obj = new stdClass(); $obj->timestamp = $page->modified; $obj->display = date('d.m.Y', $page->modified); return $obj; }; $dt2->cols->add($col); datatables support orthogonal data (https://datatables.net/extensions/buttons/examples/html5/outputFormat-orthogonal.html). a date column is a good example, because you need to DISPLAY a formatted date (like 10.02.2017) but you need to be able to SORT this column by a different value (timestamp). its very easy to accomplish this by providing both values in your json. Btw: You could also just transfer the timestamp and do the formatting on the client-side via javascript. Next Example will show ho this would work. Both cases can be necessary, it's just an example here.
      [...] removed
      Why i created this module:
      of course i know @Soma s module but i needed a lot more features and the newer datatables version. also i like to define all the columns as objects and have everything on one place. lister & markupadmindatatable: nice for basic tables but lacks of features to modify the appearance of the cell values (like rendering icons, background colors and so on) datatables provides a great frontend API for filtering, showing/hiding columns, getting data, modifying it... it also plays well together with frontend charts like google chart api in this case:
       
      todo / roadmap:
      all kinds of column filters (like seen in the example above that shows an older and bloated version of this module) support for ajax filters and pagination (currently all filtering and sorting is done on the client side. i tried it with up to 50.000 rows and got reasonable results. initial loading took around 10sec. but of course this heavily depends on the complexity of your table and your data.  
       
       
    • By Robin S
      PageListTrash
      Allows non-superusers to trash pages directly from Page List (if they have page-delete permission for that page).
      Not much to say really - the module adds a "Trash" option to the extra actions for pages in Page List. It looks and works just like the Trash action available to superusers.

      https://github.com/Toutouwai/PageListTrash/
       
      Up to you whether you think non-superusers should be trusted with simpler trashing. For most cases I like the default behaviour where editors have to jump through some more hoops - I want them to think carefully about what they are doing. But if an editor needs to trash several pages then this module might reduce frustration.
      @tpr, by now you can probably predict what I'm going to say...
      ...something to merge into AdminOnSteroids?
    • By horst
      Wire Mail SMTP

      An extension to the new WireMail base class that uses SMTP-transport

      This module integrates EmailMessage, SMTP and SASL php-libraries from Manuel Lemos into ProcessWire. I use this continously evolved libraries for about 10 years now and there was never a reason or occasion not to do so. I use it nearly every day in my office for automated composing and sending personalized messages with attachments, requests for Disposition Notifications, etc. Also I have used it for sending personalized Bulkmails many times.

      The WireMailSmtp module extends the new email-related WireMail base class introduced in ProcessWire 2.4.1 (while this writing, the dev-branch only).
       
      Here are Ryans announcement.



      Current Version 0.2.5
      get it from the Modules Directory Install and Configure

      Download the module into your site/modules/ directory and install it.

      In the config page you fill in settings for the SMTP server and optionaly the (default) sender, like email address, name and signature.
      You can test the smtp settings directly there. If it says "SUCCESS! SMTP settings appear to work correctly." you are ready to start using it in templates, modules or bootstrap scripts.


      Usage Examples
      The simplest way to use it:
      $numSent = wireMail($to, $from, $subject, $textBody); $numSent = wireMail($to, '', $subject, $textBody); // or with a default sender emailaddress on config page This will send a plain text message to each recipient.
       
      You may also use the object oriented style:
      $mail = wireMail(); // calling an empty wireMail() returns a wireMail object $mail->to($toEmail, $toName); $mail->from = $yourEmailaddress; // if you don't have set a default sender in config // or if you want to override that $mail->subject($subject); $mail->body($textBody); $numSent = $mail->send(); Or chained, like everywhere in ProcessWire:
      $mail = wireMail(); $numSent = $mail->to($toEmail)->subject($subject)->body($textBody)->send(); Additionaly to the basics there are more options available with WireMailSmtp. The main difference compared to the WireMail BaseClass is the sendSingle option. With it you can set only one To-Recipient but additional CC-Recipients.
      $mail = wireMail(); $mail->sendSingle(true)->to($toEmail, $toName)->cc(array('person1@example.com', 'person2@example.com', 'person3@example.com')); $numSent = $mail->subject($subject)->body($textBody)->send(); The same as function call with options array:
      $options = array( 'sendSingle' => true, 'cc' => array('person1@example.com', 'person2@example.com', 'person3@example.com') ); $numSent = wireMail($to, '', $subject, $textBody, $options); There are methods to your disposal to check if you have the right WireMail-Class and if the SMTP-settings are working:
      $mail = wireMail(); if($mail->className != 'WireMailSmtp') { // Uups, wrong WireMail-Class: do something to inform the user and quit echo "<p>Couldn't get the right WireMail-Module (WireMailSmtp). found: {$mail->className}</p>"; return; } if(!$mail->testConnection()) { // Connection not working: echo "<p>Couldn't connect to the SMTP server. Please check the {$mail->className} modules config settings!</p>"; return; } Following are a ...


      List of all options and features


      testConnection () - returns true on success, false on failures


      sendSingle ( true | false ) - default is false

      sendBulk ( true | false ) - default is false, Set this to true if you have lots of recipients (50+)


      to ($recipients) - one emailaddress or array with multiple emailaddresses

      cc ($recipients) - only available with mode sendSingle, one emailaddress or array with multiple emailaddresses

      bcc ($recipients) - one emailaddress or array with multiple emailaddresses

       
      from = 'person@example.com' - emailaddress, can be set in module config (called Sender Emailaddress) but it can be overwritten here

      fromName = 'Name Surname' - optional, can be set in module config (called Sender Name) but it can be overwritten here


      priority (3) - 1 = Highest | 2 = High | 3 = Normal | 4 = Low | 5 = Lowest

      dispositionNotification () or notification () - request a Disposition Notification


      subject ($subject) - subject of the message

      body ($textBody) - use this one alone to create and send plainText emailmessages

      bodyHTML ($htmlBody) - use this to create a Multipart Alternative Emailmessage (containing a HTML-Part and a Plaintext-Part as fallback)

      addSignature ( true | false ) - the default-behave is selectable in config screen, this can be overridden here
      (only available if a signature is defined in the config screen)

      attachment ($filename, $alternativeBasename = "") - add attachment file, optionally alternative basename


      send () - send the message(s) and return number of successful sent messages


      getResult () - returns a dump (array) with all recipients (to, cc, bcc) and settings you have selected with the message, the message subject and body, and lists of successfull addresses and failed addresses,


      logActivity ($logmessage) - you may log success if you want

      logError ($logmessage) - you may log warnings, too. - Errors are logged automaticaly
       
       
      useSentLog (true | false) - intended for usage with e.g. third party newsletter modules - tells the send() method to make usage of the sentLog-methods - the following three sentLog methods are hookable, e.g. if you don't want log into files you may provide your own storage, or add additional functionality here

      sentLogReset ()  - starts a new LogSession - Best usage would be interactively once when setting up a new Newsletter

      sentLogGet ()  - is called automaticly within the send() method - returns an array containing all previously used emailaddresses

      sentLogAdd ($emailaddress)  - is called automaticly within the send() method
       
      Changelog: https://github.com/horst-n/WireMailSmtp/blob/master/CHANGELOG.md