Jump to content

WireMailSmtp


horst

Recommended Posts

On 5/29/2018 at 2:57 PM, ethanbeyer said:

@Jon this sounds a little strange. Reading most of your comment, I would think that this might have something to do with your Office365 having sending limits that you're going over. The TLS issue is what makes it weird, though - because if it was a limits problem, that would not be happening.

Is there anything in the logs that gives what error is encountered, rather than saying it just stops sending?

Hello Ethan,

Nothing in the logs I've now setup sendinblue and this has resolved the issues so I assumes its 365 like you suggested. The limit would be odd though as its not sending out that many emails

Cheers

Jon

Link to comment
Share on other sites

  • 2 weeks later...
  • 7 months later...

We are getting the "WireMailSmtpConfig: ERROR: SMTP settings did not work" error with these settings (real address replaced with ***). 

Local hostname: www.***.com
SMTP Hostname: ***.mail.protection.outlook.com
SMTP Port: 25
SMTP User: (required to be left empty)
SMTP Password: (required to be left empty)
Use START-TLS: Yes

Authentication is made using something called O365 (assuming it means Office 365). Could this be the reason nothing works? Does WireMail: SMTP even work with user and password left empty?

What does the Authentication Mechanism stand for? An IP address?

In the front end when trying to submit from by Formbuilder I get "Notice: Undefined index: replyToName in ***.com/httpdocs/wire/core/WireMail.php on line 319

Link to comment
Share on other sites

1 hour ago, MSP01 said:

Authentication is taken care of by something else in this case.

Based on what you have provided so far, here are some links that may or may not help you with your situation:

https://www.fastmail.com/help/technical/ssltlsstarttls.html

https://www.limilabs.com/blog/ssl-vs-tls-vs-starttls-stls

https://www.sparkpost.com/resources/email-explained/ssl-tls-starttls-encyption/

 

 

  • Like 1
Link to comment
Share on other sites

  • 3 weeks later...

I am having trouble setting this module up on the client's webspace. 

Locally it works like charme with the given data (as seen here - only in German: https://www.ionos.de/hilfe/e-mail-office/allgemeine-themen/einstellungen-fuer-ihr-e-mail-programm/)

Locally I use SSL via port 465 (host: smtp.ionos.de)

After copying the whole processwire installation to the clients webspace I updated the hostname but then out of the sudden the SMTP server isn't reachable anymore via SSL (nor TLS). Only unecrypted connections are working. Is there anything obvious I am missing? 

Thanks a lot for your support!

 

Link to comment
Share on other sites

Is hosting provided by 1&1 as well?

If so... you could ask their support if you have to use another server/port or whatever in that case.

Have you tried another mail service like Gmail? Does that work?

If so... 1&1 might have the right answer.
if not... there is another problem.

What's the complete error message WireMailSmtp shows?

  • Like 1
Link to comment
Share on other sites

On 2/25/2019 at 9:22 PM, wbmnfktr said:

Is hosting provided by 1&1 as well?

If so... you could ask their support if you have to use another server/port or whatever in that case.

Have you tried another mail service like Gmail? Does that work?

If so... 1&1 might have the right answer.
if not... there is another problem.

What's the complete error message WireMailSmtp shows?

Yes, the site is also hosted on 1&1. 

 

And no, also gmail does not work. So proabably something wrong with 1und1. Will ask the support. 

Error message is

Quote

ERROR: SMTP settings did not work. +1
could not connect to the host "smtp.ionos.de": Connection timed out

 

Thanks for pointing me to the obvious things ?

Link to comment
Share on other sites

  • 4 weeks later...

Hi Horst,

would it be possible to implement a feature that overwrites the configuration variables (server, password...) from a config or .env File?
We've got several sites that do auto-deployments to different servers based on the git branch that is used. Currently, when deploying the local development version to a staging system we're copying the dev database and need to adjust the settings by "hand" (we've written a script for that). Having a file based configuration would make it possible to just dump a file on the server and save the config variables in it.

  • Like 1
Link to comment
Share on other sites

54 minutes ago, felix said:

Hi Horst,

would it be possible to implement a feature that overwrites the configuration variables (server, password...) from a config or .env File?
We've got several sites that do auto-deployments to different servers based on the git branch that is used. Currently, when deploying the local development version to a staging system we're copying the dev database and need to adjust the settings by "hand" (we've wrote a script for that). Having a file based configuration would make it possible to just dump a file on the server and save the config variables in it.

Just in case it's helpful, this is what I do for Tracy - anything that is defined in the $config->tracy() array overwrites the settings stored in the DB.

https://github.com/adrianbj/TracyDebugger/blob/3f1fb2cf0016b8b27cc1019f47e58bce8e2cbd3d/TracyDebugger.module.php#L322-L325

  • Like 1
  • Thanks 1
Link to comment
Share on other sites

14 hours ago, felix said:

would it be possible to implement a feature that overwrites the configuration variables (server, password...) from a config or .env File?

Hi @felix, I don't want to enable plain text files with server & password settings, but going with the already needed and available site/config.php, as @adrian suggested, seems to be fine. (As it already stores the DB-credentials).

I try to look into it and implement it this weekend. I think this can be useful for a lot of us.

  • Like 3
Link to comment
Share on other sites

Announcement:

I've created a new branch on github with the requested feature by @felix. Please can you and / or anybody else try this out and give some feedback. If everything is working as expected, I will push this to the master branch.

Short introduction:

You can specify how many and what ever params you want into an array that is called $config->wirmailsmtp. Every valid key of this array will override the key of the stored modules config setting.

// example entry in site/config.php

$config->wiremailsmtp = array(
    "smtp_host"                => "smtp.example.com",
    "smtp_port"                => 587,
    "smtp_ssl"                 => 0,
    "smtp_start_tls"           => 1,
    "smtp_user"                => "yourusersname",
    "smtp_password"            => "youruserspassword",
    "extra_headers"            => array("Organization" => "Horst Nogajski - Fotografie & Webdesign", "X-Header" => "Some Content")
);

To see your resulting (merged) settings you can var_dump the output of the method getSettings():

// debug example in a template file

$mail = wireMail();
echo "<pre>";
var_dump($mail->getSettings());

wiremailsmtp-config-override.png.6fa9a907d37c147f41333cc1add60864.png

I tested it here myself and it seems to work fine.

 

EDIT:

I forgott to mention that I removed the required flags from the modules config settings for smtp_host and smtp_port.
This way, both settings now may stay empty in the config screen, but can be set via the $config->wiremailsmtp array. The downside would be that the modules config screen isn't that robust anymore in regard of misconfiguration.

Is this acceptable, or should there also be a required setting in the modules config screen? This is open for discussion. ?

 

Edited by horst
EDIT
  • Like 7
Link to comment
Share on other sites

  • 3 weeks later...

Hi @horst

I just wanted to draw attention to a problem that might affect some in the future if TLS (or STARTTLS) is used.

I wasn't sure where to put my concerns, so I decided to write them down in the support forum. 

Some email hosting providers will shut down TLS 1.0 support in the future (or already did so). The way your module currently relies on the SMTP class (when using PHP version >= 5.6.7) it only (and exclusively) supports TLS version 1.0 (see here https://github.com/horst-n/WireMailSmtp/blob/master/smtp_classes/smtp.php#L1295).

The issue is better described by one comment on the PHP forum: https://www.php.net/manual/en/function.stream-socket-enable-crypto.php#119122.

Can you maybe integrate an option to allow specifying one of the available PHP crypto type constants?

Hopefully I don't bother you with this and maybe it is useful for somebody.

Thank you for your work in any case!

 

  • Like 1
Link to comment
Share on other sites

We'd like to send email from WireMailSMTP using G Suite. Google offers three different options:

https://support.google.com/a/answer/176600?hl=en

We've tried every variant we can, without success. For anyone using G Suite, which Google option works for you? What settings have you used in G Suite admin, and which settings have you used in the WireMailSMTP config?

(We have enabled the "allow less secure apps" option, and are not using 2-factor authentication.)

Your help is much appreciated.

 

Link to comment
Share on other sites

6 hours ago, chcs said:

We'd like to send email from WireMailSMTP using G Suite. Google offers three different options:

https://support.google.com/a/answer/176600?hl=en

We've tried every variant we can, without success. For anyone using G Suite, which Google option works for you? What settings have you used in G Suite admin, and which settings have you used in the WireMailSMTP config?

(We have enabled the "allow less secure apps" option, and are not using 2-factor authentication.)

Your help is much appreciated.

 

This has been resolved. The issue was with the WHM firewall.

  • Like 1
Link to comment
Share on other sites

On 4/18/2019 at 2:36 PM, androbey said:

Can you maybe integrate an option to allow specifying one of the available PHP crypto type constants?

Hi @androbey,

I have created a dev-branch on github with the requested functionality. Please can you try it out and give some feedback?
   https://github.com/horst-n/WireMailSmtp/tree/5600cb0230531327438d6a333b2c8a3eb29cc08d

There is also a new $mail->debugSend() method available that you can use instead of the regular $mail->send() method.
With calling the debugSend() method in a template file you will get detailed log information like this:

C STARTTLS
S 220 2.0.0 Ready to start TLS
Starting TLS cryptographic protocol
TLS started: STREAM_CRYPTO_METHOD_TLSv1_2_CLIENT

 

Spoiler

Resolving SMTP server domain "www.example.com"...
Connecting to SMTP server "www.example.com" port 587...
Connected to SMTP server "www.example.com".
S 220 www.example.com ESMTP
C EHLO wiremailsmtp.kawobi.local
S 250-www.example.com
S 250-PIPELINING
S 250-SIZE 102400000
S 250-VRFY
S 250-ETRN
S 250-STARTTLS
S 250-AUTH PLAIN LOGIN
S 250-AUTH=PLAIN LOGIN
S 250-ENHANCEDSTATUSCODES
S 250-8BITMIME
S 250 DSN
C STARTTLS
S 220 2.0.0 Ready to start TLS
Starting TLS cryptographic protocol
TLS started: STREAM_CRYPTO_METHOD_TLSv1_2_CLIENT
C EHLO wiremailsmtp.kawobi.local
S 250-www.example.com
S 250-PIPELINING
S 250-SIZE 102400000
S 250-VRFY
S 250-ETRN
S 250-AUTH PLAIN LOGIN
S 250-AUTH=PLAIN LOGIN
S 250-ENHANCEDSTATUSCODES
S 250-8BITMIME
S 250 DSN
C AUTH PLAIN bTAxZTY5ZWIAbTAxZTY5ZWIARU1zaVdnc3VzMUVoZXBNdTI=
S 235 2.7.0 Authentication successful
C MAIL FROM:<info@nogajski.de>
C RCPT TO:<info@nogajski.de>
C DATA
S 250 2.1.0 Ok
S 250 2.1.5 Ok
S 354 End data with <CR><LF>.<CR><LF>
C To:  <info@nogajski.de>
Subject: Wiremail-SMTP Test 18:50:39 =?UTF-8?q?=C3=A4=C3=B6=C3=BC_=C3=84=C3=96=C3=9C_=C3=9F?=
From: LocalTestmail <info@nogajski.de>
Return-Path: info@nogajski.de
Reply-To:  <info@nogajski.de>
Organization: Horst Nogajski - Fotografie & Webdesign
X-Mailer: ProcessWire/WireMailSmtp
Date: Fri, 19 Apr 2019 16:50:40 GMT
MIME-Version: 1.0
Content-Type: multipart/alternative; boundary="d9f4656ffd3ae4b2a17b6891ed0a92ad"
Message-ID: <20190419185040.2103.relay@nogajski.de>
C --d9f4656ffd3ae4b2a17b6891ed0a92ad
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: quoted-printable
Titel=0A=0Atext text TEXT text text=0A
--d9f4656ffd3ae4b2a17b6891ed0a92ad
Content-Type: text/html; charset=UTF-8
Content-Transfer-Encoding: quoted-printable
<h1>Titel</h1><p>text text <strong>TEXT</strong> text text</p>
--d9f4656ffd3ae4b2a17b6891ed0a92ad--
C 
.
S 250 2.0.0 Ok: queued as 4CDD02C0143E
C QUIT
S 221 2.0.0 Bye
Disconnected.

 

  • Thanks 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...