Jump to content

Vote for ProcessWire to be packaged by BitNami


saml
 Share

Recommended Posts

Just saw (via Gertrud Schrenk) that BitNami (Company that packages popular open source apps into easy to install images in various formats, including AWS cloud images) is having a contest for which apps to include next as a package, where you can vote for ProcessWire.

To quote the site:

 Which application should we package next? You get to decide! Since the beginning of the year, we have been running a contest every month. The winning app gets added to the Bitnami Application Library, providing easy to use installers, virtual machines and cloud images.

Please, all go and vote for PW at: bitnami.com/contest !  :)

Cheers

  • Like 5
Link to comment
Share on other sites

I voted already for two rounds but no chance.

Ah, I thought it was one single contest, defining the order in which they will implement these later ...

Doing multiple contests must indeed make folks give up on this :/

Link to comment
Share on other sites

You have to admire their social networking strategy. I think there are a lot of folks like me that have never heard of them, and these contests make their brand known. We derive the same benefit... it helps us whether we "win" the contest or not, as seeing ProcessWire on the first page may help get it on the radar of other visitors that don't already know about it. 

  • Like 4
Link to comment
Share on other sites

You have to admire their social networking strategy. I think there are a lot of folks like me that have never heard of them, and these contests make their brand known. We derive the same benefit... it helps us whether we "win" the contest or not, as seeing ProcessWire on the first page may help get it on the radar of other visitors that don't already know about it. 

Indeed :)

And now, processwire is already at 6th place, and should be able to get to at least 3rd place with just a dozen more votes, so I think doing a little concerted sharing around this might well be worth it. (Better to do it all one time and win the contest, than spread it out and never win :) )

(Bitnami is quite well known among Amazon AWS cloud users, btw, being one of the most active AWS image producers)

Link to comment
Share on other sites

I think there are a lot of folks like me that have never heard of them

BitNami comes bundled with XAMPP. You have to actively deselect it on installation if you don't want it. Would be good for awareness if PW could make it in ...

  • Like 1
Link to comment
Share on other sites

BitNami comes bundled with XAMPP. You have to actively deselect it on installation if you don't want it. Would be good for awareness if PW could make it in ...

And since XAMPP is used by developers often, not a bad place to be listed.

  • Like 1
Link to comment
Share on other sites

@fmgujju: Thanks for the kind words :) It could use some refinement by a real graphic designer though ...

... and, just to get back to the topic for a moment (no pun intended, logo discussion is interesting :) ), PW is making quite some progress on the bitnami contest :) ... could use a few more votes and sharing though, to get past the no 1 and 2! :)

Link to comment
Share on other sites

Just done another tweet to my handful of followers:

https://twitter.com/Joss_Sanglier/status/423744548498464769

Cool. Recommended to include the link as well! :)

I also realized yesterday that if linking to the processwire page (http://bitnami.com/product/processwire), the tweet is sometimes counted as a vote (which they indeed also say), while of course the main contest link (http://bitnami.com/contest) is not.

Made the mistake to only link the contest page, a few times.

  • Like 1
Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Similar Content

    • By JeevanisM
      Hi,
      I have installed 1 year old project backup into the new latest PW version. I used an earlier backup(taken in August 2020) and installed such as :
      1. I downloaded the latest (ProcessWire 3.0.185 dev © 2021) then extracted into htdocs 2. copy pasted the site-profile from my backup. (this has the files/folders same as other site profiles, classic, beginner etc) 3. I chose my backup site profile and installed 4. I am able to login the admin panel  5. My fronted home page shows error as below  Error: Exception: SQLSTATE[42S22]: Column not found: 1054 Unknown column 'page_path_history.language_id' in 'field list' (in wire/modules/PagePathHistory.module line 752) #0 wire/modules/PagePathHistory.module (752): PDOStatement->execute() #1 wire/core/PagesPathFinder.php (1014): PagePathHistory->getPathInfo('/', Array) #2 wire/core/PagesPathFinder.php (222): PagesPathFinder->getPathHistory('/') #3 wire/core/PagesRequest.php (255): PagesPathFinder->get('/', Array) #4 wire/core/Wire.php (414): PagesRequest->___getPage() #5 wire/core/WireHooks.php (951): Wire->_callMethod('___getPage', Array) #6 wire/core/Wire.php (485): WireHooks->runHooks(Object(PagesRequest), 'getPage', Array) #7 wire/modules/Process/ProcessPageView.module (10 This error message was shown because: you are logged in as a Superuser. Error has been logged.
       
      so I removed the line where its selecting language_id from the file wire/modules/PagePathHistory.module line 752
      But this is an ugly fix, so is there any other proper fix for this issue ? Does any one experience same issue when trying to install from a backup site profile ? 

       

       
       thanks
       
    • By ErikMH
      I’m new to Processwire. I’ve installed the current release version at my very-long-time (25 years) host, pair Networks. MySQL db is created. Installation process completed with no errors.
      I’m now trying to log in. Rather than taking the default `/admin` suggestion, I chose `/xyzzy`. When I go to `example.com/xyzzy`, PW displays a login screen, as expected. I enter the username (`xyzzy`) and password that I assigned (and copied and stored in 1Password) in the installation process (five words separated by hyphens). So far, so good.
      I would expect then to be taken to the admin pages. Or (if I got something wrong) to be given an error message. Instead, I’m taken to the URL `example.com/xyzzy/page/?login=1`, which as far as I can tell is exactly the same as the initial login page. No error is given.
      I grew so frustrated by this, that I deleted the entire installation and the MySQL database, re-downloaded PW, installed it again using a different username and password for the admin account.
      And I’m seeing exactly the same behavior. Time for me to ask you experts: WTF?
      Many thanks for any insights you may have....
       
    • By Grigorij Schleifer
      Hello processwire community, I am a total CMS beginner and I am trying to install processwire on my mac.
      I have downloaded processwire using git and loaded the location, where the files where downloaded into chrome, safary or opened the location from the terminal. No installation guide startet. I just typed the directory location into the browsers url address bar and could see all the files that were downloaded. When I tried to open installl.php file, my browser just showed me the code.
      I think I am missing something trivial. Do I need to install a specific PHP version and MySQL first? Or do I need to set up an Apache server first. 
      I am very thankful for every suggestion/help I can get.
      Thank you
    • By codevark
      The Minimal Site works fine, but if I try to login as admin, I have no idea what the credentials are.
      I did not do the "install" process myself. The OVA came with everything set up, but there's no mention of the PW admin credentials being set to some initial value.
      Wondering if anyone else has tried the Bitnami OVA and if there's a simple answer.
      --Pete
    • By Nik Groningen
      Hi,
      Currently I'm developing a platform and use Processwire for some of the backend. Everything is working very well on localhost, but the installation on namecheap does not complete. I've read some comments on this forum that mentioned hosting on namecheap (without mentioning issues). 
      Attached is a screenshot of the last step of the installation. It looks very similar to the problem mentioned in this thread: https://processwire.com/talk/topic/15516-processwire-do-not-complete-installation/. Unfortunately, this didn't help me. I also attached a picture of the server. In the error_log, i do get some error messages related to includes and requires like:
      [18-Jun-2020 03:42:32 America/New_York] PHP Fatal error:  require(): Failed opening required '/home/niklcicr/public_html/wire/config.php' (include_path='.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php') in /home/niklcicr/public_html/wire/core/ProcessWire.php on line 1199
      On the last screen, the console outputs a internal server error 500.
      That's what I tried: Installation on another server (freeinfinity) and it worked fine, installation on another namecheap account (did not work), and I adjusted the .htaccess file according to other threads in this forum that had similar problems (did not work).
      Is there anyone who got Processwire to work on namecheap hosting or can point me in the right direction? 
      Thanks in advance,
      Nik


×
×
  • Create New...