Nico Knoll

Error 503 when saving a page

Recommended Posts

Hey,

for some reason a client of mine gets an error 503 "Service Temporarily Unavailable" when she tries to save a page. Saving templates and fields, etc. works like it should be...

It's only when trying to save a page or empty the bin...

Any idea?

Greets,

Nico

Share this post


Link to post
Share on other sites

Most likely something with mod_security. Try creating a template that has nothing but a 'title' field, then create a page using that template and save. I'm guessing that'll work, because the POST has no HTML in it. Some hosts using mod_security just aren't friendly with rich text editors, especially multiple instances on the same submission. You'll want to ask your host how to disable mod_security. 

  • Like 1

Share this post


Link to post
Share on other sites

Same answer as before. :) Saving a template does not include a $_POST variable with embedded HTML, so it's not going to trigger mod_security. Mod_security doesn't like $_POST or $_GET variables with embedded HTML, especially more than one of them (like body and sidebar). Basically your web host has to disable that aspect of mod_security, as it is definitely not CMS friendly. You may also be able to resolve it by making sure you have not more than 1 field with HTML in it (i.e. just a "body" field). This is not uncommon, because WordPress typically only has 1 HTML field present, so some hosts configure their mod security to allow 1 through and not more. Personally though, I would not use a web host placing this kind of restriction unless the hosting is free. 

  • Like 1

Share this post


Link to post
Share on other sites

Im getting a 503 if I save a Page with CKEditor, but only when there is a external link inside … 

Share this post


Link to post
Share on other sites

I had this kind of problems when trying to save hanna codes (TextformatterHannaCode).

My host then disabled some security rules. After that it worked.

 

Share this post


Link to post
Share on other sites

Just yesterday I ran into a similar problem.

Saving the page didn't work at all. Hat to update some content (15 000+ characters) on a page.
All in a regular textarea field without any min/max content settings.

The result of saving the page was...

1. console log error

Resource interpreted as Document but transferred with MIME type application/x-httpd-php

2. file download of a file named Download with this in it.

<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>503 Service Unavailable</title>
</head><body>
<h1>Service Unavailable</h1>
<p>The server is temporarily unable to service your
request due to maintenance downtime or capacity
problems. Please try again later.</p>
</body></html>

Couldn't figure out why this happened and still happens.

Tried the exact same on different servers/instances (Dev/Stage/Live) of that site with the result:

  • Dev - a local Laragon instance: works
  • Stage - US Shared Hosting: works
  • Live - DE Shared Hosting: breaks

Same ProcessWire and module versions across all instances.

Seems to be a server/hosting thing.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.