Jump to content

Can't save in the backend


Recommended Posts


ran into a weird problem I'm not sure how to debug:

I can't save anything in the backend, including of templates/fields/names/structure. If i try to change the title I get Session: Change: title, but no change. But I can delete pages.

It started happening on the live site, and after copying it's the same locally – so its something specific with setup.

No errors in apache_error.log, mysql_error_log.err, php_error.log or in PW's errors.txt (!)

Version is ProcessWire 2.2.9, PHP 5.4.4



Edited by joe_g
Link to comment
Share on other sites

I'd try to clear the browser cache (and logout/login again), and/or update to latest stable version, and/or run some sort of browser dev tool to see possible JS errors / warnings. (and maybe even trying to access the backend with a different browser altogether)

  • Like 3
Link to comment
Share on other sites

Beyond what Dragan mentioned, it'd also be good to look at what 3rd party modules you have installed, just in case any of them are interfering. For instance, 2.2.9 is now an older version of PW, so you may have a module that was meant for 2.3+. 

Link to comment
Share on other sites

I tried dragans suggestion (different browser) - worked great.  I suppose that means there are more complicated stuff stored in the session, rather than just 'logged in yes/no'

The only more complicated stuff stored in the session would be CSRF protection. But I don't think that was the problem here, otherwise you'd get an error message telling you about forged requests. What browser were you using before where it wasn't working?

Link to comment
Share on other sites

  • 2 weeks later...

I'm also having this problem. In Chrome, this message is not appearing (and edits are not being saved):

Session: Saved Page: /connect-through-academics/new-411/ (1 change)

Things work as expected in Firefox. I have the latest version of Chrome (Version 31.0.1650.63 m) and I am on a PC.

I don't have any additional Admin themes installed.

Link to comment
Share on other sites

  • 3 weeks later...


It was another install with version 2.2.9 using latest chrome.

I'm trying to recreate the problem but not succeeding, if I manage I'll post the rest of the information.

I'm not sure if it said 'saved page' but I remember the green fields indicating a change of the field.


Link to comment
Share on other sites

  • 2 weeks later...
  • 4 weeks later...

I'm having (for the first time) a similar problem. The thing is I have 2 Page fields in one template which no matter what I select, their values won't get saved. The page is saved and there's a notification, but nothing is saved on those 2 fields. The rest of the page (text fields) are working ok. The crazy thing is that those same 2 fields are present on another template and they work fine!  This ocurrs only on the production website. Everything works ok locally. I'm using PW 2.3.1

What could this be? I'm using the Date Archiver module, but both templates use it! I'm lost!!

Link to comment
Share on other sites

  • 1 year later...


hope it's alright to add my problem to this thread?

So, I just realised couple of days ago that I'm not able anymore to change my own user roles.

They just won't get saved and I'm not getting any information. Debug mode is on.

It just says "Saved Page: /access/users/admin/" and that's it. I'm editing via /access/users/edit/?id=41

and after saving it adds &s=1 to the url so everything seems to be fine.

All other fields work as expected, and the roles field is working for all other users, too. (I tried 3 or 4 others)

Same problem on localhost and live site.

I'm running 2.6 stable. I noticed this after the last update fo the first time but I don't know if it is related, probably it came up before.

What else can I provide?

I haven't synced those to installs for a long time now, and I would say it worked within that period (but I could be wrong) so probably it's related to one of the last updates?

Hope you guys have some hints for me :-)


Link to comment
Share on other sites

  • 1 year later...

Just for the record: I just had the problem that pages with a certain template did not save content any more.

There was the green notification "Saved" but the changed fields have forgotten any changes made.

The reason was that I had a fieldset in the template in the wrong order: The fieldset_END part was before the opening fieldset part. Maybe there was some inadvertent dragging of the wrong field. (tested with ProcessWire 3.34)

Maybe this is useful to know for someone having the same mystery issue.


This issue was solved in PW 3.35

Edited by ceberlin
This issue is solved
  • Like 4
Link to comment
Share on other sites

  • 1 year later...

I'm having the exact same problem now as Can posted - for the first time ever.

I cloned a template last Friday, set up a few fieldsets, and now if I edit and save any page that uses my OLD template, the fields won't get saved. No matter if it's a text field, checkbox or page reference.

I checked if fieldsets were in the wrong order - everything look OK.

I get the usual yellow confirmation at the top:

Session: Saved Page: /projekte/website-hans-muster-ag-standard-project-template/

and the URL looks OK too:
URL: page/edit/?id=10202&s=1&c=0

No JS errors in the console. I've never seen anything so weird. Thank God this is happening on a dev environment, not live...

I tried it with all 3 installed themes, and with both Chrome + Firefox.

PW 3.0.108

Edited by dragan
added note about themes + browsers
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...