adrian

Custom Upload Names

Recommended Posts

Hi @adrian

Thank you for your efforts in this module.

I faced a problem with js in CUN on 67 line

data[i]['enabledPages'] = $(this).find('input[id=enabledPages'+i+']').val().split(",");

bit if I uncomment the previous line it works

if($(this).find('input[id=enabledPages'+i+']').length !== 0) data[i]['enabledPages'] = $(this).find('input[id=enabledPages'+i+']').val().split(",");

Variant with if statement looks more logical for me, but I'm curious is there any reason why you have commented it? 

Share this post


Link to post
Share on other sites

Hi @Zeka - sorry for the delay - hope you read elsewhere that I was away for quite some time.

I have just been looking at this, and I can't find any problems with the current code - can you please explain the problem you are having?

At the moment I also can't see why the version with the check wouldn't be more correct, but I also can't see why it should actually be necessary. If you can let me know more, perhaps I can reproduce and figure out the best approach.

Share this post


Link to post
Share on other sites

Thank you for the plugin, it works great! Is there any way to have it so that it allows you to put it in a custom folder? This would be great because then it will make a backup of my image directory a lot more organized.

I tried /$page->title/{$page->title}-randstring[nn]

But it removed my slashes in the final output so it was just $page->title-{$page->title}-randstring[nn]

Thank you.

Share this post


Link to post
Share on other sites
23 minutes ago, cjrobe said:

Thank you for the plugin, it works great! Is there any way to have it so that it allows you to put it in a custom folder? This would be great because then it will make a backup of my image directory a lot more organized.

I tried /$page->title/{$page->title}-randstring[nn]

But it removed my slashes in the final output so it was just $page->title-{$page->title}-randstring[nn]

Thank you.

Hi @cjrobe - I am glad you are finding the module useful.

Unfortunately I think what you are looking for is beyond the scope of this module. Changing the paths to files/images is an entirely different problem to changing their filenames. I honestly think you should ask why you really want them stored under the title of the page - what if you change the title of a page at some point - then the file will be in an incorrectly named folder. Page IDs (which is how it works now) will always be the same. If you really want to go down this road, have a read here: https://processwire.com/talk/topic/9544-how-to-change-imagefiletemplate-path/

 

Share this post


Link to post
Share on other sites

Silly me - I hadn't yet realized that ProcessWire stores all attachments from a page in a folder with the page ID! I can then just export to CSV the IDs/Titles of all the pages and I'm sure there's some sort of batch rename tool that can handle that data easily.

Sorry for misunderstanding and thanks again for your plugin.

  • Like 1

Share this post


Link to post
Share on other sites

Hello @adrian

could you please check this notice:

PHP Notice: Trying to get property of non-object in .../ProcessCustomUploadNames.module:194

Thanks

Share this post


Link to post
Share on other sites
1 hour ago, Juergen said:

Hello @adrian

could you please check this notice:


PHP Notice: Trying to get property of non-object in .../ProcessCustomUploadNames.module:194

Thanks

Thanks @Juergen - late here, so will look at better in the morning, but could you please check if it's $file, $repeater, or $rf that is triggering that?

I am assuming you either have no files uploaded to that field, or no items in the repeater yet.

Thanks!

Share this post


Link to post
Share on other sites

Hello @adrian,

sorry for the long delay, but I was 12 hours at work. I am sorry, but I dont know how to check which triggers that.:huh:The strange thing is that the notice disappears if I refresh the same page. After a while the error appears again. This happens on different pages with one or more pictures.

Share this post


Link to post
Share on other sites
1 minute ago, Juergen said:

I am sorry, but I dont know how to check which triggers that.

Just do a bd() call on each of those variables just before that line - one of them will likely return null.

Share this post


Link to post
Share on other sites

Its late here in Austria. I will take a look tomorrow.

Share this post


Link to post
Share on other sites

Hello @adrian

I am not sure if I am doing the check right: I added the bd function on line 193 on ProcessCustomUploadNames.module file (remember the notice message points to line 194)

I check the variables by using bd($file), bd($repeater) and bd($rf) on that line. The results are:

1) bd($file):

Screenshot(4).png.53e5ba533ccdab9b4a42903942c218b8.png

2) bd($repeater):

Screenshot(5).png.4d7614bd64c4d24d67f40d9ab189f6b7.png

3) bd($rf):

Screenshot(6).png.034eef643583e85ff2b2ee0123ae5200.png

I hope this could be helpful to you - but maybe I have done something wrong during the check.

Best regards

Share this post


Link to post
Share on other sites

Thanks @Juergen  - I don't really understand why you are getting those results for $file - I can't reproduce, but maybe you could just test this for me:

Replace this:

foreach($repeater->{$rf->name} as $file) {
    $files[$file->name] = $repeater->id.'|'.$rf->id; // add filename with respective repeater pageid and fieldid to array
}

with:

foreach($repeater->{$rf->name} as $file) {
    if(!$file) continue;
    $files[$file->name] = $repeater->id.'|'.$rf->id; // add filename with respective repeater pageid and fieldid to array
}

Check that the notice is gone and that everything still works as expected.

Thanks!

  • Like 1

Share this post


Link to post
Share on other sites

Hello @adrian,

I have implemented your fix and for the moment everthing seems to work fine. If I discover any issues I will post it.

Thanks

  • Like 1

Share this post


Link to post
Share on other sites

@adrian

Hello Adrian,

I am using your module and completely clueless about one thing.

Your code has this place

elseif($field->type instanceof FieldtypeRepeater) {
                    foreach($editedPage->{$field->name} as $repeater) {

                        //make sure repeater item actually exists already, which is important when you have added items beyond those initially rendered.
                        //fixes this issue: https://github.com/ryancramerdesign/ProcessWire/issues/1541
                        if(!$repeater->id) continue;

                        foreach($repeater->fields as $rf) {
                            if($rf->type instanceof FieldtypeFile) {
                                if(count($repeater->{$rf->name})) {
                                    foreach($repeater->{$rf->name} as $file) {
                                        if(!$file) continue;
                                        $files[$file->name] = $repeater->id.'|'.$rf->id; // add filename with respective repeater pageid and fieldid to array
                                    }
                                }
                            }
                        }
                    }
                }
            }

However, when I save a page which has a repeater with empty single image, I got a notice

<b>Warning</b>:  count(): Parameter must be an array or an object that implements Countable in <b>C:\t2cms\site\assets\cache\FileCompiler\site\modules\ProcessCustomUploadNames\ProcessCustomUploadNames.module</b> on line <b>204</b><br />

The reason is that image is empty and is NULL.

I tried to debug your module using PW admin, namely by moving the same page and checking the output. And surprise, there was no notice... Instead of NULL, empty Pagefields object had been passed.

Is there a hook in PW or your module which returns empty Pagefields array instead of NULL for single empty image. For me the issue is only reproducable for image inside a Repeater.

Thanks in advance!

Share this post


Link to post
Share on other sites

Hi @simonsays - firstly, that is just a warning coming from PHP 7.2. I need to adapt that code to handle the way the 7.2 now works with `count()`. I am curious though, because the warning you are getting says line 204, but the count is on line 202 in the current version. Are you running 1.0.9 or an older version?

Despite the line number difference, I can't replicate the error. Typically outputformatting is off in a module, which means even a single image field will return an array, but in this module I do turn it on when creating the new filename so that dates/times are formatted as expected. Perhaps this is what is causing the issue. Could you please send me your settings for CustomUploadNames and also the settings for the image field in question so I can try to replicate?

Thanks.

Share this post


Link to post
Share on other sites
14 hours ago, adrian said:

Hi @simonsays - firstly, that is just a warning coming from PHP 7.2. I need to adapt that code to handle the way the 7.2 now works with `count()`. I am curious though, because the warning you are getting says line 204, but the count is on line 202 in the current version. Are you running 1.0.9 or an older version?

Despite the line number difference, I can't replicate the error. Typically outputformatting is off in a module, which means even a single image field will return an array, but in this module I do turn it on when creating the new filename so that dates/times are formatted as expected. Perhaps this is what is causing the issue. Could you please send me your settings for CustomUploadNames and also the settings for the image field in question so I can try to replicate?

Thanks.

@adrian

Sorry about the line number confusion, I did insert two debugging lines when trying to reproduce/debug (I use the latest module version).

And yes, it is PHP 7.2. Should have mentioned as well.

There are actually two workarounds for my problem - either mark output format as an array in admin (a quick fix) or set repeater outputFormatting to false before saving the page (more bullet proof).

This helps me for now, but I am still curious, why this does not happen when I use PW admin. As if outputFormatting for the repeater (not for the page itself) is explicitly set to false elsewhere

Here are my settings:

39bce551-bb2b-4d63-8c9c-2019f7f049ed.png

Edited by simonsays

Share this post


Link to post
Share on other sites

@simonsays - not sure exactly what is going on, but I just noticed that with this module running it's sometimes possible to upload more than one image to a single image field in a repeater - I think this might be the cause of the issue. I just commented out line 160 of this module:

$editedPage->of(false);

and it seems to be behaving better but I am not sure of other ramifications just yet. Would you mind doing a quick test at your end though and let me know if that solves things please? Be sure to return the image field to automatic and any other things you may have tweaked.

Share this post


Link to post
Share on other sites

@simonsays - any luck with that change noted in my last post?

I think that is probably your issue and I'd like to commit the change if you can confirm it works for you.

Thanks!

Share this post


Link to post
Share on other sites
On 9/16/2018 at 11:34 PM, adrian said:

@simonsays - any luck with that change noted in my last post?

I think that is probably your issue and I'd like to commit the change if you can confirm it works for you.

Thanks!

Sorry, @adrian will get back to you asap. Rather busy with current sprint 🙂

Just tested. Without explicitly going through all the repeaters prior to save and setting their formatting to false, I got exactly the same result.

Edited by simonsays
grammar

Share this post


Link to post
Share on other sites
On 9/18/2018 at 5:21 AM, simonsays said:

Without explicitly going through all the repeaters prior to save and setting their formatting to false

I'm afraid I don't understand this - how are you setting them to false? Are you saving pages via the API, rather than the admin backend? 

Share this post


Link to post
Share on other sites

The module was working great...until it stopped working so great.

Now when I hit 'Save' on the template (with "Rename on Save" is checked) the page clears the image fields on template that are targeted for renaming. The image fields are blank, 0kb images.

I tried disabling the part of the module that was renaming the images and uploading at least went back to normal. Uninstalling and re-installing, the problem persists.

The The HTML Entity Encoder was enabled on all the image fields, but the name of the last image that 'broke' the module for me was named something like "Artist-Name-------------Oil-on-Canvas------32-in-x-45-in-$1000.png" is that helps.

My renaming convention for the images was just the page title:  img-{$page->title)

 

Share this post


Link to post
Share on other sites

Hi @PCuser - sorry you're having problems.

I just tested with an image with exactly that filename and it worked just fine.

I wonder if there is something else at play here. Any chance you could do a little debugging? Firstly try on a clean PW install and if that works, see if it's some other module that is conflicting. Or perhaps it's specific image field settings at play. Does it work with a newly created image field with default settings?

You get the idea 🙂

Share this post


Link to post
Share on other sites
On 9/24/2018 at 10:08 PM, adrian said:

I'm afraid I don't understand this - how are you setting them to false? Are you saving pages via the API, rather than the admin backend? 

@adrian

Yes, I am doing it via API, but I found a workaround.

Share this post


Link to post
Share on other sites
On 9/28/2018 at 8:43 AM, adrian said:

Hi @PCuser - sorry you're having problems.

I just tested with an image with exactly that filename and it worked just fine.

I wonder if there is something else at play here. Any chance you could do a little debugging? Firstly try on a clean PW install and if that works, see if it's some other module that is conflicting. Or perhaps it's specific image field settings at play. Does it work with a newly created image field with default settings?

You get the idea 🙂

 

@adrian

I have come across a similar issue.

My filename pattern is {$page->name}-{$file->filesize}-[YmdHis]. Rename on save is checked.

The plan was to avoid caching, both on server side and on the client side, as our prod servers have several layers of cache.

I tested with image field inside a repeater and crop functionality.

Initially the image is uploaded fine and replacing image also works.

However, when I crop it and save the page, the image still gets the old path (which is now broken), both in admin and on the front-end.

I looked into both the DB and the filesystem. DB record (field value) is not updated and stays the same on crop. However, image filename is updated.

Once again - this happens on crop, inside a repeater field.

I tested without a repeater and indeed, it works fine.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Robin S
      Another little admin helper module...
      Template Field Widths
      Adds a "Field widths" field to Edit Template that allows you to quickly set the widths of inputfields in the template.

      Why?
      When setting up a new template or trying out different field layouts I find it a bit slow and tedious to have to open each field individually in a modal just to set the width. This module speeds up the process.
      Installation
      Install the Template Field Widths module.
      Config options
      You can set the default presentation of the "Field widths" field to collapsed or open. You can choose Name or Label as the primary identifier shown for the field. The unchosen alternative will become the title attribute shown on hover. You can choose to show the original field width next to the template context field width.  
      https://github.com/Toutouwai/TemplateFieldWidths
      https://modules.processwire.com/modules/template-field-widths/
    • By horst
      Croppable Image 3
      for PW 3.0.20+
      Module Version 1.1.16
      Sponsored by http://dreikon.de/, many thanks Timo & Niko!
      You can get it in the modules directory!
      Please refer to the readme on github for instructions.
       
      -------------------------------------------------------------------------
       
      Updating from prior versions:
       
      Updating from Croppable Image 3 with versions prior to 1.1.7, please do this as a one time step:
      In the PW Admin, go to side -> modules -> new, use "install via ClassName" and use CroppableImage3 for the Module Class Name. This will update your existing CroppableImage3 module sub directory, even if it is called a new install. After that, the module will be recogniced by the PW updater module, what makes it a lot easier on further updates.
      -------------------------------------------------------------------------
       
      For updating from the legacy Thumbnail / CropImage to CroppableImage3 read on here.
       
      -------------------------------------------------------------------------
       
    • By MoritzLost
      UPDATE: I have published a stable version of this module!
      Discussion thread:
      Github: https://github.com/MoritzLost/TextformatterPageTitleLinks
      ---
      Hello there,
      I'm working on a tiny textformatter module that searches the text for titles of other pages on your site and creates hyperlinks to them. I'm not sure if something like this exists already, but I haven't found anything in the module directory, so I wrote my own solution 🙂
      It's not properly tested yet and is still missing some functionality I would like to implement, so at the moment it should be considered in BETA. Features include limiting the pages that will get searched by template, and adding a custom CSS class to the generated hyperlinks. As I'm writing this I noticed that it will probably include unpublished and hidden pages at the moment, so yeah ... it's still in development alright 😅
      You can download the module from Github:
      https://github.com/MoritzLost/TextformatterPageTitleLinks
      There's some more information in the readme as well.
      Anyway, let me know what you think! I'm happy about any feedback, possible improvements or ideas on how to improve the module. Cheers.
    • By blad
      Hi guys!
      I just uploaded a module to explore files based on elFinder. By default it will show the "Files" folder.
      Screenshots:

      Video:
       
      To do:
       More options To fix:
       The function of rotating or scaling an image fails  Image editors V 1.01 (view issue)
      Fixed the bug working with the Multi-Language support ( translation of folders ). Fixed the name of elfinder.en  Github:
      https://github.com/LuisSantiago/ProcessElFinder/
      I hope you like it.
    • By BitPoet
      I'm really in love with FormBuilder, but the one thing missing to match all my end users' expectations were repeatable field groups. Think repeaters, in ProcessWire terms. Our primary application of PW is our corporate intranet, so "lines" of fields are quite common in the forms I build. We have all kinds of request forms where the information for a varying number of colleagues needs to be entered (from meal order to flight booking request) and where it is simply impractical to send a form for each, and I don't want to clutter my forms with multiple instances of fields that may only get used ten percent of the time.
      That's why I started to build FormBuilderMultiplier (link to GitHub).
      What it does:
      Adds an option to make a regular Fieldgroup repeatable Lets you limit the number of instances of a Fieldgroup on the form Adds an "Add row" button the form that adds another instance of the Fieldgroup's fields Adds a counter suffix at the end of every affected field's label Stores the entered values just like regular fields Makes the entered values available in preview and email notifications Supports most text based fields, textareas and selects (really, I haven't had enough time to test all the available choices yet) What it doesn't do (yet):
      Support saving to ProcessWire pages (i.e. real Repeaters) I haven't tested all the validation stuff, Date/Time inputs etc. yet, but since I'm utterly swamped with other stuff at work, I didn't want to wait until I have it polished. Any feedback is welcome. There might also be some issues with different output frameworks that I haven't encountered yet. The forms I work with mostly use UIKit.
      Status:
      Still alpha, so test well before using it in the field.
      Known issues:
      When rows are added, the form's iframe needs to be resized, which isn't completely clean yet.
      How it works:
      The Fieldgroup settings are added through regular hooks, as is the logic that adds the necessary field copies for processing the form and displaying previews.
      "Multiplied" field instances are suffixed with _NUM, where NUM is an incremental integer starting from 1. So if you have add two fields named "surname" and "givenname" to a fieldgroup and check the "multiply" checkbox, the form will initially have "surname_1" and "givenname_1" field (I'm still considering changing that to make the risk to shoot oneself into the foot by having a regular "surname_1" field somewhere else in the form less likely).
      When a "row" is added, the first row is cloned through JS and the counter in the fields' IDs, names and "for" attributes as well as the counter in the label are incremented before appending the copies to the Fieldset container in the form.
      To keep backend and frontend in sync, a hidden field named [name of the fieldset]__multiplier_rows is added to the form. Both the backend and the frontend script use this to store and retrieve the number of "rows".
      ToDo:
      Naturally, add the option to store the data in real repeaters when saving to pages. Do a lot of testing (and likely fixing). Make a few things (like the "Add row" button label etc.) configurable in field(set) context. Add a smooth API to retrieve the multiplied values as WireArrays. The mandatory moving screenshot: