Jump to content
haha

host changed ,then can not login

Recommended Posts

sometimes ago there i got an error of "aborted" when i log in. then now I got error of " login fail"

i dont; know what to do with the problem. I have tried of change password with a tech tip in forum but nothing changed I got "login fail" still.
 

Share this post


Link to post
Share on other sites

Hello haha,

one question: Have you reinstalled processwire and after transferred the templates + database ?

The password are "salted" with a key defined in /site/config.php. This key must be the same as previous installation, if not you cannot login.

/**
 * Installer: User Authentication Salt
 *
 * Must be retained if you migrate your site from one server to another
 *
 */
$config->userAuthSalt = '[alphanumeric string]';
Edited by Alessio Dal Bianco

Share this post


Link to post
Share on other sites

Hello haha,

one question: Have you reinstalled processwire and after transferred the templates + database ?

The password are "salted" with a key defined in /site/config.php. This key must be the same as previous installation, if not you cannot login.

/**
 * Installer: User Authentication Salt
 *
 * Must be retained if you migrate your site from one server to another
 *
 */
$config->userAuthSalt = '[alphanumeric string]';

no reinstallation. the Salt is excatly the same one

Share this post


Link to post
Share on other sites

Got same problem, thing is i downloaded newes dev version of pw, and now forget password plugin dont work. Usualy i just reseted password and it worked.

If u have stable version of PW then all u need to do is reset your password when logging in.

EDITED,

Ok it works its my bad, previously  you had to enter email address now system asking you for username.

So ye best way to do this is to reset your password with this plugin, if u dont have it installed then i propose to install it on your local then copy database again to your destination server along with the module files. then when loging in u will have forget password button, enter email address or username (depends on your PW version). and wait for email. Change your password and thats it.

I had same problem once now i allways isntall forget password module (its in core)

Edited by vxda

Share this post


Link to post
Share on other sites

Got same problem, thing is i downloaded newes dev version of pw, and now forget password plugin dont work. Usualy i just reseted password and it worked.

If u have stable version of PW then all u need to do is reset your password when logging in.

EDITED,

Ok it works its my bad, previously  you had to enter email address now system asking you for username.

So ye best way to do this is to reset your password with this plugin, if u dont have it installed then i propose to install it on your local then copy database again to your destination server along with the module files. then when loging in u will have forget password button, enter email address or username (depends on your PW version). and wait for email. Change your password and thats it.

I had same problem once now i allways isntall forget password module (its in core)

is there any easy way?  I still have my old host file back up. and password of pw with old host is still nice logged

Share this post


Link to post
Share on other sites

If u can install forget password module on your destination server then its easy.


if u cant u have to install module on your local, then export it to your destination server when u do that, just try to login in on your destination server and use module to reset password. That allways works for me, and this is how im doing it.

Meaby someone have better solution.

Share this post


Link to post
Share on other sites

You can install a module from code in a template for example.

$modules->get("ModuleName")

If not installed it will install it.

But you can also just set a new password with code.

$u = $users->get("admin");

$u->pass = "xpassword";

$u-save();

If nothing works maybe clear session folder and cache folder.

  • Like 1

Share this post


Link to post
Share on other sites

tried some ways

none works for me

just

"This request was aborted because it appears to be forged."

Share this post


Link to post
Share on other sites

For Soma's code to reset the password above, you might also need to add a $u->of(false); to turn off output formatting, before doing the save. 

But the "request aborted" message you are getting makes me think there's a file system write problem and sessions aren't saving. Your actual /site/assets/ might be writable, but is everything in it writable? I'm guessing not. You probably need to do a recursive reset of the permissions in there so that the server can write to it. On a unix system where you wanted to make it globally readable/writable you'd do it like this: 

chmod -R og+rw /site/assets/

That may not be the appropriate setting for your server, so it's one to check with your host about if you want to ensure the best security. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...