Jump to content

.htaccess trouble with bitnami MampStack


Recommended Posts


I'm using Bitnami MampStack on my OSX (newest version of everything).

I got the SQL database created and I got Processwire installed with "green lights" everywhere, but after the installation - pretty much nothing happens. I only get the "Basic Example Site" page under http://localhost:8080/ProcessWire-master/, but notheing else works.

Everything points to .htaccess, but there is no .htacces files anywhere to be edited. I tried reading up on the topic, but it soon became overwhelming and went over my head so to speak..

Would it be possible to get a little help? I have very little sever-side knowledge as I'm basically just a front end dev who would like to get to know processwire from exactly that point of view. The back end guys abviously allready have processwire installed on their servers, but they don't run macs and I want to get to know processwire locally and test modules in a sandboxed enviroment...

The Bitnami Stack system is a development enviroment and you can install it for free from the App store and try installing Processwire on it and see where it stalles... Even greater would be if there would be a Stack with Processwire pre-installed in the stack! :)


Looking forward for some help!

Link to comment
Share on other sites

Given that PW installed properly, I assume you managed to change htaccess.txt to .htaccess?

It might not be visible now though. Does entering the following in your terminal help: 

defaults write com.apple.Finder AppleShowAllFiles YES

Once you can edit the .htaccess file at the root of your site, try uncommenting some of the rewrite base options - probably the first one will do the trick.

Link to comment
Share on other sites

Thank you very much for a swift reply!

defaults write com.apple.Finder AppleShowAllFiles TRUE

killall Finder

That worked, and I can open and edit .htaccess

I uncommented the rewrites and saved, then installed.

but no.

after installation, there is still no /processwire directory . The installer shows green everywhere.

Just making sure, where should I put the ProcessWire-master folder containing the installation? I have it in the root of my "apache2/htdocs" that I use for development. Should it go somewhere else, like in the apps folder where phpmyadmin resides or something?

...getting closer, but not quite there yet.

Link to comment
Share on other sites

It depends on whether you want one or several dev websites set up under htdocs. You can do root, but chances are you'll want more than one, so subfolders would make sense.

Also, if you haven't seen it, check out DNSMasq - it will make multiple sites a breeze - trust me and take the time to set this up! Here are some instructions for MAMP setup that might be handy: http://eddmann.com/posts/the-ultimate-mamp-setup-hands-down/

There shouldn't be a processwire directory - htaccess will take care of redirecting something like localhost/processwire to the admin panel, assuming you left the admin as "processwire"

Regarding the rewrite base - make sure you only uncomment one at a time, not all. I would assume the first would work if you installed processwire in htdocs. 

Link to comment
Share on other sites

Check your server error log in case the problem is un-related to .htaccess. You may also find some errors in siteroot/site/assets/log/error.txt. What specifically about admin isn't working are you getting a 500 error, a blank page, etc? More info will help.

Link to comment
Share on other sites

  • 1 year later...

Getting the same problem.

No error in the log file.

<title>404 Not Found</title>
<h1>Not Found</h1>
<p>The requested URL /lliriajuventud/processwire was not found on this server.</p>
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...