Jump to content

Can't change page titles from admin


Roope
 Share

Recommended Posts

I have very strange problem on one little multilingual site that has only default language set at the moment. I can only edit Title field of Home page but all others are uneditable. The text that was used on creation rolls back after page save. Title is editable via API though.

Site is build on dev branch. Just pulled latest updates but no change. There is only admin hotkeys and emo modules installed (except language support). Default language changed to finnish and here is only error that system throws on page save: Session: Missing required value (_pw_page_name)

Could this be some bug on PageTitleLanguage module or is there something obvious I'm just missing again? I have no problems on any other projects developed from same branch.

Link to comment
Share on other sites

OK, so I was able to reproduce this scenario: when you use PageTitleLanguage fieldtype with only default language installed, content of the Title field is not editable. Content does not change after page save. Problem is solved when you install more languages to PW.

Maybe this thread should be moved to Multi-Language Support forum instead where we can discuss is this even bug since why would you need PageTitleLanguage field with only default language installed. Well, I did so because we will have different languages for the site in the future but first release will be only in finnish.

  • Like 1
Link to comment
Share on other sites

I'd consider that a bug. There are reasons to install language support even with only 1 language, like if you want to take advantage of static translation capability in template files. I've added this as an issue on GitHub, and I'm hoping to get through the current queue of issues here over the next few days. 

  • Like 2
Link to comment
Share on other sites

  • 2 weeks later...
  • 4 years later...
  • 3 years later...

Bit me once again today :)

In this case I did have that module installed, but even after disabling it, I still had issues with a particular template where I had specifically set noLang in the advanced template settings, so watch out for that. 

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...