Jump to content
horst

Page Image Manipulator 1

Recommended Posts

Horst: Thanks for the very detailed explanation, It is just happening on the last image or two. It must be a PHP memory getting low (shared hosting account). I will use the PNG watermark method instead.  (thanks for the code example).

Update: my shared hosting account on this site is giving me 64mb of RAM memory limit. I think that might be the issue right there. I tried the PNG method of watermarking, but my site still hangs my server or larger batches 20 images@1,000px.

Share this post


Link to post
Share on other sites

 Update: my shared hosting account on this site is giving me 64mb of RAM memory limit. I think that might be the issue right there. I tried the PNG method of watermarking, but my site still hangs my server or larger batches 20 images@1,000px.

Have you tried to increase it in the .htaccess file?

php_value memory_limit 128M
#php_value memory_limit 256M
  • Like 1

Share this post


Link to post
Share on other sites

Still looking for a workaround to my problem. I'm going to try running it on a slightly newer server configuration to see if it helps.

Does anyone know if would it be possible to implement this as a hook when I upload images using a certain field?

Share this post


Link to post
Share on other sites

Hi, horst!

After updating PW to the latest dev yesterday, i've getting this on pimLoad():
 

Fatal error: Exception: You do not have permission to execute this module - ProcessCropImage (in D:\OpenServer\domains\5520.pro\wire\core\Modules.php line 717)
#0 D:\OpenServer\domains\5520.pro\wire\core\Modules.php(668): Modules->getModule('ProcessCropImag...')
#1 D:\OpenServer\domains\5520.pro\site\modules\PageImageManipulator\ImageManipulator.class.php(254): Modules->get('ProcessCropImag...')
#2 D:\OpenServer\domains\5520.pro\site\modules\PageImageManipulator\PageImageManipulator.module(185): ImageManipulator->__construct(Object(Pageimage), Array, false)
#3 D:\OpenServer\domains\5520.pro\wire\core\Wire.php(381): PageImageManipulator->getPageImageManipulator(Object(HookEvent))
#4 D:\OpenServer\domains\5520.pro\wire\core\Wire.php(317): Wire->runHooks('pimLoad', Array)
#5 D:\OpenServer\domains\5520.pro\site\templates\docs-product.php(12): Wire->__call('pimLoad', Array) #6 D:\OpenServer\domains\5520.pro\site\templates\docs-product.php(12): Pageimage->pimLoad('test')
#7 D:\OpenServer\domains\5520.pro\wire\core\TemplateFile in D:\OpenServer\domains\5520.pro\index.php on line 220

any suggestions?

Share this post


Link to post
Share on other sites

Hello everyone,

New to PW and modules etc, so this is a steep learning curve for me at the moment but enjoyable

Using the code below I am getting images to display without problem, now I would like to add a watermark to the images

  • I have installed the PageImageManipulator
  • Have read through the postings on using it but still confused

Is the watermark image stored in the images file or does it have to form part of a template and page?

I have made a template called watermark

  • Should I know make a page called template and upload an image into it?
  • How do I get the watermark to work with the code below

<?php
$images = $page->new_images_field;
foreach($images as $image){

  echo "<img src='{$image->url}' />";
  echo "<br><br><br>";

}

?>

Thank you - Mel

Share this post


Link to post
Share on other sites

@Mel: here is a post that describes how to use a watermark that is uploaded into a single image field (to make an image field a single image field you have to setup the field to only allow 1 file, otherwise, 0 or greater 1 it is a multiple files field): https://processwire.com/talk/topic/4264-release-page-image-manipulator/#entry41883

The general how to you can read in the initial post here in this thread:

* watermarkLogo

watermarkLogo($pngAlphaImage, $position='center', $padding=2)

  • param: $pngAlphaImage - mixed [systemfilepath or PageImageObject] to/from a PNG with transparency
  • param: $position - (string) is one out of: N, E, S, W, C, NE, SE, SW, NW,
    - or: north, east, south, west, center, northeast, southeast, southwest, northwest
    default is 'center'
  • param: $padding - (integer) 0 - 25, default is 5, padding to the borders in percent of the images length!
  • return: pim - (class handle)

You can pass a transparent image with its filename or as a PageImage to the method. If the watermark is bigger than the destination-image, it gets shrinked to fit into the targetimage. If it is a small watermark image you can define the position of it:

The $pngAlphaImage can be a filename (full path and not an url!) or a pageimage.

Example with filename, assumed you have uploaded a png watermark image per FTP to your server into a directory besides wire and site, called "_mystuff":

$png = $_SERVER['DOCUMENT_ROOT'] . '/_mystuff/' . 'basename-of-my-watermark.png';

foreach($images as $image) {
    $watermarked_image = $image->pimLoad('tw', true)->width(500)->watermarkLogo($png, 'southeast', 0)->pimSave();
    echo "<img src='{$watermarked_image->url}' />";
}

An example with png from an imagefield, assumed it is called 'watermarkfield' and is on a page with the name/url '/tools/'. The tools page isn't visible from the frontpage, it is only a page that holds some fields and stuff that I need around the site on different places:

// assumed the watermarkfield is a single image field:
$png = $pages->get('/tools/')->watermarkfield;

// assumed the watermarkfield can have multiple images and I want use the first one:
$png = $pages->get('/tools/')->watermarkfield->first();

foreach($images as $image) {
    $watermarked_image = $image->pimLoad('tw', true)->width(500)->watermarkLogo($png, 'northwest', 0)->pimSave();
    echo "<img src='{$watermarked_image->url}' />";
}

  • Like 3

Share this post


Link to post
Share on other sites

Hello Horst,

Thank you for the instructions on how to use the watermarkLogo it works really well, I used the second example above using the tools page - which also taught me a bit more about how templates and pages interact with each other.

Thanks again - Mel

  • Like 1

Share this post


Link to post
Share on other sites

Hi Horst

Got a little problem.

I have just upgraded my server to apache 2.4 and, more importantly, php 5.5.9

On one dev site I am suddenly getting the following error - it was fine on the old server and older version of php:

Error: Call to undefined function imagecreatefromstring() (line 837 of /home/sanglier/public_html/site/modules/PageImageManipulator/ImageManipulator.class.php) 

What do you reckon?

Share this post


Link to post
Share on other sites

Okay, ignore me....

GD wasn't installed.

Damn, I thought I had done that too.

Share this post


Link to post
Share on other sites

@Joss: you should not use the PHP 5.5.9 - it has a buggy GD-lib, (if has a installed one  :P )

You should use one greater than 5.5.11!

You should run processdiagnostics when starting with new server setups. This one would have told you everything at once.

Edited by horst
  • Like 1

Share this post


Link to post
Share on other sites

Don't even go there!

This is the one that ships with the most recent Ubuntu

Its working now though

  • Like 1

Share this post


Link to post
Share on other sites

I'm trying to use this module to convert a bunch of png files to jpg. It works fine with a handful of images, but then it get's slower and slower. Here is my testing code:

$images = $page->images;

if ($images) {
	foreach ($images as $image) {
		$jpg = $image->pimLoad()->setOutputFormat('jpg')->pimSave();
	}
}

And here are the debug times in seconds - every number at the beginning of the line shows the loop count (it equals the number of images converted):

1: 0.21
2: 0.41
3: 0.67
4: 1.08
5: 1.96
6: 4.42
7: 12.79

In fact it's always the same image with a different name (1.png, 2.png and so on).

Anybody facing the same?

Share this post


Link to post
Share on other sites

Hi horst - great module (I'm a bit late to the party ;)).

Here's an example using Apeisa's Thumbnails module - I had trouble with this because the thumbnail URL is relative to the homepage and therefore doesn't contain the whole server path to load the thumbnail with.

// First we get the thumbnail - replace thumbname with your thumbnail name as set in the Thumbnails module
$relativePath = $page->images->first()->getThumb('thumbname');
 
// Then we add the root path (note: will not work in a subdirectory - not sure about localhost either - you may have to hardcode this bit unless someone has an idea?
$fullPath = $config->paths->root . $relativePath;
 
// Now do your nice manipulations if the image doesn't already exist (we only want to convert it once)
if (!file_exists($fullPath)) {
    $modules->get('PageImageManipulator')->imLoad($fullPath, array('outputFormat'=>'jpg', 'targetFilename' => '$page->images->path . 'test.jpg'))->save();
}
 
echo "<img src='" . $page->images->url . "test.jpg' />

This was typed in the browser and my actual code is for a different scenario so this may require some modification!

EDIT: Of course, once you've generated the file once then you will want to check for that rather than keep recreating the file - modified my example to show this.

EDIT2: It would probably be a good idea if you are using this example to have a module that clears any existing test.jpg files on page save (or image changes but not sure how) for the relevant templates so that if someone changes the image the PIM runs again when the image is next viewed on the site.

  • Like 1

Share this post


Link to post
Share on other sites

Possible bug?

If I use it on a normal PageImage and use the targetFilename option, it creates a new file whenever the code is run, appending _1, _2 etc to the end of the targetFilename. If I run the same code without the targetFilename option it creates the file once and doesn't overwrite or create duplicates.

Basically I want to name my file in a specific way, but I don't want to create it each time or create duplicates - to achieve this I have to use the if (file_exists... code from my example in the previous post but I'm not sure I should need to?

Share this post


Link to post
Share on other sites

@Pete: I'm not sure if I have updated the Pim after that post here: https://processwire.com/talk/topic/4264-release-page-image-manipulator/page-5#entry60648

possibly not. So best you do not pass your options with the class-init but with the ->setOptions($options) method or with individual methods ->setTargetfilename ->setOutputformat,

Can you test it and report back please?

Edited by horst

Share this post


Link to post
Share on other sites

@Pete: regarding your "test.jpg", you only need to build a name that matches the new naming conventions of PW core Pageimage. That way all is fine because PW will do the dishes for you.

It takes care of all image variations belonging to an original image. You only need to tell the system that this is a derivative image. :)

The naming scheme now is aware of suffixes. You simply can use the original filename and add a suffix to it. (in fact it isn't limited to only one suffix, it can have multiple of them). Following the original image is named basename.ext

If you want create one or more derivatives you should go with this scheme:

      basename.-suffix.ext

      basename.-suffix1-suffix2.ext

following i change your above example in a detailed manner:


// define suffix, and fileformat if needed
$suffix = 'yoursuffix';               // allowed are: a-z 0-9 and underscore !! not more!
$ext    = 'png';                      // your desired outputformat

$image = $page->images->first();      // get the image
$info  = pathinfo($image->filename);

$dir   = $info['dirname'];            // dir to the page assets/files/ folder
$name  = $info['filename'];           // basename without extension
$ext   = $info['extension'];          // only if you want use the same fileformat as the original is !!

// build the targetfilename and the URL
$targetFilename = $dir .'/'. $name .'-'. $suffix .'.'. $ext;

$targetURL = dirname($image->url) .'/'. $name .'-'. $suffix .'.'. $ext;

$sourceFilename = $dir .'/'. basename($image->getThumb('thumbname'));

// Now do your nice manipulations if the image doesn't already exist (we only want to convert it once)
if (!file_exists($targetFilename)) {
    $modules->get('PageImageManipulator')->imLoad($sourceFilename)->setOutputFormat($ext)->setTargetFilename($targetFilename)->save();
    // or this way
    $modules->get('PageImageManipulator')->imLoad($sourceFilename)->setOptions(array('outputFormat'=>$ext, 'targetFilename'=>$targetFilename))->save();
}
 
echo "<img src='{$targetURL}' />";

.

.

Additionally, if you use Pia to assist you while developing a site, your code should ask her if you are actually online and like to refresh all images:

// Now do your nice manipulations if the image doesn't already exist or if you (Pete) are actually online, testing something and want force recreate images
if (!file_exists($targetFilename) || true === $config->imageSizerOptions['forceNew']) {
...
I love it when a plan comes together!    a-team-240x300.jpg
 
  • Like 1

Share this post


Link to post
Share on other sites

Hi, horst!

After updating PW to the latest dev yesterday, i've getting this on pimLoad():

Fatal error: Exception: You do not have permission to execute this module - ProcessCropImage (in D:\OpenServer\domains\5520.pro\wire\core\Modules.php line 717)
#0 D:\OpenServer\domains\5520.pro\wire\core\Modules.php(668): Modules->getModule('ProcessCropImag...')
#1 D:\OpenServer\domains\5520.pro\site\modules\PageImageManipulator\ImageManipulator.class.php(254): Modules->get('ProcessCropImag...')
#2 D:\OpenServer\domains\5520.pro\site\modules\PageImageManipulator\PageImageManipulator.module(185): ImageManipulator->__construct(Object(Pageimage), Array, false)
#3 D:\OpenServer\domains\5520.pro\wire\core\Wire.php(381): PageImageManipulator->getPageImageManipulator(Object(HookEvent))
#4 D:\OpenServer\domains\5520.pro\wire\core\Wire.php(317): Wire->runHooks('pimLoad', Array)
#5 D:\OpenServer\domains\5520.pro\site\templates\docs-product.php(12): Wire->__call('pimLoad', Array) #6 D:\OpenServer\domains\5520.pro\site\templates\docs-product.php(12): Pageimage->pimLoad('test')
#7 D:\OpenServer\domains\5520.pro\wire\core\TemplateFile in D:\OpenServer\domains\5520.pro\index.php on line 220

any suggestions?

Horst - I'm experiencing this at the moment and have found the solution.

I think the line in your module here is problematic:

$a = wire('modules')->get('ProcessCropImage')->getModuleInfo();

That line will run fine when you are logged into ProcessWire, but I think it somehow loads into memory the actual page using the ProcessCropImage process module which is only accessible by admins so doesn't work when viewing as a guest (that's the only crazy theory I have for now :)).

It's a tricky issue to track down, but basically replacing that whole block of code with this stops it from happening (essentially turning thumbnail boost off!):

// check if we can be used to boost the thumbnail module, - is it installed?
            if(true === ($this->thumbnailBoost = (bool)wire('modules')->isInstalled('ProcessCropImage'))) {
                // now check that at least the minimum version number of ProcessCropImage is installed:
                $needed = '1.0.2';
                //$a = wire('modules')->get('ProcessCropImage')->getModuleInfo();
                //$actual = preg_replace('/(\d)(?=\d)/', '$1.', str_pad("{$a['version']}", 3, "0", STR_PAD_LEFT));
                //$this->thumbnailBoost = version_compare($actual, $needed, '<') ? false : true;
                $this->thumbnailBoost = false;
            }

Share this post


Link to post
Share on other sites

@Pete: thanks for tracking this down! ^-^

I have updated the module and changed the code by adding a check for the permission 'image-crop' here.

(this needs further investigation, here it is a quick solution to stop the error.)

If you can find some time, would you be so kind and test it if this work at your end?

Edited by horst
removed first post content and wrote something useful

Share this post


Link to post
Share on other sites

Hi.

I've got some problems after creating an PIM image. I'm using PHP 5.5.19 and tried it on the current 2.5.2 and on the latest dev from this morning. Server is lightning.pw, so usual this setup doesn't make any problems. I'm using the default 2.5 image settings in the config.php

Task: First, resize the image to a given width, then grayscale() it and then overlay a transparent gradient.  Afterwards use it on different position in the HTML code. This is my function to create this image variation:

function getBrandImage($image,$width=1080,$prefix='branded') {
	if($image->name != '') {
	
	//$image->pimLoad($prefix)->removePimVariations();
	
	//Path to the overlay png depending on orientation
	$overlay_path = wire('config')->paths->templates . 'assets/overlay-landscape.png';
	
	if($image->width < $image->height) 
		$overlay_path = wire('config')->paths->templates . 'assets/overlay-vertical.png';
	
	//Output
	$o = array('outputFormat'=>'jpg');
	
	// apply it together with other actions
	$result = $image->pimLoad($prefix,true)->setOptions($o)->width($width)->grayscale()->watermarkLogoTiled($overlay_path)->pimSave();	
	
	}
	return $result;
}

It will create an image variation that has the desired effect. But now starts the weird stuff I can't figure out.

1) On my homepage, I'm calling this function with the default width of 1080 and I get back the PageImage. I now pass this PI to a simple function that renders and srcset html output by generating 3 variations of this image with the PW image functions.  This function works when I just pass a regular $page->image->size(120,120) PI object.

//Renders an image as srcset
function renderImage($image,$class='',$sizes='auto',$sets=array(400,767,1080,2120)) {
	$out = '';
	
	if($image->name != '') {
		if($class != '') $class = ' ' . $class;
		
		$o = array( 'upscaling' => true, 'cropping' => true, 'quality' => 40);
		
		//Start
		$out .= "<img src='{$image->width(260,0,$o)->url}' alt='{$image->description}' data-srcset='";
		foreach($sets as $s) {
			$img = $image->size($s,0)->url;
			$out .= "{$img} {$s}w, ";	
		}		
		$out = substr($out,0,-2);
		$out .= "' data-sizes='{$sizes}' class='lazyload{$class}'/>";
	}	

The $image here is the $result from the function above. It will create the first image in srcset (inside the foreach). The other images will output with 0x0 in the filename and are not created. 

2) On another page, where I need smaller images but only in 1 resolution, I'm calling the getBrandImage() function again but this time with width of 400. It will create the image but I think it crashes because the file permissions are set wrong, so the files can only be seen directly on a file level. 

I get the same results when I resize the image before I pass it to PIM or try different combinations.

When I just leave out the PIM stuff and create the image inside PIM with PW (and without the gradient/grayscale) everything works. That why I think this is an issue with PIM but I can't figure out anymore. The errrors.txt file doesn't show anyting. When I turn on debug, those messages appear. They don't appear when I comment out the PIM part.

Warning: imagecreatetruecolor(): Invalid image dimensions in /lightning/version/2.5.10.5/wire/core/ImageSizer.php on line 1417

Warning: imagecopy() expects parameter 1 to be resource, boolean given in /lightning/version/2.5.10.5/wire/core/ImageSizer.php on line 1438

Warning: imageconvolution() expects parameter 1 to be resource, boolean given in /lightning/version/2.5.10.5/wire/core/ImageSizer.php on line 1439

Warning: imagedestroy() expects parameter 1 to be resource, boolean given in /lightning/version/2.5.10.5/wire/core/ImageSizer.php on line 1528

Warning: imagedestroy() expects parameter 1 to be resource, boolean given in /lightning/version/2.5.10.5/wire/core/ImageSizer.php on line 1529

Warning: imagegammacorrect() expects parameter 1 to be resource, boolean given in /lightning/version/2.5.10.5/wire/core/ImageSizer.php on line 1354

Warning: imagejpeg() expects parameter 1 to be resource, boolean given in /lightning/version/2.5.10.5/wire/core/ImageSizer.php on line 429

Sorry for the long report, but just want to make sure that I didn't overlooked something. Help would be appreciated, thanks :)

Share this post


Link to post
Share on other sites

Hi Philipp,

ähm, may I say that this sounds confusing? :)

It will create an image variation that has the desired effect. But now starts the weird stuff I can't figure out.

You only need to double check here if it returns a valid pageimage and has created the derivative file. If both is yes, PiM has done it work successful.

If you further do not call PiM anymore, it has nothing to do with PiM! - Ready!

-------------------------------

Looking at your code:

$out .= "<img src='{$image->width(260,0,$o)->url}'

What is width 260, 0, $o ?

You have done the same things wrong like in earlier posts. Passing a zero as second option to width, what should be an array with options! Ryan has changed pageimage::size to silently fail with this instead of crashing the process. This was a wish by yourself!

Another thing is that you has run into timeouts with imagesizer in the past. I have posted a solution to you and maybe over 10 times more here in the forums: include a set_time_limit() in every loop that calls imagesizer. ( foreach($sets as $s)!

There are two options for the set_time_limit() now: please add it into your loops or only use PW >= 2.5.10 in the future, because PW since 2.5.10 has an own set_time_limit() call in ImageSizer! :)

Share this post


Link to post
Share on other sites

Thanks for the answer. If I replace the single line where I call PIM

$result = $image->pimLoad(....)->pimSave()

with

$result = $image->size(123,123) 

all the following functions and stuff works. Yes, you've found a bug/problem in the rest of my code (thanks), but my question is, why does it totally fail with the PI object from PIM and not with the one from PWire? I rewrite all those image stuff this evening and try again.

I'm using the latest dev build (2.5.10 the latest version on the dev branch as of yesterday 18:00 GMT time) and the time limit is 60 seconds. A try with 120seconds did also fail (with a single image at 2000x1333). Memory limit is 128M.

_

I never requested it fo fail silently. The problem was, that an error a developer could made in the past and that is now fixed, affects all future operations with an image because a half-way created image exists on the file system.

Share this post


Link to post
Share on other sites

Hhm, it wasn't clear to me that you have encountered differences between Pageimages derived from Pageimage or derived from PiM. (or I may have overlooked it in all that examples)
 
I think it would have avoided some confusion if you just have asked / told that the objects behave different, without (partly wrong) code and lots of error messages.
 
You are also speaking about filenames generated with .0x0 in its name.?! Pageimage::size generates the filenames before any manipulatiuon through ImageSizer and only according the passed values for width and height. So, at that point you may check what values you are passing to the functions.

------

But lets focus on that objects thing:

I will try to replicate and compare that. Just to clarify a few things:

  • You have checked that after your PiM call a Pageimage Object is returned?
  • Have you tried it with a PiM that does other manipulations, maybe just pimLoad()->pimSave(). Does it behave the same or is it different?

Pim generates the PageimageObjects this way: https://github.com/horst-n/PageImageManipulator/blob/master/ImageManipulator.class.php#L751
It looks the same like Pageimage::size does it: https://github.com/ryancramerdesign/ProcessWire/blob/dev/wire/core/Pageimage.php#L316

 
So, we need to compare the objects, first try with simple objects that only should differ in the name:

$size = $image->size($image->width, $image->height);

$pim = $image->pimLoad('test')->pimSave();

And then with a manipulated one from your example.

------
 

I never requested it fo fail silently. The problem was, that an error a developer could made in the past and that is now fixed, affects all future operations with an image because a half-way created image exists on the file system.


Ah, ok! Sorry for remember me wrong!

  • Like 1

Share this post


Link to post
Share on other sites

Finally found time so rewrite the thing. In short, it is now working but I can't figure out what didn't work before.

1) My $size was set to 0. This was my mistake. The width() options just ignored the $options array.

2) I manually removed all pages including the image files and re-upload them. This made PIM PageImage objects work as well as the ProcessWire ones.

Sorry, this seems like a fault on my side. PIM works fine once you get the things around right.

  • Like 2

Share this post


Link to post
Share on other sites

Horst, thanks a lot for this wonderful module. It is extremely useful to me and I'm impressed by its complex possibilities!

I've got a question regarding the caching and rendering: While regular images are cached, those images I process using PageImage Manipulator seem to be recreated on every access of the frontend page containing the image.

Is this a desired behaviour, or did I just miss setting the right parameters?

Here's the code used in my template to output an image with added watermark on the website:

        $img = $page->special_image;

        // choose file containing watermark sample
        $watermark = $pages->get("/special/watermark")->images->first();

        // add watermark to image
        $imagewithwatermark = $img->pimLoad('tw',true)->width(800)->watermarkLogoTiled($watermark->filename)->pimSave();

		// output image
        $content .= '<img src="'.$imagewithwatermark->url.'" title="'.$page->title.'" style="height: '.$imagewithwatermark->height.'px; width: '.$imagewithwatermark->width.'px;" /><br />';

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By eelkenet
      Hi! I've created a small Inputfield module called InputfieldFloatRange which allows you to use an HTML5 <input type="range" ../> slider as an InputField. I needed something like this for a project where the client needs to be able to tweak this value more based on 'a feeling' than just entering a boring old number. Maybe more people can use this so I'm hereby releasing it into the wild. 
      EDIT: You can now install it directly from the Modules directory: http://modules.processwire.com/modules/inputfield-float-range/
       
      What is it?
      The missing range slider Inputfield for Processwire. 
      What does it do?
      This module extends InputfieldFloat and allows you to use HTML5 range sliders for number fields in your templates.
      It includes a visible and editable value field, to override/tweak the value if required.  
      Features
      Min/max values Precision (number of decimals) Optional step value (Read more) Optional manual override of the selected value (will still adhere to the rules above) Configurable rounding of manually entered values (floor, round, ceil, disable) Usage
      Clone / zip repo Install FieldtypeFloatRange, this automatically installs the Inputfield Create new field of type `Float (range)` or convert an existing `Float`, `Integer` or `Text` field. To render the field's value simply echo `$page->field` Demo
      A field with Min=0, Max=1, Step=0.2, Precision=2

      Field with settings Min=0, Max=200, Step=0.25, Precision=2

       
      Todo
      Make the display-field's size configurable (will use the Input Size field setting)  Hopefully become redundant  
      Changelog
      004 (current version)
      - Make rounding of manually entered values configurable (floor, round, ceil or disable)
      - Fix small JS bug when the value-display field was not displayed
      - Update README
      003
      - Code cleanup, add some ModuleInfo data & LICENSE
      - Submit to PW Modules directory (http://modules.processwire.com/modules/inputfield-float-range/)
      002
      - Fix issue where setting the step value to an empty value created problem with validation
      - Make the display-field optional
      001
      - Initial release
       
      Thanks!
       
       
    • By Gadgetto
      Status update links (inside this thread) for SnipWire development will be always posted here:
      2019-10-18
      2019-08-08
      2019-06-15
      2019-06-02
      2019-05-25
      If you are interested, you can test the current state of development:
      https://github.com/gadgetto/SnipWire
      Please note that the software is not yet intended for use in a production system (alpha version).
      If you like, you can also submit feature requests and suggestions for improvement. I also accept pull requests.
      ---- INITIAL POST FROM 2019-05-25 ----
      I wanted to let you know that I am currently working on a new ProcessWire module that fully integrates the Snipcart Shopping Cart System into ProcessWire. (this is a customer project, so I had to postpone the development of my other module GroupMailer).
      The new module SnipWire offers full integration of the Snipcart Shopping Cart System into ProcessWire.
      Here are some highlights:
      simple setup with (optional) pre-installed templates, product fields, sample products (quasi a complete shop system to get started immediately) store dashboard with all data from the snipcart system (no change to the snipcart dashboard itself required) Integrated REST API for controlling and querying snipcart data webhooks to trigger events from Snipcart (new order, new customer, etc.) multi currency support self-defined/configurable tax rates etc. Development is already well advanced and I plan to release the module in the next 2-3 months.
      I'm not sure yet if this will be a "Pro" module or if it will be made available for free.
      I would be grateful for suggestions and hints!
      (please have a look at the screenshots to get an idea what I'm talking about)
       




    • By Robin S
      Another little admin helper module...
      Template Field Widths
      Adds a "Field widths" field to Edit Template that allows you to quickly set the widths of inputfields in the template.

      Why?
      When setting up a new template or trying out different field layouts I find it a bit slow and tedious to have to open each field individually in a modal just to set the width. This module speeds up the process.
      Installation
      Install the Template Field Widths module.
      Config options
      You can set the default presentation of the "Field widths" field to collapsed or open. Field widths entered into the Template Field Widths inputfield are only applied if the Edit Template form is submitted with the Template Field Widths inputfield in an opened state. "Collapsed" is the recommended setting if you think you might also use core inputs for setting field widths in a template context. You can choose Name or Label as the primary identifier shown for the field. The unchosen alternative will become the title attribute shown on hover. You can choose to show the original field width next to the template context field width.  
      https://github.com/Toutouwai/TemplateFieldWidths
      https://modules.processwire.com/modules/template-field-widths/
    • By NehaPillai
      Hello Everyone, I was trying to update SEO meta title, description and meta keywords for my website in Process Wire CMS but it saving in the backend but it is not reflecting on my website, Please help me regarding this error. Please find below attached screen shot for your ref. TIA.


    • By adrian
      Tracy Debugger for ProcessWire
      The ultimate “swiss army knife” debugging and development tool for the ProcessWire CMF/CMS

       
      Integrates and extends Nette's Tracy debugging tool and adds 35+ custom tools designed for effective ProcessWire debugging and lightning fast development
      The most comprehensive set of instructions and examples is available at: https://adrianbj.github.io/TracyDebugger
      Modules Directory: http://modules.processwire.com/modules/tracy-debugger/
      Github: https://github.com/adrianbj/TracyDebugger
      A big thanks to @tpr for introducing me to Tracy and for the idea for this module and for significant feedback, testing, and feature suggestions.
×
×
  • Create New...