Jump to content
Sign in to follow this  
anowitz

enabling mod_rewrite using php.ini file?

Recommended Posts

I'm moving a PW site from a local environment to a dev site for a client hosted by register.com.  I've followed Ryan's directions here (thanks, Ryan - very clear and helpful!) and am getting an "internal server error" when I go to the root (found here) and am also getting this error when I try to access the admin page:

"Apache/2.2.22 (Unix) mod_ssl/2.2.22 OpenSSL/0.9.8e-fips-rhel5 DAV/2mod_auth_passthrough/2.1 mod_bwlimited/1.4FrontPage/5.0.2.2635 Server at dev.callicoonfinearts.com Port 80"

I created a test.php file that executes phpinfo, among other things (test.php file can be found here.)  From what I can gather, mod_rewrite is not currently enabled.

I uncommented the "RewriteBase" line in .htacess so that it reads

RewriteBase /process/

and have tried placing the .htacess file in both my dev folder and in the site's public_html folder.

When none of these worked, I called register.com and was advised to enable mod_rewrite through a php.ini file that I should place in the public_html folder.

My question is - is it possible to enable mod_rewrite using a php.ini file?  (All the research I've done seems to .htaccess or httpd.conf as places where mod_rewrite should be enabled - some comments I've read have specifically said that because mod_rewrite is an apache module it has nothing to do with php or a php.ini file.)  Was I misinformed by the person at register.com, or am I missing something?

Thanks!!  Many frustrating hours spent on this already....

Share this post


Link to post
Share on other sites

Hi anowitz,

It's probably not a good idea to publicly post your phpinfo file like that :)

Share this post


Link to post
Share on other sites

Oops!  Thanks for the tip - changed it now - just thought it would help!

In fact, I am now seeing this in the php info "_ENV["HTTP_MOD_REWRITE"]   On"

So perhaps this is a different problem altogether...

Share this post


Link to post
Share on other sites

I apologize - I think I wrote this post prematurely.  Still working on the problem, but don't think it has anything to do with mod_rewrite so am marking post as solved...

Share this post


Link to post
Share on other sites

Problem now solved!  I should have used the site profile exporter module from the start - I started fresh with it, and it did the trick without any problems at all (though I did make sure to change htaccess.txt to .htaccess before I ran the installer.)  Thanks for the great module, Ryan!

  • Like 2

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By alanp
      I have a PW site where I had been successfully uploading png and jpeg files. Recently the file and image file fields don't save. The upload status bar completes (100%) without error but when the page with the file field is saved the uploaded file name is missing from the refreshed page.
      This must be due to a site hosting change but I need more specific info like error details before I raise it with them.
      The php v5.4 config has file uploads enabled and safe mode is off. 
      I have tried the following to fix this without success:
      I have read and tried the fixes to the similar posting from Soma:  can't upload image/files problem Upgraded the PW site from 2.3 to 2.5.3. (no change) Turned on debug in config.php with no obvious error messages showing. Debugged core\WireUpload.php where I found that the recommended fixes from 1. wouldn't work because the file field is not using Ajax. Have you got any other suggestions?
        
    • By horst
      Hi,
      I have had some (more) trouble to get started with PW  :-(
      In my php.ini the default_charset was set to 'ISO-88591' or something similar.
      So, as the DB uses utf8 and the pages are delivered in utf8, php is required to use it too.
      If not you can run into errors when try to save strings with e.g. german umlaute: äöü ÄÖÜ
           Incorrect string value: '\xFCchte ...' for column 'data' at row 1
      I'm not sure if this was checked with the install routine, but I have seen only green lines
      Maybe this could be done to avoid some hassle to users with a setup other than utf8.
      Or it maybe an option to add "ini_set('default_charset','utf8');" somewhere at the top of index.php,
      and to be very very sure (also for paranoics like me ) one can set and check it:
          ini_set('default_charset','utf8');
          $php_use_utf8 = strtolower(trim(ini_get('default_charset')))=='utf8' ? true :  false;
       
      Ok, now I can start try out that wonderful CMS
×
×
  • Create New...