Jump to content

Admin > Pages throws Error and won't load


mrClapham
 Share

Recommended Posts

HELP!!!!

I've been building a back end in ProcessWire. All was going well until it spontaneously began throwing an error when I try and view my page list tree, rendering the entire back end useless.

I'm developing locally on Mamp on a Mac.

I get the following JavaScript Error:

Uncaught TypeError: Object #<Object> has no method 'complete' JqueryCore.js:2
v.extend.ajax                          JqueryCore.js:2
v.(anonymous function)         JqueryCore.js:2
v.extend.getJSON                 JqueryCore.js:2
loadChildren                          ProcessPageList.js:385
init                                         ProcessPageList.js:119
(anonymous function)           ProcessPageList.js:734
v.extend.each                      JqueryCore.js:2
v.fn.v.each                            JqueryCore.js:2
$.fn.ProcessPageList           ProcessPageList.js:93
(anonymous function)           ProcessPageList.js:17
l                                             JqueryCore.js:2
c.fireWith                              JqueryCore.js:2
v.extend.ready                     JqueryCore.js:2
A
 
The offending line seems to be: $.getJSON(options.ajaxURL + "?id=" + id + "&render=JSON&start=" + start + "&open=" + options.openPageIDs[0], processChildren);
 
if I threw a try/catch around the 'document.ready' function and it throws an error - it gives me no other info -- just an error and an empty Object.
 
I think it's to do with getting the jSon file.
 
 
it's three days work down the drain and I'm up against a deadline!!!
Link to comment
Share on other sites

What do you mean with 'I've been building a back end in ProcessWire'?

Any custom modules that could have introduced this error?

Try to backup your wire folder (rename it for example to wire.old) and copy

the same directory from a fresh Pw version, master or dev.

Maybe some files got corruped.

Link to comment
Share on other sites

I am guessing that maybe there is a module installed that had an older jQuery version dependency? jQuery tends to deprecate a lot of widely used stuff with new versions. We upgraded jQuery versions in the 2.2 => 2.3 upgrade, so if there was some jQuery dependency in a module installed in 2.2, that seems like a potential place to look. I would start by uninstalling 3rd party modules, especially those that might affect the PageList and see if you can track it down. Let us know what module it is.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By luischacon
      Hello how are you, I need help on how I can solve this, update a module and now I don't know what to do

    • By caffeineben
      My hosting company (Dreamhost) upgraded their VPS accounts from Ubuntu 14 (also known as Trusty) to Debian 10 (aka Buster). Since they have done that, I can no longer upload photos through the PW admin. Most of my templates use the Images field and when I go to upload an image - no matter the size, I just see spinning over the image icon. I checked my console and get the following errors:
      [Error] Failed to load resource: the server responded with a status of 418 () (edit, line 0)
      [Error] SyntaxError: JSON Parse error: Unrecognized token '<'
          parse (JqueryCore.js:2:13595)
          parseJSON (JqueryCore.js:2:13595)
          (anonymous function) (InputfieldImage.min.js:1:35271)
      I have multiple sites hosted by Dreamhost and this is now happening on all sites.  I am using Processwire 3.0.165. PHP 7.4.
      I don't know what other info is helpful so please let me know if you have any ideas. I have filed a ticket and suspect this is a result of the upgrade as all these sites worked previously. And the sites still work - just can't upload and save to the images field.
       
    • By quickjeff
      Hi Guys, 
      I have been debugging a site for the last 2 hours and cannot solve the issue. 
      I have a site running on 3.0.148. 
      I installed the Kongondo Blog module and was updating the templates to include the website style. 
      Once everything was set and done, I checked the page tree to see an error appear. 
      Template must be assigned a name before 'filename' can be accessed
      The same error appears in templates. 
      Debugging Steps
      I checked the templates in the server to ensure I didnt accidentally delete the namespace.  Deleted cache in browser and server under assets Still no go. 
      Any help is appreciated. 
      Thanks! 
    • By gswoodman
      Hello all,
      I have recently installed ProcessWire as I am learning to develop my own personal website.
      The installation process was completed, pressed 'Login to Admin' and I am receiving a 404 error.
      I am using a GoDaddy Shared Hosting Package with Plesk installed.
      Does anyone have any experience with using ProcessWire on a shared hoasting package?
      Many Thanks.
×
×
  • Create New...