Jump to content

[solved] Does disabling multi-lang work for you?


Recommended Posts

I've created this issue back in 2019: https://github.com/processwire/processwire-issues/issues/916

Ryan seems not to be able to reproduce the issue ? Can you guys please try what I show here and see if that works for you or if you get the same issue like I do? Video: https://calip.io/O1wKadGz#cQZ1CRZf

Here is a copy of that site for everybody to install: https://github.com/processwire/processwire-issues/issues/916#issuecomment-1120170931

Thanks for your help! @matjazp are you even not able to reproduce the issue with my copy?

Link to comment
Share on other sites

Sorry, at the moment I only have PW 3.0.184 multilang availabe, and there it works as it should.

I will try later with a more recent version.

  • Thanks 1
Link to comment
Share on other sites

Tried your copy on my local dev server and it shows the same behavior like in the video. Both languages are there until I save or publish. Then additional langs vanish.

  • Thanks 1
Link to comment
Share on other sites

Thx @Klenkes maybe you can try my submitted version?

Quote

Hey Ryan thx. That's very strange... I've tried it again and it's the same result. Could you try installing my version and see if that works different on your end?
Here is the zip with all the files + a db dump in /site/assets/backups/database/db.sql (will be online for 14 days I think): https://transfer.sh/fg4HYY/tmp-lang.zip
Admin login is ddevadmin / ddevadmin. See config.php to adjust db connection info (dont forget to change the db host as it is "db" in my case).
You can delete the .git and .ddev folders after extract.

Here is how this installation looks like on my end (will be deleted on 21/05): https://calip.io/O1wKadGz#cQZ1CRZf

 

Link to comment
Share on other sites

14 minutes ago, Klenkes said:

Tried your copy on my local dev server and it shows the same behavior like in the video. Both languages are there until I save or publish. Then additional langs vanish.

I did.

I checked 3.0.190 and it worked.
I checked 3.0.197 and it doesn't work anymore.

Somewhere in between it happened.

  • Like 1
Link to comment
Share on other sites

Interesting find. Though I'd ask you to try that again, because my issue is from 2019 so it should not have been introduced between .190 and .197 as they are a lot younger! I just checked replacing the wire folder from my example setup...

  • 3.0.184 --> same bug
  • 3.0.96 from 2018 --> same bug
Link to comment
Share on other sites

Thx @matjazp maybe it has to do something with locale settings? Not sure, but I really just did the steps outlined in the github issue. No external modules (only processdatabasebackups to share the sql file)...

Link to comment
Share on other sites

Looks like it happens whn there is only one template that could be used for a new page. Can you try and add another template that doesn't have multilang disbaled?

  • Like 1
Link to comment
Share on other sites

  • bernhard changed the title to [solved] Does disabling multi-lang work for you?
15 minutes ago, matjazp said:

Looks like it happens whn there is only one template that could be used for a new page. Can you try and add another template that doesn't have multilang disbaled?

Can reproduce this here on 3.0.198 dev with Default Multilang Profile.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...