Jump to content

Very Frustrated first time user!


mikeindee
 Share

Recommended Posts

Rick - I'm not at home so not on my local network, but I can advise you I absolutely removed the random data I typed in the .htaccess files (both of them!) before I resaved them. So this is a real worry. Does the error now showing indicate that the .htaccess file isn't being 'read'? And if so, why? I haven't fixed the rewrite base issue yet, but will do so at first opportunity.

Thanks again for your help!

Link to comment
Share on other sites

When you first got your pi, did you install LAMP successfully? Is it debian based? Did apache serve a test php file from the url (or IP) correctly?

If you need help with that, the pi forums should provide advice and tips to get the pi running correctly.

Once your pi is running correctly, install PW as normal, fixing only the issues the installer presents to you. If there is sufficient resources, everything should function as intended.
 

Link to comment
Share on other sites

18 hours ago, mikeindee said:

I've restarted Apache and now if I click on any 'link' (admin login; site map etc), I get:

Internal Server Error

This is potentially progress, as it suggests ProcessWire is at least being given control. ProcessWire throws an internal server error instead of displaying a message if something went wrong.

Maybe check site/logs/errors.txt or exceptions.txt also, if you haven't already, in site/config.php add $config->debug = true; as that should display errors.

  • Like 1
Link to comment
Share on other sites

Quote

 

Well Rick and Chris - some amazingly good news at last!! Rick - Apache worked perfectly. Default page etc. after installation. I've loaded some programs with an associated 'index' file and these all worked perfectly, too. And I did load PW as suggested fixing every problem (bar the lack of zip) as it occurred. This was my frustration - PW indicated that it was 'up and good to go'. Except it clearly wasn't!!

Then as suggested I 'fixed' the 000-default.conf file and this led to the error I indicated (and which Chris has kindly commented on). There was another issue with this - I was no longer able to call up the index file that showed my applications. So, I changed the config file setting to read DocumentRoot /var/www/html (removed the pwire directory) and same for <Directory /var/www/html/........ I also commented out the entire rewrite options in.htaccess

And as if by magic, it all works!!! Using the 'vanilla' IP address of the server shows me my index file and associated applications. Adding /pwire to the URL takes me to the PW home page - and all the links work! Login to admin; site map; about - whoopee!! 😃

Now, as fantastic as this is it would have been nice if PW on installation, had 'warned' me that I might need to fix an Apache config file and not left me wondering why this "easy to use" CMS wasn't...... But there we are. Thanks a million to all the patient and very helpful contributors. Very much appreciated!

  • Like 5
Link to comment
Share on other sites

On 12/1/2021 at 11:01 AM, mikeindee said:

Apache worked perfectly. Default page etc. after installation

This doesn't indicate a properly working Apache for all scenarios at all. It's just the most basic startup screen you could imagine for LAMP setup.

On 12/1/2021 at 11:01 AM, mikeindee said:

I've loaded some programs with an associated 'index' file and these all worked perfectly, too.

So... you installed everything in just one folder (/var/www/html/PROGRAMMSUBFOLDER)?
No... set up VirtualHosts. That's a one-time-investment in a solid dev environment. From there... you could go in any direction. 
With ProcessWire, WP, Drupal, Typo3... whatever.

On 12/1/2021 at 11:01 AM, mikeindee said:

Adding /pwire to the URL takes me to the PW home page

That's the default behaviour when installing ProcessWire into a subfolder. While it works... I wouldn't recommend it. Only when you really know what you are doing, testing for example, or when you already installed Processwire 100 times.

 

On 12/1/2021 at 11:01 AM, mikeindee said:

PW indicated that it was 'up and good to go'. Except it clearly wasn't!!

On 12/1/2021 at 11:01 AM, mikeindee said:

Now, as fantastic as this is it would have been nice if PW on installation, had 'warned' me that I might need to fix an Apache config file and not left me wondering why this "easy to use" CMS wasn't.

ProcessWire was ready to go. Your setup wasn't.

 

Sorry when this sounds a bit rude but using a non-working or better to say not fully configured environment as a base for whatever kind of (web-) development and then blaming the software because it doesn't like it that much... is unfair.

I can't and won't blame you but I want to move your focus to the reason for your experience here.
It wasn't ProcessWire. Sure installation is sometimes a bit more than just clicking but in this case there were way more steps than really necessary.

In case you want to experience a super solid installation that's a breeze... use something like Laragon on Windows, MAMP on Mac or ... let's skip the Linux part here.

 

One last word here: Even though my response here could be read a bit harsh... I really appreciate that you stayed the whole way, worked through everything from start to finish. And I wish and hope you start to love ProcessWire like each and everyone here in this thread and community.

  • Like 3
Link to comment
Share on other sites

I agree wit wbmnfktr, however, I also tend to agree with OP that the installer could be made more fool-proof. We’ve had a lot of threads over the years with people getting 500s trying to access the Admin (or anything other than the front page) right after installing PW. OP’s case may be especially niche, but .htaccess adjustments to get PW running aren’t really. It might be a good idea for the installer to ping the chosen admin URL and display a warning with some instructions if it doesn’t get a 200.

Also, from a UI perspective, looking at this screenshot I just see a bunch of tick marks. We all know users don’t read anything you put in front of them, and this only encourages us to believe no further action is needed. IMHO, the “Complete & Secure Your Installation” section shouldn’t have check marks. Maybe it should even be a different color to emphasise its to-do-list nature and differentiate it from the mere success messages. “Get Started” is mostly to-do as well, albeit more optional.

On 11/29/2021 at 8:27 AM, mikeindee said:

pwire#1.jpg

 

  • Like 5
  • Thanks 1
Link to comment
Share on other sites

This is a great addition and idea! @Jan Romero

Fool-proof or advanced settings to make it more secure and more awesome.

A point I didn't see due to so many instances I installed and configured.

Maybe we could even open a thread to collect solutions based on hosting companies to get some idea about how different providers need different settings within .htaccess or whatever. Just an idea right now but I know that I had to tinker around with things in STRATO (DE, hosting company) a lot a few years back and even some hostings (I won't name names here) I moved away from because it didn't work out at all.

  • Like 1
Link to comment
Share on other sites

Wow! Well, that was a can of worms I opened! 😀 OK, let me come clean and say that I have actually tried - many times! - to load PW on various platforms before. Always Linux based - and let me also say that I have never succeeded. I'm not really interested in a Laragon - Windows approach. I really wanted to get it to run correctly on a Linux based platform. I've tried nginx as well as Apache as the server platform, and neither have set up correctly despite following all the comments and suggestions (except, as I've said before, the 'unzip software' which is, I believe classed as a 'nice to have but not essential'. This time, after yet another frustrating and initially unsuccessful attempt, I thought 'b***r it - I'm going to see what the community can make of this!' Now, despite comments about everything in the one folder, that is NOT how I have things set up. I have an 'index' file in the /var/www/html directory that links to a number of useful applications - node-red; php-lite-admin; webmin etc and these are, of course, in their own sub-folders. And work!! The obvious, and apparently sensible approach, with PW was to put this in a sub-folder, too. No-one ever suggested that wasn't the correct approach! My comments are, then, based on an actively and apparently correctly working web-server and a - supposedly - fool-proof and 'simple to install' CMS and, I'd still argue it wasn't.  OK, I accept that my server knowledge isn't that of a professional web designer - but I was 'encouraged' that that wasn't apparently necessary with PW. And, yes, a knowledge of virtual hosting is something I could obviously improve on. But - and I reiterate - that isn't what PW advises me. It tells me 'you are ready to go!' and yet only the front page shows. Now, OK, thanks to the patience of many people here, I ultimately get it working - and I understand the comment 'it wasn't PW - it was your server set-up' because clearly PW was ready to go....but only after making Apache changes. And I'd argue that PW could have better informed me that would be necessary. I really like Jan Romero's remarks, and agree that PW, whilst good, could be made better for less experienced users with an unblinkered look at the install process. And - if that takes place (and it would have to be by persons far more experienced than me!), then.....well, I may have achieved one of my unstated objectives! Thanks again for all the patience, comments and advice - Mike

  • Like 3
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...