Jump to content

Edit: Possible Bug? - Correctly building a selector with checkbox multi value field


Guy Incognito
 Share

Recommended Posts

I'm trying to build a search selector that includes a checkbox multiple option field (clinicdetails_specialisms). The whole selector works fine if I don't include the checkbox field. With it included I get errors like "Error: Exception: SQLSTATE[HY093]: Invalid parameter number: mixed named and positional parameters (in wire/core/PageFinder.php line 627)".

This is the selector as it currently stands.

subscription_status=active,(template=user,clinicdetails_description|clinicdetails_short_description|clinicdetails_clinic_name|clinicdetails_first_name|clinicdetails_last_name*=$query),(clinicdetails_specialisms.title=$query)

I've also tried setting the specialisms field in one string rather than groups and have also tried with/without the '.title' property.

Oddly the selector works if specialisms is the only field being searched. It seems to fail when mixed with other selectors.

Can anyone advise what stupid mistake I'm making!

Edited by Guy Incognito
Updated to reflect poss bug found
Link to comment
Share on other sites

  • Guy Incognito changed the title to Edit: Possible Bug? - Correctly building a selector with checkbox multi value field

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...