Jump to content

Hanna Code Question - Update Problem [solved]


HannaP
 Share

Recommended Posts

I'm about to update an old site from PW 2.7.2/ PHP 7.4  to  3.0.165/ PHP 8.0

I have a problem with a HannaCode/PHP thing.

This
 

require_once($config->paths->assets . "moon_phase/moonphase.php");

worked in 2.7.2 but throws an error in 3.0.165
as if it can't find moon_phase/moonphase.php anymore.

What can I do so it works again?

Any help appreciated.

 

PS.: just tested - seems to be related to PHP 8 because it works on PHP 7.4

 

 

Link to comment
Share on other sites

ok, solved by myself.

Finally found that my XAMPP is configured without short open tags.
Changed <? to <?php in the script .. and voilà

things work now.

Link to comment
Share on other sites

  • HannaP changed the title to Hanna Code Question - Update Problem [solved]

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...