Jump to content

Stuck on admin login, new install via Docker


Recommended Posts

I'm new to ProcessWire, but I just installed ProcessWire in a Docker container. All appears to have gone smoothly, but nothing seems to happen when I try to log into the admin page, other than a screen refresh. No error message, with or without the right password, just a page refresh.

Noticed a similar support topic where:

$config->sessionFingerprint = false;
$config->sessionChallenge = false;
 

was suggested, but that does not seem to have made any difference for me. Wiped everything and tried again several times. Always the same issue.

The 'modules.txt' has an odd message:

"Found 2 module(s) missing file: FieldtypeNumber => /var/www/html/site/modules/FieldtypeNumber/FieldtypeNumber.module, ProcessPage => /var/www/html/site/modules/ProcessPage/ProcessPage.module"

The files do not exist at those locations, but then nor do they appear to exist on a working installation that I looked at (although that did not have the 'missing file' notice in the modules.txt file).

I'm completely stuck. Any suggestions where I go from here?

modules.txt messages.txt system-updater.txt

Link to post
Share on other sites

Never worked with Docker so my knowledge there is super limited.

So therefore I looked this up:

https://www.google.de/search?q=processwire docker (there might be a few directions to go)

 

The behaviour you mentioned is strange. There should be at least some kind of information.

Please enable the debug mode which should tell you more about your setup and problems with it.

In /site/config.php is the $config->debug option which needs to be set to true.

Please check that your Docker container uses Apache 2, PHP 7.4, and a recent MySQL/MariaDB database version. mod_rewrite is necessary to make everything work.

If possible try ProcessWire in either something like Laragon (Windows), MAMP (Mac) or within any other LAMP stack.

 

And... Welcome to the ProcessWire forum @KenM!

Link to post
Share on other sites

I am using Docker Desktop on MacOS (Big Sur).

I am using a lamp stack: php-Apache-MySQL-containerised, which was recommended on a site, but I will look into MAMP as an option as I am fairly agnostic as to what I use, as long as I can get it to work!

I’ve checked the Dockerfiles and no versions are specified, so I should be defaulting to the latest versions.

I’ve checked that debug is enabled, but it does not seem to be giving me any messages that I know of.

I’ll try out the various other suggestions on Monday, to see if this gets me any further forward. 

Thanks for the pointers. I will let you know if I make any progress...
 

Link to post
Share on other sites

Problem resolved, thanks to the above help. A basic error in that mod-rewrite was not enabled.

Did not prove straightforward to enable it in the Alpine image I was using, but one of the provided links pointed me to several Docker containers that are already set up for pw. Using the joyofpw/docker container instead of the one I was using got me going within a few minutes.

Many thanks for all the help.

  • Like 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...