Jump to content

Forum Upgrades


Recommended Posts

Hey, the forum looks great! I love some fresh colours. However, it's one tiny thing that bothers me. I was used to browse the forum with javascript disabled, especially on the mobile. This has some drawbacks, but the page is loaded faster and, most importantly (for me), was that I could see the complete lists of last posts, without any text cut off, at a glance. In the previous forum version, text cut off was made with javascript, and now it's done on the server-side. 

Link to comment
Share on other sites

2 hours ago, matjazp said:

Hey, the forum looks great! I love some fresh colours. However, it's one tiny thing that bothers me. I was used to browse the forum with javascript disabled, especially on the mobile. This has some drawbacks, but the page is loaded faster and, most importantly (for me), was that I could see the complete lists of last posts, without any text cut off, at a glance. In the previous forum version, text cut off was made with javascript, and now it's done on the server-side. 

Ah well unfortunately I won't be able to do anything about that.

They do now have an app but I'm not sure if there's value in adding us to it - theoretically that would run faster but probably wouldn't solve your issue.

Link to comment
Share on other sites

Maybe a little off-topic, but while we are speaking about javascript: is there any particular reason why Stripe is loaded on every forum page instead of just checkout page? Seems redundant, but maybe I'm not seeing the whole picture here.

  • Like 2
Link to comment
Share on other sites

On 5/21/2021 at 2:31 PM, matjazp said:

Thanks Pete. Is it somehow possible to try this app?

We'd have to submit the forum to their app to get it included. I'm not sure what the process is exactly but you do lose navigation to the rest of the site - it basically just shows the common parts of the forum and throws out any theme customisations from what I can tell.

On 5/21/2021 at 6:25 PM, johndoe said:

Maybe a little off-topic, but while we are speaking about javascript: is there any particular reason why Stripe is loaded on every forum page instead of just checkout page? Seems redundant, but maybe I'm not seeing the whole picture here.

No idea. Maybe when you add stuff to the basket it allows you to complete the purchase from anywhere, but you'd think even if you paid via a modal it would just load when the modal loads 🤷🏻‍♂️

There is JS and CSS hooked in from the main site too in a very basic fashion to make theme upgrades simple (like we're including all of UIKit for the header) so not sure if it's from there but I don't imagine it is.

Like I say, it largely "is what it is" with each upgrade because they like to change things every so often.

Link to comment
Share on other sites

The email notifications for subscribed topics now seem to be truncated when they used to include the full post.

2021-05-23_195114.png.c9c63aa5927c76ba343dad548af888ea.png

@Pete, is it possible to change a setting so that emails are not truncated?

  • Like 4
Link to comment
Share on other sites

There used to be a "solved" feature we do not have anymore but with this last upgrade somehow it sneaked in again 🙂

members-solved-count.png.26f3b32e8933aed0c80754a4aa00c381.png

These Invision Community members love experimenting...

Link to comment
Share on other sites

Thank you for all your hard work on this

On 5/20/2021 at 6:01 PM, Ivan Gretsky said:

Forum looks cool after the update. Thanks, @Pete! But the topic titles in the list (and probably other stuff) became smaller and my 4 eyes are having trouble seeing 'em. Is it possible to scale fonts up a bit?

I agree with Ivan about typography, font is somehow thinner, sharpen, in some places smaller, breadcrumbs contrast, etc. Last theme for me has great readability (easier to read and easier to notice new things...). This theme is nice and attractive but probably my eyes not good like before and get tired quickly (probably that is my main problem 🙂).

I really appreciate who do all this job and thanks for that!

Best regards.

Link to comment
Share on other sites

On 5/23/2021 at 12:52 AM, Robin S said:

The email notifications for subscribed topics now seem to be truncated when they used to include the full post.

@Pete - I'd like to second this - is it an easy fix to show the full message in the email?

Thanks!

  • Like 2
Link to comment
Share on other sites

On 5/23/2021 at 8:52 AM, Robin S said:

The email notifications for subscribed topics now seem to be truncated when they used to include the full post.

@Pete, is it possible to change a setting so that emails are not truncated?

 

On 5/30/2021 at 11:59 PM, adrian said:

@Pete - I'd like to second this - is it an easy fix to show the full message in the email?

Thanks!

I found the setting for this and turned it off:

image.png

I get why they added it, but for some communities it makes more sense than others.

Personally I think they could have added a setting to control the truncate length to be a "best of both worlds" but switching it off is fine for this forum.

  • Like 5
Link to comment
Share on other sites

  • 3 weeks later...

@Pete, the reputation count seems to have disappeared (Ryan's is around 20K). Deliberate?

2021-06-24_115732.png.6cfc08d971ba4dfa1a4b6c5c36bdb924.png

Also, the rocket that is poking everyone in the face looks stupid. Can we lose that? Like, what exactly is a "hero" member anyway and does anyone really care about that status? 🤔

  • Like 6
Link to comment
Share on other sites

Hey @Pete... do you have an idea when we will have the reputation count back? The more I use the forum now, the more I somehow want it back as fast as possible. It's probably weird but... it was such a great indicator for a lot of things here.

And no... it's not about my silly amount of reputation points.

  • Like 3
Link to comment
Share on other sites

16 hours ago, wbmnfktr said:

Hey @Pete... do you have an idea when we will have the reputation count back? The more I use the forum now, the more I somehow want it back as fast as possible. It's probably weird but... it was such a great indicator for a lot of things here.

And no... it's not about my silly amount of reputation points.

Not sure why they removed it from the design flow, but you can easily hover any member's avatar to see it:

image.png

  • Like 1
Link to comment
Share on other sites

On 7/3/2021 at 12:41 AM, Pete said:

Not sure why they removed it from the design flow, but you can easily hover any member's avatar to see it

But this isn't a solution for touch devices which don't have a hover state, and we all know that touch devices are a big share of internet use.

There's discussion in the Invision Community support forums about how to bring back reputation points into the author pane (some of which I can't see but maybe @Pete can)...
https://invisioncommunity.com/forums/topic/462326-current-ranks-–-and-–-reputation/
https://invisioncommunity.com/forums/topic/462099-bring-back-reputation-in-userinfopane/
Could we implement that here?

Also, it would be nice to bring back custom member titles for those who had them (e.g. Ryan's reiska title):
https://invisioncommunity.com/forums/topic/462409-46-how-to-restore-custom-member-titles/

  • Like 6
  • Thanks 1
Link to comment
Share on other sites

+1001 (for permanent visible reputation count and for individual member titles like: captain earth, manager of expectations, ... etc.) 👍😊

  • Like 2
Link to comment
Share on other sites

I'll see what I can do about the rep count - in the meantime I've done something someone else asked for (and my older eyes needed) - increased font size on mobile.

I haven't gone too far with it but it's a lot better than 13px 😄 

  • Like 4
Link to comment
Share on other sites

  • 3 weeks later...

After every login I receive this mail:

Hi kaz,

You just logged in from a device we haven't seen you use before.

Browser and Mac are always identical …

Link to comment
Share on other sites

  • 1 month later...

Hi @Pete, could the minimum character count for the search on the forum please be reduced to 3 instead of (what I suspect) 4?

It's really impractical to not be able to search for words like 'api', or 'get', while you know for sure that there must be many results for those words.

  • Like 2
Link to comment
Share on other sites

1 hour ago, eelkenet said:

Hi @Pete, could the minimum character count for the search on the forum please be reduced to 3 instead of (what I suspect) 4?

It's really impractical to not be able to search for words like 'api', or 'get', while you know for sure that there must be many results for those words.

Wouldn't it be better using g**gle search for that?

searching forum:

site:processwire.com/talk api

(https://www.google.com/search?q=site%3Aprocesswire.com%2Ftalk+api)

searching whole site:

site:processwire.com/ api

(https://www.google.com/search?q=site%3Aprocesswire.com%2F+api)

  • Like 2
Link to comment
Share on other sites

On 7/30/2021 at 8:48 AM, kaz said:

After every login I receive this mail:

Hi kaz,

You just logged in from a device we haven't seen you use before.

Browser and Mac are always identical …

Sorry I'm not sure what that could even be. I don't think anyone else has reported that before.

Link to comment
Share on other sites

4 hours ago, eelkenet said:

Hi @Pete, could the minimum character count for the search on the forum please be reduced to 3 instead of (what I suspect) 4?

It's really impractical to not be able to search for words like 'api', or 'get', while you know for sure that there must be many results for those words.

I think we need to setup ElasticSearch for the search index as it's partly a limitation of the MySQL setup but also so searches don't overload the forum itself when people search for "the" etc (imagine if someone just wanted to slow the whole system down - you can do it fairly easily with 3 letter searches as it'll find a lot more matches even with flood control systems in place).

I'd like to get it setup eventually as Horst's suggestion works for public forums but for other parts like the Pro module forums it doesn't work there.

I thought we had it in place already actually but apparently not - I'll look into where we got up to with it.

  • Like 5
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...