Jump to content

Forum Upgrades


Recommended Posts

Hi all, 

The forums have just had a fairly major upgrade - everything seems brighter and cleaner though as always if you spot any areas we may have missed that don't look quite right (broken rather than different), please comment here.

  • Like 19
  • Thanks 1
Link to comment
Share on other sites

Thanks - I'll check that out. Just pushed a fix for mobile as the user menu was missing - I guess we need to keep that 🙂

  • Like 1
Link to comment
Share on other sites

27 minutes ago, adrian said:

Thanks for your work on this @Pete

One thing I noticed is pink on dark grey doesn't really work, eg: 

image.thumb.png.5179df0b2c0f4cff7ae9809d322833d6.png

Otherwise, looks great!

Fixed, thanks.

  • Like 2
Link to comment
Share on other sites

It's worth noting that there are now TFA options on your account for added security if you go to Account Settings > Security & Privacy. Likely not required for most people but if you want to add a little extra security to your account you now can.

image.png

  • Like 2
Link to comment
Share on other sites

3 minutes ago, ngrmm said:

i would say the name on a profile page lacks a bit of contrast

 

Fixed, thank you.

  • Like 2
Link to comment
Share on other sites

Thanks @monollonom - I think it might be a bit of a fluke but the new default colours in the software mostly match the ProcessWire site with just some minor tweaks anyway.

What browser/OS are you seeing that white space on? It seems alright on Windows+Chrome.

  • Like 1
Link to comment
Share on other sites

I'm on MacOS using Firefox. I know Firefox has its way of doing when it comes to some cases with margin-bottom...

Regarding colors: maybe a suggestion would be to set the blue for buttons / nav bar to a be a bit more blue-ish. Here I took the color from the (invisible) background of thumbnails (32, 115, 206) :

619702950_Capturedecran2021-05-18a22_08_29.thumb.png.6d69429cb689074773443e2d0a93e0ee.png822409055_Capturedecran2021-05-18a22_08_12.thumb.png.f6ecc25ccadbeeb0f4c77faf2d535860.png

Edit: wouldn't mind as well to have the left and right paddings to match the ones on the header (40px left/right). And sorry for throwing you css details !

1712123239_Capturedecran2021-05-18a22_18_43.thumb.png.ba5c22ab1ed06f0a4c4782223aba9208.png

  • Like 1
Link to comment
Share on other sites

I usually keep an eye on unread posts: https://processwire.com/talk/discover/unread/

Previously, when I clicked on the title of the topic, I was taken to the last unread post and that was very convenient. However, the new version just links to the first post, which is not very useful.

Currently the closest thing to do is to click on the "number of replies" link, but that takes me to the last post, and I need to scroll up to find the where the "Unread replies" begin.

Is there still a link that leads directly to the beginning of "Unread replies"? I need it badly 🙂

Also, some topics (maybe module support sections?) have a new "stats section" laid out as a new right column. This is a waste of space because the main column is narrower than full width, so a long topic has become even longer than before. This means a lot of extra scrolling from now on, which does not make me happy at all 😞

Code in this new narrow main column is mostly need horizontal scrolling just to see the content, and that is annoying. I also saw some fixed-width code text sticking out of the main column it for some reason.

I am not pleased with these changes at all, they are definitely not welcome. I hope Pete can sort these issues out.

  • Like 2
Link to comment
Share on other sites

2 minutes ago, szabesz said:

Is there still a link that leads directly to the beginning of "Unread replies"? I need it badly 🙂

I think I found it, the XYZ minutes/hours ago link might lead there. I just cannot test it currently 'cos I have run out of unread posts 🙂

  • Like 1
Link to comment
Share on other sites

59 minutes ago, szabesz said:

Previously, when I clicked on the title of the topic, I was taken to the last unread post and that was very convenient. However, the new version just links to the first post, which is not very useful.

I found this in Account Settings (click the user dropdown in the forum header):

2021-05-19_102641.png.ac3b78180f97c3d6e963328f2e837cb6.png

  • Like 4
Link to comment
Share on other sites

8 hours ago, Robin S said:

I found this in Account Settings (click the user dropdown in the forum header):

2021-05-19_102641.png.ac3b78180f97c3d6e963328f2e837cb6.png

They had added this as a new setting and, somewhat bizarrely, not set it to the most useful setting by default. I've changed it so the default is now what we were all used to so you shouldn't need to go and set that setting.

  • Like 4
Link to comment
Share on other sites

@szabesz can you link to an example of this right column? I can't see it though I wonder if Ryan or one of the moderators was perhaps playing with the block manager yesterday without realising it shows for all users (we had that happen a few years back accidentally too and I've not found a setting to turn if off yet 🙂 ).

My one complaint with forum software (most big forum software really) is that they need to stay relevant in a world where social media dominates so they add new features and don't always think about what the default setting should be (see my previous post - hopefully that one is sorted) and they do like to move the settings around in the admin so we spend a little while every year or so learning where things are. Mostly though the improvements are usually good, but we don't have the luxury we have with ProcessWire of not upgrading so there will always be these little pain points every so often.

  • Like 1
Link to comment
Share on other sites

Another new feature - you can also switch to a card view (less useful) and this "fluid view" which may be more useful to those of you who use the activity feed in that you can select forums to filter by on the main forum homepage and have all the topics appear in a list. I've not used it so I'm not sure how useful it really is, but it's an option.

image.png

  • Like 2
Link to comment
Share on other sites

Posted (edited)
9 hours ago, Robin S said:

I found this in Account Settings (click the user dropdown in the forum header)

Thanks! Yes, the first option sets the URL to the same one  as the URL of the XYZ hour ago link.

31 minutes ago, Pete said:

I've changed it so the default is now what we were all used to so you shouldn't need to go and set that setting.

Thank you very much, Pete!

Some examples for the "right column" feature:

screenshots:

Spoiler

topic-with-sidebar-2.jpg.2e8d39d8412f821e6ba90289de31b549.jpg

topic-with-sidebar-1.thumb.jpg.eaa5986201bd5d0025c915605ab4a999.jpg

Looks like it is the long topics which get these stats feature added automatically perhaps? I am not sure how useful these stats are. This is more of a social media like feature you talked about, which is kinda irrelevant in our case, I think too. It just takes up space. I vote for turning it off, if possible.

Thanks in advance, Pete!

EDIT: It is not possible to use the scroll wheel of the mouse to get to "under" the spoiler, I had to position the cursor in the text above and use the arrow keys of the keyboard to edit anything below.

I wish the forum's developers spent more time on improving the RTE instead of anything else. Using the RTE is still a pita sometimes. I know that a JavaScript based RTE in the browser is the hardest thing to implement ever, but still... 🙂

Edited by szabesz
  • Like 1
Link to comment
Share on other sites

Thanks, I found the setting to turn off topic stats - not sure why anyone thought that was a useful feature but it seemed to be a global setting that triggered under certain scenarios 😄

I won't be able to change things like scroll wheel without digging into the JS so that's not something I'll be able to solve unfortunately. Their code is a little impenetrable (to me at least) whenever I try to read it so I try and stick to simple template updates in this software. I'm a bit of a JS noob in that I'm happy with jQuery but I don't fully understand JS classes yet and am rusty with vanilla JS - though it's definitely time I learned.

The RTE as far as I'm aware is a modded CKEditor. They did used to use their own a few years back but it was a big project on its own just to manage it, but yes there is room for improvement in some areas I agree.

  • Like 2
Link to comment
Share on other sites

Posted (edited)

Hey @Pete! Not sure if this has changed recently, but just noticed that http://processwire.com/talk/ works as well. Should/could this redirect to the HTTPS version instead?

Unrelated note regarding moderator actions: I'm pretty sure that flagging someone as a spammer used to hide their posts. Doesn't seem to work that way anymore. Also I seem to recall there being some sort of limit to what new users can post. Am I wrong or did something change regarding this/these? 🙂

Edited by teppo
  • Like 1
Link to comment
Share on other sites

11 minutes ago, wbmnfktr said:

does this forum software support/provide a native dark theme?

Great question! I am also interested. I've been browsing the Forum with Dark Reader for years but a native solution is usually better.

  • Like 1
Link to comment
Share on other sites

11 hours ago, wbmnfktr said:

Thank you, @Pete for maintaining the forum!

Just a question not only out of curiosity but... does this forum software support/provide a native dark theme?

 

11 hours ago, szabesz said:

Great question! I am also interested. I've been browsing the Forum with Dark Reader for years but a native solution is usually better.

They do, but only in the admin unfortunately. There are quite a few "marketplace" dark themes but they do vary in quality and I'd prefer something supported directly by the Devs that switches based on your device preferences (the admin theme for example is dark on my smartphone automatically). Maybe that will come in a future release, I'm not sure.

  • Like 2
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...