Jump to content

TextFormatterVideoEmbed


Warran
 Share

Recommended Posts

Hi,

I'm having an issue with TextFormatterVideoEmbed. Never had any problems with this before but it's not picking up the Youtube or Vmeo urls when it's in <p> tags, as it should do. Has anyone experienced this too?

I'm using PW v3.0.165, TextFormatterVideoEmbed v1.1.1 in CKEditor (core within PW 3.0.165).

Thanks

Warran

Link to comment
Share on other sites

Hi Adrian

Thanks for you reply. Could be, I'll take a look. 

Yes. The module looks for either a Youtube or Vimeo url between <p> tags and knows to output it as an embedded video. This isn't happening. It just outputs the url as plain text.

I'll have a look at the module.

Thanks again.

Link to comment
Share on other sites

  • 1 month later...
  • 2 months later...
Posted (edited)

Having strange issues with this one as well. The field is 'body' and it has the TextformatterVideoEmbed option.

On the same page, I have the YT URL in the page's body field. It outputs the URL.

Below it, I have a Repeater Matrix field with the same body field and content and it outputs the video.

Any ideas?

Edit:

I have found a cause but not the fix. My code is:

<?php 
	$featured = false;
	if ($page->hasField('images') && $page->images->count > 0) {
        $featured = $page->images->last;
        $description = !empty($featured->description) ? $featured->description : $page->get("headline|title");
    }

	// ...
?>


<?php if (!empty($page->body)) : ?>
  <div class="main__body owllob">
    <?php if ($featured != false) : ?>
      <img class="main__feature-img" loading="lazy" src="<?=$featured->width(300)->webp()->url?>" alt="<?=$description?>" />
    <?php endif; ?>

    <?=$page->body?>
  </div>
<?php endif; ?>

When I include a 'featured' image and even though it renders separately to the body field, the YT URL does not convert.

When I delete the image, it does and the video shows/plays as expected???

Screen Shot 2021-07-08 at 24952 pm.png

Screen Shot 2021-07-08 at 25021 pm.png

Edited by psy
more info
Link to comment
Share on other sites

Are you using the latest version of TextFormatterVideoEmbed 2.0.2 ?

Is 'body' a CKEditor field? Also is the YT URL within <p> tags? Pretty obvious things but worth checking. 

Link to comment
Share on other sites

@Warran Yes, yes and yes

As in my original post, both the page & repeater matrix field use the 'body' field. It's a textarea with CKEditor + TextformatterVideoEmbed and the body content source code is the same

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...