Jump to content

After redircts modul install MarkupPwpswpGallery not working anymore


Recommended Posts

Hi all,

I'm fighting with a strange problem. On a processwire installation I've tried to install https://processwire.com/modules/process-redirects/ which ended in a json error. A refresh quitted with an error 500. Even after deleting the redirects module via FTP the error 500 persisted. After enabling debug  in settings following output is shown:


Strange as the Gallery module worked for years without problems. What I do not understand is why the class cannot be found. it is there ? 

This is how it's called in `MarkupPwpswpGalleryLegacy.module`

`class MarkupPwpswpGalleryFlex extends MarkupPwpswpGallery implements Module {`

and on the same level in `MarkupPwpswpGallery.module`

`class MarkupPwpswpGallery extends WireData implements Module {`

My guess is it has something todo with the php 7.0 version the server runs with and namespaces (did not change between module installations). To get rid of this nasty situation I've just tried to reinstall the gallery but this one fails as requirement 7.0 >= 5.6PHP is not met (why? 7 is bigger as 5.6?) Anyways any tipp to get it running again is much appreciated! 

Link to comment
Share on other sites

  • 1 month later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...