Jump to content
typ9

CKEditor: justify-options always set in toolbar

Recommended Posts

In the textfields we implement with CKEditor we cannot deactivate the JustifyBlock etc. options.

I attached screenshots that show the Toolbar settings and the output.

I found out that I can remove the whole Justify-Plugin, then none of the Justify options appear.

My goal would be to offer the JustifyRight, JustifyCenter and JustifyLeft option,
but remove the JustifyBlock option...
I don't have any clue how to achieve that!

Do you maybe have an idea?

Bildschirmfoto 2021-01-22 um 12.42.23.png

Bildschirmfoto 2021-01-22 um 12.43.44.png

Share this post


Link to post
Share on other sites

Are you doing something like adding the Justify plugin yourself? If so, you don't need to do that because it's already included in PW's InputfieldCKEditor by default.

You can specify the individual justify toolbar items you want:

2021-01-23_100534.png.a5f0b604b2c386bdec360a0ea1b2a0af.png

2021-01-23_100624.png.add1bb2ef4c73db0b50bbb451c165d48.png

  • Like 1

Share this post


Link to post
Share on other sites

No, unfortunately I don't think that this is the solution. With the whole "wire" directory as we get it by download, the problem already occurs.
If I for example add JustifyCenter manually to the toolbar, I happens to show up twice!

Bildschirmfoto 2021-01-23 um 16.34.27.png

Bildschirmfoto 2021-01-23 um 16.33.37.png

Share this post


Link to post
Share on other sites

Maybe there are some settings at another place where we somehow by mistake add the Justify options to the toolbar by default? But I cannot find it anywhere...

Share this post


Link to post
Share on other sites
18 hours ago, typ9 said:

But I cannot find it anywhere...

Are you using AOS? (AdminOnSteroids module) It enables to configure a lot in regard of CKE.

  • Like 2
  • Thanks 1

Share this post


Link to post
Share on other sites

Yes, thanks a lot, that was the solution!!!
In AdminOnSteroids, there is a submodule CKEaddons, and there we had the Justify Plugin enabled!

Thanks a lot for your help, @horst!!!

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...