Jump to content
cyberderf

New local install. Index / frontpage shows correctly, but not the admin page

Recommended Posts

Just installed locally on Windows 10 and MAMP. Installation went fine, but not the admin page. I used a virtualhost and load my site like this: local.mywebsite.com. Frontpage work fine, but httptp://local.mywebsite.com/processwire/gives a 404 error.

My virtualhost in MAMP apache config is set like that, and MAMP is running on port 80.

<VirtualHost *:80> 
DocumentRoot "C:\Users\Fred\sites\mywebsite" 
ServerName local.mywebsite.com
</VirtualHost>

I also added the following in windows hosts file, at the end:

127.0.0.1    local.mywebsite.com

Any idea why the admin page dont load?

Edit: if this could help, every other subpages dont works either. Ex. http://local.mywebsite.com/about/

Share this post


Link to post
Share on other sites

Hi @cyberderf,

Welcome to the forum.

It seems like a url rewrite problem.

Please check the following:

1. Does .htacccess file exist in your web root folder. You need to rename the htaccess.txt file to .htaccess.

2. Check your apache conf file and see if mod_rewrite is enabled.

Gideon

  • Like 2

Share this post


Link to post
Share on other sites

For the record I finally ended just adding this to MAMP httpd.conf , restarted MAMP/Apache and it works:

<Directory "C:\Users\Fred\sites\mywebsite">
        AllowOverride All
/Directory>

Thanks for help!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...