Jump to content
u-nikos

Module: ProcessDateArchiver

Recommended Posts

Using ProcessDateArchiver with PW 2.4.8 (dev). No problems found. I use a year and a month template.

Share this post


Link to post
Share on other sites

Hi there,

anyone got this module working with PW 2.6.0?

everytime I create a new page with the template "article" under "News", my "News" container (and any other published page on the first level) will be deleted and replaced with the new container "2015"?

anyone experience something similar or know how to fix it ...maybe even a similar, up-to-date module for the same task?

XcUW6fC.jpghgxRAHp.jpg

TTqhXPp.jpg

Share this post


Link to post
Share on other sites

I've got this working on a local (MAMP) 2.6 install without any problems. Could it be that your year and month archive templates are the same? 

Share this post


Link to post
Share on other sites

thanks, Marty

created a new template as container for month & year and it seems to work, although the urls look like this:

EaXyYDV.jpg

any ideas? how is your date field set up?

cheers, j

Share this post


Link to post
Share on other sites

On the setup I use this on my date field (publish_date) is setup to output only dates (no times) as: April 8, 2012. I haven't used this with a multi-language setup either so I'm not sure if that has anything to do with it.

Screen-Shot-2015-05-18-14-53-31.png

My 'news-archive.php' template just lists the child pages of the year url I'm in.

Share this post


Link to post
Share on other sites

thanks,

hmmm, damn ...might be

I haven't used this with a multi-language setup either so I'm not sure if that has anything to do with it.

my date field is set up like this:

Igthulx.jpg

bOsWC38.jpg

Share this post


Link to post
Share on other sites

Actually I am seeing this behaviour on another install where I have 'name format for children' set as title in the parent template.

Share this post


Link to post
Share on other sites

Hey Marty,

just checked again and it seems to work :)

not sure what I changed though, 'name format for children' was left blank all the time.

Share this post


Link to post
Share on other sites

I seems I'm having a similar situation.

the post eg. /2016/08/01/article-post
is being saved to /2016/08/01/article-post-2
and after saving again it's being renamed to /2016/08/01/article-post

I was mentioned before, it's not really compatible for 2.7 but I was wondering if there might be an update available, or not...

 

Share this post


Link to post
Share on other sites

What happened to field "The date field to archive on" (see below). It's not editable in PW3.

 image.png.e19a45f902c1a3ced5678ec53c5de5cc.png

Edited by flod
more infos

Share this post


Link to post
Share on other sites

can someone please help me. I´m using this module in the PW 3.. and its working as it should. I have a jobboard and when the pages gets archived i want them to be unpublished, is that possible?

Share this post


Link to post
Share on other sites

hello this is my first time using this module, work great but I'm not sure how should my year, month templates look like. My php is not so good, would appreciate some help here.

I would like to post some articles from that "month, year", maybe a title an image and some short text.

my year template name is blog-articlelist-year.php and month blog-articlelist-month.php

Thank you very much

R

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...