Jump to content
ryan

Weekly update – 13 November 2020

Recommended Posts

This week I’ve been continuing to work on the new ProcessWire modules directory, this time focusing on the front-end editing aspects for module authors. This is the part that deviates the most from the existing modules directory (and makes revolutionary improvements upon it), so none of this is on the production server yet, and it’s going to take a little more time to develop. LoginRegisterPro and FormBuilder are saving a lot of time in the development. LoginRegisterPro handles the account management side, while all module editing forms are powered by FormBuilder. By next week I’m hoping I might be able to launch the new editing features so that module authors can begin to use the system, but we’ll see how it goes. This week there have also been several updates to the core dev branch, including both improvements and issue fixes. By next week I also expect to bump the version to 3.0.169. For more on the modules directory improvements, be sure to also see last week’s post
 

  • Like 15

Share this post


Link to post
Share on other sites

Little feedback on the module pages.

1) Search does not seem to include the header in the results (e.g. searching "Admin Action" does not find ProcessAdminActions module). Is this because there's just one giant textarea field that includes all the text in the main content area?

2) It's not immediately clear what the modules classname is. In the old version it was clearly marked, on the new page you have to know it's the heading on the blue. It might be a good idea to add this in a clear way on the right hand bar or somewhere else where people new to PW will easily find it when they're looking to install modules.

3) Googling for modules will lead you to pages that don't work anymore (https://modules.processwire.com/modules/process-admin-actions/)

 

Share this post


Link to post
Share on other sites

@MSP01

Thanks for the feedback.

1. I couldn't duplicate that, when searching "admin action" it does find ProcessAdminActions for me at least. Though several days have passed so maybe Adrian recently updated something in the module info that makes it match. 

2. The class name is the primary headline. But someone else mentioned this too, I will add something else that specifically indicates it.

3. I also can't seem to duplicate this. Those pages should be redirecting to the new modules directory URLs. Maybe it got stuck on that one for one reason or another. I have cleared the caches just in case. 

  • Like 1

Share this post


Link to post
Share on other sites

1) Works for me also and I haven't made any changes for over a month.

image.png.f598c7848a705679399d4f2c9c408a4a.png

2) I agree that an explicit classname section would be a nice improvement.

3) Also no problem here - it redirects as expected.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...