Jump to content
KG Euroregion

ProCache nt working - always creates new files

Recommended Posts

I've been searching the web a lot and nobody seems to have this problem: I'm using ProCache (3.1.4) on Processwire 3.0.165, but it doesn't seem to work. It always creates and delivers a new HTML file, despite the existing one in the cache. I'm logged out from Processwire, use even another browser. The license key is for the developer version, so it should work with any website. All templates are checked to be cached and the cache files are properly created, but not used. What could be a solution for that?

Share this post


Link to post
Share on other sites

Moderator note: this is not the VIP ProCache module support thread, so I'm moving it to the General Support area of the forum instead. Please keep in mind that the Modules/Plugins area is only intended for non-commercial module-specific support threads. If you don't have access to the VIP ProCache module support thread, please send a PM to @ryan and he can help you gain access. Thanks!

 

Share this post


Link to post
Share on other sites
On 9/26/2020 at 6:26 PM, KG Euroregion said:

What could be a solution for that?

Have you also checked the entries in the root .htaccess file, if they are correct?

Share this post


Link to post
Share on other sites

Well, the ProCache admin screen says "The .htaccess file looks good for cached page delivery." And "Allow ProCache to update .htaccess file automatically?" is switched on.

The lines concerning ProCache are the following:

# --- ProCache Manual Directives from 2020-05-22 22:19:39 ---------------------------------------
  # PROCACHE xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
  RewriteCond %{REQUEST_METHOD} !=POST
  RewriteCond %{QUERY_STRING} !.*=.*
  RewriteCond %{HTTP_COOKIE} !^.*(wire_challenge).*$
  RewriteCond %{DOCUMENT_ROOT}/site/assets/ProCache-[......]/$1/index.html -f
  RewriteRule ^(.*) %{DOCUMENT_ROOT}/site/assets/ProCache-[......]/$1/index.html [L]
  # /PROCACHE
  # If using UTF8 page names update the line below consistent with your $config->pageNameWhitelist
  # or copy the existing uncommented line from the PW-PAGENAME section of your .htaccess file.
  RewriteCond %{REQUEST_URI} "^/~?[-_.a-zA-Z0-9/]*$"
  # --- End ProCache Manual Directives ------------------------------------------------------------

Do they look fine to you? They just seem to reflect the settings on the ProCache admin tabs. Is there anything else needed?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...