Jump to content
DrQuincy

Repeater required if…

Recommended Posts

When using a repeater Visible if… seems to work but not Required if…

So, I have a Select drop down in the repeater (foo) and I only want a field to be required if this drop down equals a certain value (6). So, I put in the Required if box foo=6 and it seems to treat it as a required field regardless  of the value of foo. Is this some kind of limitation with repeaters?

Thanks.

Share this post


Link to post
Share on other sites
11 hours ago, DrQuincy said:

Is this some kind of limitation with repeaters?

Yes. The admin warns you about this when you define a "required if" condition for a field inside a Repeater:

2020-06-27_102410.thumb.png.a53e8d2139e4f77df9fb69c8aa953776.png

@ryan, it would be nice though if this limitation was mentioned in the relevant section of the inputfield dependency documention.

More information:

https://github.com/processwire/processwire-requests/issues/262

  • Like 1

Share this post


Link to post
Share on other sites

Thanks Robin. It's not a big deal but good to know it's not me doing it wrong.

Does the ProFields plugin bring this functionality? I did read something that implied this in another post but I thought ProFields added new fields rather than enhanced existing ones.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...