Jump to content
Nik Groningen

Installation does not complete on namecheap server

Recommended Posts

Hi,

Currently I'm developing a platform and use Processwire for some of the backend. Everything is working very well on localhost, but the installation on namecheap does not complete. I've read some comments on this forum that mentioned hosting on namecheap (without mentioning issues). 

Attached is a screenshot of the last step of the installation. It looks very similar to the problem mentioned in this thread: https://processwire.com/talk/topic/15516-processwire-do-not-complete-installation/. Unfortunately, this didn't help me. I also attached a picture of the server. In the error_log, i do get some error messages related to includes and requires like:

[18-Jun-2020 03:42:32 America/New_York] PHP Fatal error:  require(): Failed opening required '/home/niklcicr/public_html/wire/config.php' (include_path='.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php') in /home/niklcicr/public_html/wire/core/ProcessWire.php on line 1199

On the last screen, the console outputs a internal server error 500.

That's what I tried: Installation on another server (freeinfinity) and it worked fine, installation on another namecheap account (did not work), and I adjusted the .htaccess file according to other threads in this forum that had similar problems (did not work).

Is there anyone who got Processwire to work on namecheap hosting or can point me in the right direction? 

Thanks in advance,

Nik

pw.PNG

server.PNG

Share this post


Link to post
Share on other sites
[18-Jun-2020 03:42:32 America/New_York] PHP Fatal error:  require(): Failed opening required '/home/niklcicr/public_html/wire/config.php' (include_path='.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php') in /home/niklcicr/public_html/wire/core/ProcessWire.php on line 1199

I don't have an answer to you, sadly, but looking at the post you linked to, this seems like a different issue. In that other case the problem was that the host only had 32MB of memory available, which wasn't enough to actually run (or even install) the system.

In this case it seems that PHP is unable to include the config file. I would start by making sure that it actually exists in the path mentioned above. If it does, it could be a permission issue: depending on the setup PHP may be running as some user that doesn't have access to this file.

Could also be something entirely different, so what I'd really suggest doing would be contacting support on the host in case they've got an idea what's going on.

Note: this is a little off-topic, but your host is running PHP 5.6.40. That's a very old version that hasn't received official security updates since January 2019, so I'd suggest updating to PHP 7, and preferably at least PHP 7.3. And if that's not possible on this host, it might be best to look for a new one... 🙂

  • Like 1

Share this post


Link to post
Share on other sites

Thanks for the reply teppo! 

You're right, i definitely should use php 7.3, I also tried that. I just developed the site on php 5.x and wanted to keep the settings as similar as possible. 

I'm talking to the namecheap support right now, if I can solve the issue with them I will post it here for future reference.

  • Like 4

Share this post


Link to post
Share on other sites

Unfortunately, the namecheap support was also not able to help me. Part of the response included:

"As we have checked, there are no issues on the server side. Please contact your website developer in order to resolve the issue.
Otherwise, please let us know how the issue should be fixed, and we will gladly help you." 😬

I wish I could have helped other users who run into the same issue. However, I think it's best for me to just switch the hosting provider for now. If anyone ran into the same issue and figured it out, I would still love to hear it!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By mushmush45
      Hi, 
      Could anyone advise me on the following system requirements, which I am missing for ProcessWire installation:
      DO (pdo_mysql) is required (for MySQL database)
      Fail: GD 2.0 or newer  Fail: JSON support ZipArchive support was not found. This is recommended, but not required to complete installation.    
    • By franciccio-ITALIANO
      Hi, I must change server provider.
      I don't want rewtrite all page and articles, what must I do?
      I download a database copy on my pc, and now?

      Thanks!!
    • By neosin
      During the install process I can never get to Step 4 for setting up an admin account.
      It creates the database and in the screen it shows it installed the database and imported the SQL
      and under that it shows "Profile Import" but nothing else.
      I have the same result with master & dev branch.
      I looked in the database and do not see a user table of any kind, unless it has some other name than "users"
    • By godmok
      Hi everyone,
      I can't get my head around this, so maybe someone can help: I want to know how install the dev branch of processwire with composer.
      I use laragon and the "quick create" function and there you can run composer like this: "composer create-project processwire/processwire %s". OK, this is working, so I will get the master branch from it, but how about dev? I found some examples for laravel on this question, but no luck with it. Here some examples:
      composer create-project processwire/processwire %s --prefer-dist --stability=dev composer create-project processwire/processwire:dev %s composer create-project processwire/processwire:dev %s --stability=dev composer create-project processwire/processwire:dev %s --prefer-dist --stability=dev composer create-project processwire/processwire:dev-master %s --prefer-dist --stability=dev composer create-project processwire/processwire:dev-branch %s --prefer-dist --stability=dev composer create-project processwire/processwire:@dev %s --prefer-dist --stability=dev and so on... Maybe someone got this already and would like to share?
    • By devlisa
      Hello. I'm not new to Processwire (I've been using it on a Mac environment for multiple site builds), but I am new to installing it on a Windows environment. I have unsuccessfully installed Processwire 3.0.62 both via downloaded zip file and GitHub on my Windows machine. The Site Installation Profile and Compatibility Checks are successful, and I am able to get past the MySql Database screen. However, this is where the installation process stops (step 3). The Test Database and Save Configuration screen says my database connection was successful and the configuration was saved to ./site/config.php and that's it, but I know from my ProcessWire experience I should also see fields for setting up the admin login etc. on this screen. I can't go any further after this. I've redone this process multiple times. I am running XAMPP, if that helps. Any clue what could be stopping the installation process?
×
×
  • Create New...