Jump to content

Formbuilder Embed Options Query


cosmicsafari
 Share

Recommended Posts

Hi all,

I have the same form on multiple pages, the idea being that I can populated a hidden field with a page specific value automatically.

I figured this should be reasonably straight forward but I can't seem to get the following to take effect.

<?php echo $forms->embed ('my-form-name', array('hidden_field_name' => '666')); ?>

No matter what I do, it never updates the default value currently set for said hidden field.

Feels like I'm missing something really obvious?

Any ideas?

Link to comment
Share on other sites

  • 3 weeks later...

Hey @cosmicsafari!

FormBuilder questions should really be posted to the VIP support area, which you should have access to if you've got a FormBuilder license. If you have bought the license yet still don't have access, you should contact Ryan so you can get it sorted out 🙂

I don't think I've ever used $forms->embed() in this way, but according to the docs you can pass in an array that overrides GET variables, while with render you can pass in an array of pre-populated values. These are different things, obviously, though it probably should work if you had configured your form so that values can be pre-populated using GET variables.

 

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...