Jump to content
stemalo

Installation failed

Recommended Posts

Tried to install processwire. Everything went fine until this appears:

Fatal Error: Uncaught Error: Call to a member function ready() on null in /............/public_html/processwire/wire/core/ProcessWire.php:692

This error message was shown because: Superuser has never logged in. Error has been logged.

Any idea to solve this?

 

 

Share this post


Link to post
Share on other sites

Hi @stemalo and welcome to the forums.

You don't provide any details about your setup so I can only give you a general search, "site:processwire.com/talk super user has never logged in". This returns quite a few results regarding this topic. Maybe you can post your results when you find the one that solves your issue.

Share this post


Link to post
Share on other sites

Till which step did you get? Is the setup completed? Did the error occur within the setup?

Share this post


Link to post
Share on other sites

Without further information it is like "fortune telling" 

Test your database connection. 

Share this post


Link to post
Share on other sites

Thanks for your quick answers. The installation process went fine, every steps were fullfilled. At the end I've got this message. Will try a new installation, maybe the error will disappear. Let you know.

Share this post


Link to post
Share on other sites

All good now. Second installation process was successfully. Now I'm ready for testing. I want to create a directory site for local artisans. And after viewing and testing  some other CMS I came to the conclusion that processwire will be the first choice and I think it's highly qualified for this case.  Hope do not regret this.

  • Like 2

Share this post


Link to post
Share on other sites
1 hour ago, stemalo said:

directory site for local artisans

A piece a cake! 😉

Share this post


Link to post
Share on other sites

A piece of cake for people knowing processwire well. Maybe for me hard work. But anyway. Can I ask a question: for building a directory I think ListerPro will be the right plugin for this to make the things easy. Is this right?

Share this post


Link to post
Share on other sites
2 hours ago, stemalo said:

A piece of cake for people knowing processwire well. Maybe for me hard work.

I believe what was meant was piece of cake for ProcessWire, i.e. ProcessWire can handle it 🙂 (in. reference to your "Hope do not regret this").

Welcome to the forums and ProcessWire 😄 

  • Thanks 1

Share this post


Link to post
Share on other sites
5 hours ago, kongondo said:

I believe what was meant was piece of cake for ProcessWire

Exactly..

Share this post


Link to post
Share on other sites
7 hours ago, stemalo said:

for building a directory

I suggest you check this website that Ryan created to show the potential of PW, you can see the Frontend, the Backend and the source code on Github:

https://processwire.com/about/demo/

  • Like 1

Share this post


Link to post
Share on other sites

Can I ask a question? After successful installation I want to install the Skyscraper profile from GitHub. But I'm not sure where to upload the files. All files into site/templates?

Share this post


Link to post
Share on other sites
4 minutes ago, stemalo said:

Skyscraper profile from GitHub.

 

4 minutes ago, stemalo said:

All files into site/templates?

No. Profiles don't work like that (some would say unfortunately). Profiles need to be included before you install ProcessWire so that they can be picked up by the installer.  

Share this post


Link to post
Share on other sites

Means I've to do a new installation. No problem. Will do so. But for this I've to include these files at site/templates?

Share this post


Link to post
Share on other sites
47 minutes ago, stemalo said:

Got it now. Thanks.

Cool! Let us know how it goes 🙂 .

Share this post


Link to post
Share on other sites

Did it already. Worked like a charme, without any problems. Now I'm ready for playing.

Share this post


Link to post
Share on other sites
1 hour ago, stemalo said:

Did it already. Worked like a charme, without any problems. Now I'm ready for playing.

Excellent! Glad you got it sorted. Happy coding 😄 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...