Jump to content

Pages showing 404 error

Peter Knight

Recommended Posts

Hi guys

is there a checklist of items I should consider for diagnosing a series of pages which display a 404 error?

Basically I have built a Blog and all my posts are under a folder called 'Posts'. Some of these pages successfully display while others display a 404 page. 

This is what I have confirmed so far...

1. All pages are within the same root folder 'Posts'
2. All pages have the same template and fields completed
3. All pages have the same properties under Settings > Who can access this page
4. Pages have no redirects in place
5. Pages have no special characters or anything funky in the URL slug

There are no errors showing in the log either so I am stuck 😕


Link to comment
Share on other sites

24 minutes ago, Peter Knight said:

is there a checklist of items I should consider for diagnosing a series of pages which display a 404 error?

Just to add on to your list:

  1. Is this happening for all users or just guests?
  2. Do you have any autoload modules in place that could be interfering?
  3. Do you have any hooks in place that could be interfering?
  4. Single or multi-lingual site?
  5. Tracy debugger errors?
  6. Changes to .htaccess, i.e. some rule getting matched?


I don't think it is mod_security since you can access some pages but not others..

Edited by kongondo
added more
Link to comment
Share on other sites

Thanks @kongondo

I found a fix for it although I don't understand the issue root cause.

Discovered that editing the page url slug fixes this. Even if I just add an extra letter. Once the page saves, I can view it.

Not wanting to have to do this manually to 50+ pages, I wondered what would happen if I changed the name (Settings > Name) of the parent for the 50 posts. That worked too and seems to have 'fixed' the 50 pages.

It must be something related to the Page Path History module or something similar.

  • Like 1
Link to comment
Share on other sites

@Peter Knight, I have experienced what I think is the same issue and discovered the same quick fix as you did. I think it's caused by errors relating to the expanded file and image field properties feature and I'm trying to narrow down the exact cause so I can open a GitHub issue. To check if what you're experiencing is the same as my issue...

1. Are you running one of the latest dev versions - 3.0.154 or 3.0.155?

2. Did you create everything from scratch inside the PW version you are running now, or did you update a site that was running an older PW version, or perhaps install using a site profile that was created under an older PW version?

3. Have you seen any error messages relating to image fields when you create a new page? E.g. something about a column not found such as modified_users_id

4. Do you have the PagePaths core module installed?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Similar Content

    • By horst
      I want to hook into the 404 handling of PW at the most earliest stage. Pleas can anybody point me to the hook or file that suits this best?
    • By dweeda
      I installed an SSL Certificate, then edited my .htaccess file:
        # -----------------------------------------------------------------------------------------------
        # 9. If you only want to allow HTTPS, uncomment the RewriteCond and RewriteRule lines below.
        # -----------------------------------------------------------------------------------------------
        RewriteCond %{HTTPS} off
        RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
      by uncommenting out the Rewrite lines.
      Now I get 404 error pages when I try go to any .../processwire-master/<pagename>/
      This includes my admin page at .../processwire-master/processwire/, so i can't get into my admin.
      What else do I need to do?
    • By joeck
      Hi Guys,
      I'm trying to do my first migration to the customers existing server (IIS 10) . I ran the site as a subdirectory on my website for test purposes (everything works fine).
      Following the tutorial of Joss, I tryed the site on a local xampp server to make sure, it also works on a root directory. So far so good, everything works.
      Now I moved the files (from the xampp) to the customers server. The root/index page is shown but for every subpage i get 404 Errors...
      Hence I followed the troubleshooting guide for not working URLs:
      On the first sight, the .htaccess file is not recognized, therefore I contacted the host support. They said, it is recognized but not all modules are supported in the processwire .htaccess file. I did the "öalskjfdoal" test in the .htaccess file and didn't get a 500 Error.... BUT the rewrite rule from the hosts support, to proof the file is read, DID work... The support claims, they do not provide debugging... so basically the .htaccess file is recognized and working, but not throwing any errors (for whatever reason).
      Working rewrite rule (from support):
      RewriteEngine On RewriteBase / RewriteRule ^test\.asp$ index.html [NC,L] RewriteRule ^test\.html$ konzept.html [NC,L] RewriteRule ^test2\.html$ team.html [NC,L] The support said, a couple modules are not supported in the htaccess file, the supported ones are listed here: http://www.helicontech.com/ape/ (I think mod_rewrite is supported)
      As I do not completely understand what exactly is happening in the htaccess file, I'm stuck. I tried all suggestions I found regarding this topic on the forum, but none of them solved the problem.
    • By vmo
      this has resolved.
      Thank you
    • By vmo
      I have a Processwire installation and when accessing any page it gives 404, page not found.
      The site is under development and until recent I just was developing the templates and right now I am developing the php and html into the templates files like home.php.
      The site was recently updated to the version 3.0.89 and I don't if it has something to do with the 404 error.
      Right now I do not have a clue about was happening,
      I appreciate if any one have a clue what it might being happening.
      Thank in advanced.
  • Create New...