Jump to content
benbyf

FormBuilder Strange behaviour

Recommended Posts

I have a a form in my site footer that can be accessed anywhere on site, I've added the form in the _inc.php file and added the render in the pages footer.php. However, this works well on the homepage e.g. you can submit said form and get a thank you on reload, doesnt work at all on other pages... Just lots like a fresh reload. Any thing im doing wrong here or ways to diagnose as there isn't an error log for formbuilder etc...?

Share this post


Link to post
Share on other sites

Are the other pages cached?

Share this post


Link to post
Share on other sites

None seem to be cached no.

Share this post


Link to post
Share on other sites

Are you talking about ethicalby.design? Because there the form’s action points to "./" regardless of the page you’re on, so if you only process the form submission on the home page, it should always be directed there, i. e. "/".

Share this post


Link to post
Share on other sites

Thanks, no it’s a client site but it has the same behaviour as the form is built by the form builder module not me 😞

Share this post


Link to post
Share on other sites

so works fine on the / and /apply/ pages respectively but not the /privileges/bvlgari/

http://supercarownerscircle.nicegrp.com/

Doesn't seem to submit correctly on that page as I'm unable to see anything in the $input variable 😞

Share this post


Link to post
Share on other sites

GRRRRRRRR ok found something that worked in the form settings for pages two levels deep i have to turn off Disable session tracking and CSRF protection? which must be getting in the way and disallowing everything. not sure how to get around this but might add a honey pot as replace meant... but either way I get LOTS of spam before sooooooo not great... gonna have to fob off FormBuilder at this rate

Share this post


Link to post
Share on other sites

I wonder if the latest version has soved some of this as I'm also getting errors when using the spam filtering 😞

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By 999design
      Hi all,
      Running into an odd error that I can't seem to get my head around.
      We have 2 separately created Formbuilder forms sitting on a single page.
      But we keep experiencing weird results with them, originally we couldn't get one of the forms to ever submit so we ended up disabling CSRF for them which let us get around this issue.
      However it then causes a problem in that with CSRF disabled, one of forms always records 2 entries on submission. Just a straight duplicate within the entries for that form.
      So trying to stop this happening we tried enabling CSRF again and although that does stop the duplicated entry, it ends up giving really weird feedback such as the attached screengrab.
      Hazarding a guess I assume whatever is trigger on submission is firing twice because of the presence of the second form, but I have no idea why this would be the case as they are 2 seperately named forms?
      Any ideas?

    • By cosmicsafari
      Hi all,
      I have the same form on multiple pages, the idea being that I can populated a hidden field with a page specific value automatically.
      I figured this should be reasonably straight forward but I can't seem to get the following to take effect.
      <?php echo $forms->embed ('my-form-name', array('hidden_field_name' => '666')); ?> No matter what I do, it never updates the default value currently set for said hidden field.
      Feels like I'm missing something really obvious?
      Any ideas?
    • By neophron
      Hi,
      I hope, this is the right place for questions about the Formbuilder (I couldn't find in the ProField support a subsection for the Formbuilder).
      A client needs for his website a random generator of a code (as winning numbers). This generator should be placed in a simple form (name and email) and a random generated code should be visible there.
      This code, or winning number, must be stored in the db together with the name and email. And the participant must receive a confirmation email with this code.
      I know, that the Formbuilder can store and send data to the user. But what about a random generated code? Is this a hook job?
      I found this module: http://modules.processwire.com/modules/process-field-generator/ but it's not for PW 3. 
    • By prestoav
      Hi folks.
      I'm building a Formbuilder form to create new advert pages in a marketplace. Formbuilder is ideal for this. I need to add a description field that allows text to be added with line breaks etc. so showing a CKEditor field would be ideal (i.e. exactly like the field I'm typing into right now)!.
      Does anyone know if it's possible to add a CKEditor field to the front end presentation fo a Formbuilder field, maybe via a module or such?
      Many thanks!
×
×
  • Create New...